Raised This Month: $ Target: $400
 0% 

SteamTools (v1.2.0)


Post New Thread Reply   
 
Thread Tools Display Modes
gabuch2
AlliedModders Donor
Join Date: Mar 2011
Location: Chile
Old 05-23-2017 , 18:32   Re: SteamTools (v1.1)
Reply With Quote #61

Quote:
Originally Posted by Arkshine View Post
Then I don't know. I can't reproduce.

Did you updated manually libsteam_api.so? Actually, can you attach it here?
What OS exactly?
Do you have SELinux enabled or similar security software? If so can you disable it temporarily to see if it helps?

I tried under debian/ubuntu without issues. I hope you are not going to say CentOS, there is always trouble with this OS ahah.
PHP Code:
         _,met$$$$$gg.           REDACTED
      
,g$$$$$$$$$$$$$$$P.        OSDebian 8.7 jessie
    
,g$$P""       """Y$$.".      Kernelx86_64 Linux 3.16.0-4-amd64
   
,$$P'              `$$$.      Uptime: 83d 1h 28m
  '
,$$P       ,ggs.     `$$b:    Packages: 778
  
`d$$'     ,$P"'   .    $$$     Shellbash 4.3.30
   
$$P      d$'     ,    $$P     CPU: Virtual CPU a7769a6388d5 @ 2.4GHz
   $$:      $$.   -    ,d$$'     
RAM1957MB 3965MB
   
$$\;      Y$b._   _,d$P'
   Y$$.    `.`"Y$$$$P"'
   
`$$b      "-.__
    
`Y$$
     `
Y$$.
       
`$$b.
         `
Y$$b.
            
`"Y$b._
                `"""" 
File related: libsteam_api.so
Attached Files
File Type: so libsteam_api.so (74.3 KB, 252 views)
__________________
gabuch2 is offline
Arkshine
AMX Mod X Plugin Approver
Join Date: Oct 2005
Old 05-23-2017 , 18:37   Re: SteamTools (v1.1)
Reply With Quote #62

I've updated my post above.
__________________

Last edited by Arkshine; 05-23-2017 at 18:38.
Arkshine is offline
gabuch2
AlliedModders Donor
Join Date: Mar 2011
Location: Chile
Old 05-23-2017 , 21:07   Re: SteamTools (v1.1)
Reply With Quote #63

Code:
unIP = 757114009, usPort = 26900, usGamePort = 27123, usQueryPort = 65535, eServerMode = 3, pchVersionString = 1.1.2.2/Stdio
__________________

Last edited by gabuch2; 05-24-2017 at 10:09.
gabuch2 is offline
Arkshine
AMX Mod X Plugin Approver
Join Date: Oct 2005
Old 05-24-2017 , 06:56   Re: SteamTools (v1.1)
Reply With Quote #64

Honestly, I'm out of ideas.

- I've fixed the params in Hook_SteamGameServer_Init() and looking at the debug, the values seems correct
- I've fixed a potential issue if you're using SELinux
- I've tested on different OS without issues.

Really I don't understand.
Technically, the engine calls SteamGameServer_Init() in libsteam_api.so, then my module hooks this function (Hook_SteamGameServer_Init) and inside it calls the original function.

Code:
DETOUR_DECL_STATIC6(Hook_SteamGameServer_Init, bool, uint32, unIP, uint16, usPort, uint16, usGamePort, uint16, usQueryPort, EServerMode, eServerMode, const char*, pchVersionString)
{
	auto result = DETOUR_STATIC_CALL(Hook_SteamGameServer_Init)(unIP, usPort, usGamePort, usQueryPort, eServerMode, pchVersionString);
...
}
The code does nothing special, it simply hooks the function and calls the original function address as it is, then I do stuff afterward.
The crash happens when the original function SteamGameServer_Init is called from my module. Too bad there is no debug in libsteam_api.so, we could have figured out where it crashes. But to crash at this point, all I can think is either there is something wrong the function header (but afaik it's fixed now) or the way is hooked is problematic (can't confirm, can't reproduce).

Today, I've installed a new server (DigitalOcean) specifically with Debian 8.8 and 3.16.0-4-amd64 to try to match your OS, then whatever with the official engine or ReHLDS, the SteamTools module is loading as expected.

What is your host (vultr?)? Also, do you think it would be possible to give me a temporary access so I can look myself in your context, at this point all I can do is to try to figure out what is different. There is definitely something weird/wrong with your server.
__________________

Last edited by Arkshine; 05-24-2017 at 11:42.
Arkshine is offline
brlight
Senior Member
Join Date: Jun 2011
Old 05-27-2017 , 19:17   Re: SteamTools (v1.1)
Reply With Quote #65

I once have issues and it was the kernel I was using, perhaps you should give that a shot
brlight is offline
Arkshine
AMX Mod X Plugin Approver
Join Date: Oct 2005
Old 05-28-2017 , 05:23   Re: SteamTools (v1.1)
Reply With Quote #66

I tried on the same kernel as well. I tried different host, different OS, different kernel and could not reproduce the issue. At this point, all I can assume is there is something wrong with his installation.
__________________
Arkshine is offline
Arkshine
AMX Mod X Plugin Approver
Join Date: Oct 2005
Old 10-19-2017 , 15:13   Re: SteamTools (v1.2.0)
Reply With Quote #67

v1.2.0, a little update : https://github.com/Arkshine/SteamTools/releases/latest.
__________________
Arkshine is offline
Old 08-21-2019, 11:30
GoGetSomeSleep
This message has been deleted by GoGetSomeSleep. Reason: moderation
Old 08-23-2019, 13:54
salesforceautomation
This message has been deleted by Arkshine. Reason: spam
gabuch2
AlliedModders Donor
Join Date: Mar 2011
Location: Chile
Old 01-03-2023 , 15:49   Re: SteamTools (v1.2.0)
Reply With Quote #68

Is this still working? Steam Tools never seem to connect and the features are never available for use. Steam_SteamServersConnectFailure() and Steam_SteamServersDisconnected() are also never called and there's no related logs.
__________________
gabuch2 is offline
root88
Senior Member
Join Date: May 2016
Old 01-30-2024 , 09:12   Re: SteamTools (v1.2.0)
Reply With Quote #69

In case someone is looking why it segfaults on current hlds/cstrike version - you need an older steamclient.so, I've taken my from current CS: Source version and it works fine
__________________
root88 is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 15:12.


Powered by vBulletin®
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Theme made by Freecode