Raised This Month: $120 Target: $400
 30% 

SourceMod 1.7.2 and Metamod:Source 1.10.5 Released


Post New Thread Closed Thread   
 
Thread Tools Display Modes
Toledostoner
Junior Member
Join Date: May 2013
Old 06-04-2015 , 14:32   Re: SourceMod 1.7.2 and Metamod:Source 1.10.5 Released
#11

I have updated to 1.7.2 For Counter Strike Source , and everything works great except 1 thing ..... when I or any other admin brings up the admin menu every command is there except Ban. i went and looked at the admin_simple.ini and everything looks fine. any idea's? cause im stumped... please help, Thank-You.

Last edited by Toledostoner; 06-04-2015 at 14:42.
Toledostoner is offline
ocwoody
AlliedModders Donor
Join Date: Nov 2010
Location: huh
Old 06-04-2015 , 15:02   Re: SourceMod 1.7.2 and Metamod:Source 1.10.5 Released
#12

Quote:
Originally Posted by Toledostoner View Post
I have updated to 1.7.2 For Counter Strike Source , and everything works great except 1 thing ..... when I or any other admin brings up the admin menu every command is there except Ban. i went and looked at the admin_simple.ini and everything looks fine. any idea's? cause im stumped... please help, Thank-You.
Restart your server and the ban option should reappear. This happened because of sourcebans.
__________________

ocwoody is offline
Powerlord
AlliedModders Donor
Join Date: Jun 2008
Location: Seduce Me!
Old 06-04-2015 , 15:03   Re: SourceMod 1.7.2 and Metamod:Source 1.10.5 Released
#13

Admin menu items are controlled by the Permissions system. Do your admins have the d flag and/or sm_ban override?
__________________
Am I back? Well, we'll see.
Powerlord is offline
Toledostoner
Junior Member
Join Date: May 2013
Old 06-04-2015 , 15:42   Re: SourceMod 1.7.2 and Metamod:Source 1.10.5 Released
#14

I have restarted the server, and no luck. And Yes i have the D flags in place. that is why im so confused
Toledostoner is offline
zaerius
Junior Member
Join Date: Feb 2011
Old 06-04-2015 , 15:45   Re: SourceMod 1.7.2 and Metamod:Source 1.10.5 Released
#15

Quote:
Originally Posted by bombjack View Post
Hi,
Since the update of CS:GO a while ago, my server refuses to load SM. I've tried various combinations of MM/SM snapshot builds without luck and eventually gave up and thought "I'll wait for official release". Now that it's here, SM still does not load. This is what I see:

meta list
Listing 1 plugin:
[01] <FAILED>
meta load addons/sourcemod/bin/sourcemod_mm_i486
Failed to load plugin addons/sourcemod/bin/sourcemod_mm_i486 (/home/<username>/csgo_server/csgo/addons/sourcemod/bin/sourcemod.2.csgo.so: undefined symbol: _ZZ15GetBitForBitnumi13bitsForBitnum

Server is running on Linux and uses version "1.34.8.6/13486 6040 secure"

Any thoughts?
Hi I'm running a couple of CSGO servers on Linux fedora and I have the exact same issue as bombjack. Servers are up to date. I've tried a lot of MM and SM snapshot combinations but the result is always the same, MM runs fine but SM cannot load.
Code:
Plugin 1 is not loaded.
         File: /home/cstrike/servertest/csgo/fungo/csgo/addons/sourcemod/bin/sourcemod_mm_i486.so
Code:
 Failed to load plugin addons/sourcemod/bin/sourcemod_mm (/home/cstrike/servertest/csgo/fungo/csgo/addons/sourcemod/bin/sourcemod.2.csgo.so: undefined symbol: _ZZ15GetBitForBitnumiE13bitsForBitnum).
Srsly Im running out of ideas I've tried everything, I need help with this.

Last edited by zaerius; 06-04-2015 at 15:51.
zaerius is offline
bombjack
Junior Member
Join Date: Aug 2006
Old 06-05-2015 , 18:46   Re: SourceMod 1.7.2 and Metamod:Source 1.10.5 Released
#16

Quote:
Originally Posted by zaerius View Post
Hi I'm running a couple of CSGO servers on Linux fedora and I have the exact same issue as bombjack. Servers are up to date. I've tried a lot of MM and SM snapshot combinations but the result is always the same, MM runs fine but SM cannot load.
Code:
Plugin 1 is not loaded.
         File: /home/cstrike/servertest/csgo/fungo/csgo/addons/sourcemod/bin/sourcemod_mm_i486.so
Code:
 Failed to load plugin addons/sourcemod/bin/sourcemod_mm (/home/cstrike/servertest/csgo/fungo/csgo/addons/sourcemod/bin/sourcemod.2.csgo.so: undefined symbol: _ZZ15GetBitForBitnumiE13bitsForBitnum).
Srsly Im running out of ideas I've tried everything, I need help with this.
Which version of Fedora are you using? I installed cs:go together with MM and SM on an old laptop using Fedora 21: worked like charm! On my failing server I use Fedora 11 (painfully old, I know. But I have reasons to stay on that installation a.t.m.) I am re-installing cs:go from scratch right now, but it's taking forever to download. I'll get back with result as soon as I know if that helped.
bombjack is offline
Toledostoner
Junior Member
Join Date: May 2013
Old 06-06-2015 , 00:58   Re: SourceMod 1.7.2 and Metamod:Source 1.10.5 Released
#17

Still having troubles , No admin ban. All my admins, their flags include the "d" flag. And i have restarted the server several times including the auto daily restart, and its still not showing ban in the admin control panel. Please any suggestions would help...
Toledostoner is offline
asherkin
SourceMod Developer
Join Date: Aug 2009
Location: OnGameFrame()
Old 06-06-2015 , 08:38   Re: SourceMod 1.7.2 and Metamod:Source 1.10.5 Released
#18

Quote:
Originally Posted by Toledostoner View Post
Still having troubles , No admin ban. All my admins, their flags include the "d" flag. And i have restarted the server several times including the auto daily restart, and its still not showing ban in the admin control panel. Please any suggestions would help...
Try reading the error logs, you're probably missing the ban reasons file.
__________________
asherkin is offline
Toledostoner
Junior Member
Join Date: May 2013
Old 06-06-2015 , 14:31   Re: SourceMod 1.7.2 and Metamod:Source 1.10.5 Released
#19

Ban reason File?
Toledostoner is offline
bombjack
Junior Member
Join Date: Aug 2006
Old 06-06-2015 , 15:57   Re: SourceMod 1.7.2 and Metamod:Source 1.10.5 Released
#20

Quote:
Originally Posted by bombjack View Post
Which version of Fedora are you using? I installed cs:go together with MM and SM on an old laptop using Fedora 21: worked like charm! On my failing server I use Fedora 11 (painfully old, I know. But I have reasons to stay on that installation a.t.m.) I am re-installing cs:go from scratch right now, but it's taking forever to download. I'll get back with result as soon as I know if that helped.
I have now re-installed cs:go from scratch and it still does not work. I guess there are dependencies or similar that needs to be updated. I will have to live without SM until I get time to update Fedora.
bombjack is offline
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 23:43.


Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Theme made by Freecode