Raised This Month: $110 Target: $400
 27% 

./steamcmd.sh Error


Post New Thread Reply   
 
Thread Tools Display Modes
MegaBrutal
New Member
Join Date: Sep 2021
Location: Hungary
Old 09-26-2021 , 22:00   Re: ./steamcmd.sh Error
Reply With Quote #11

Ubuntu 19.10 Eoan Ermine is end-of-life and not supported anymore, so you should not use it.
After making proper backups, use "do-release-upgrade" to upgrade your system to Ubuntu 20.04 Focal Fossa. Luckily, 20.04 is an LTS (Long Term Support) release, so it's still supported today and you don't need to run subsequent release upgrades to get a supported version (as it would be necessary if you had 18.10, for example).

Many releases ago, I think like in 2016 with Ubuntu 16.04 Xenial Xerus, the apt-get command was changed to apt. The change is rooted in Debian, Ubuntu only inherited it. Though the apt-get command still works, it's recommended to be used in scripts. The change is favorable because it makes APT simpler, e.g. commands of apt-cache are also available under apt, so you don't need to remember what operations are done with apt-get or apt-cache.

As DJEarthQuake has pointed it out, the multiverse repository needs to be enabled, as steamcmd belongs to multiverse:
https://packages.ubuntu.com/focal/steamcmd

You also need the i386 (32-bit) architecture enabled on amd64 (64-bit) systems, because sadly SteamCMD and HLDS still don't have 64-bit builds so you need to use the 32-bit compatibility layer.

If still doesn't work:
  1. Check if the executable file the script wants to invoke exists (ls -l /root/SteamCMD/linux32/steamcmd).
  2. Check that it has executable permission (you should see the x characters in the permission flags, e.g. rwxr-x---, and obviously run as a user that has access to the file).
  3. Check that you have the required libraries to run it (ldd /root/SteamCMD/linux32/steamcmd). If you have libraries missing, you might need to install additional packages.
Also, NEVER run SteamCMD or HLDS as root (unless you have a solid excuse, for example it's confined in a container).
MegaBrutal is offline
kumarrsushil501
New Member
Join Date: Oct 2021
Old 10-21-2021 , 12:25   Re: ./steamcmd.sh Error
Reply With Quote #12

I have the same issue. Any tips for solution?
vidm.fun/vidmate/ mobdro

Last edited by kumarrsushil501; 10-27-2021 at 06:16.
kumarrsushil501 is offline
abdobiskra
Veteran Member
Join Date: Jul 2014
Location: Algeria
Old 10-21-2021 , 13:18   Re: ./steamcmd.sh Error
Reply With Quote #13

Quote:
Originally Posted by kumarrsushil501 View Post
I have the same issue. Any tips for solution?
try :
Code:
sudo apt-get install libc6:i386 -y
or
Code:
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install libc6:i386
sudo apt-get install -f
__________________

Last edited by abdobiskra; 10-21-2021 at 13:19.
abdobiskra is offline
Send a message via Skype™ to abdobiskra
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 16:49.


Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Theme made by Freecode