Raised This Month: $319 Target: $400
 79%   Almost there!

New podbot mm beta update


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
KWo
AMX Mod X Beta Tester
Join Date: Jul 2004
Location: Poland
Old 04-19-2016 , 15:14   New podbot mm beta update
Reply With Quote #1

After long time (about 3 years) I have updated a bit podbot mm. If somebody is interrested, please try out this version:
http://forums.bots-united.com/showpo...&postcount=568
It is called beta, but there shoudn't be any problem with server crashing. In my private opinion bots from this version are working better than from any previous "my" versions.
Any feedback (about bugs/strange behavior) please post at bots-united forum - here.
__________________
The Fullpack of podbot mm V3B22 - 24 apr 2012!!! is available here.
The All-In-One 3.2a package - 02 jun 2013 (AMX X 1.8.2 [with ATAC 3.0.1b , CSDM2.1.3c beta, CM OE 0.6.5, podbot mm V3B22c and mm 1.20) is available here.
The newest Beta V3B23a (rel. 28 august 2018!!!) is available here.
KWo is offline
Krtola
Veteran Member
Join Date: Oct 2013
Location: Serbia
Old 04-19-2016 , 16:20   Re: New podbot mm beta update
Reply With Quote #2

New update are solid,but to me it means nothing.
PodBot -1 bot,my online server has huge lag.
YAPB - 10 bots and no lag.
Krtola is offline
Send a message via Skype™ to Krtola
YuGiOhJCJ
Member
Join Date: Mar 2007
Old 08-25-2016 , 23:50   Re: New podbot mm beta update
Reply With Quote #3

Hello,

I am happy to see a new update of podbot_mm but on my Counter-Strike 1.6 Dedicated Server on Slackware 14.1, I am using:
  • ambuild-965f21beb316e9f693b5236a9b33903625d673f1 [1]
  • hlsdk-a0edb7792a96998d349325bebab8ea41ec5cb239 [2]
  • metamod-hl1-18a10db686702e8ae9e0fcb5b5febf8881dc9c2d [3]
  • amxmodx-e24b9548d43c2f0d09d394cc1884b6d171bd2790 [4]
The dependencies are:
  • metamod-hl1 depends on hlsdk
  • amxmodx depends on ambuild, hlsdk and metamod-hl1
Now, I am trying to build podbot_mm_src_v3B23 [5].
The dependencies are:
  • podbot_mm_src_v3B23 depends on hlsdk and metamod-hl1
The problem is that podbot_mm_src_v3B23 seems to depend on hlsdk and metamod-hl1, the official ones from metamod [6] instead of the ones from alliedmodders.

The result is that if I build with the ones from alliedmodders, I have this:
Code:
$ make
g++ -O2 -fomit-frame-pointer -march=i586 -mtune=i686 -fno-exceptions -fno-rtti -DNDEBUG -Dstricmp=strcasecmp -Dstrcmpi=strcasecmp -Wall -Wno-unknown-pragmas -DOPT_TYPE=\"optimized\" -fPIC -I. -I../metamod/metamod -I../hlsdk/multiplayer/engine -I../hlsdk/multiplayer/common -I../hlsdk/multiplayer/pm_shared -I../hlsdk/multiplayer/dlls -I../hlsdk/multiplayer  -DLINUX -o obj.linux/bot.o -c bot.cpp
In file included from bot.cpp:17:0:
bot_globals.h:25:20: fatal error: extdll.h: No such file or directory
 #include <extdll.h>
                    ^
compilation terminated.
make: *** [obj.linux/bot.o] Error 1
Indeed, in the alliedmodders version of hlsdk, the "extdll.h" header is here: hlsdk/dlls/extdll.h whereas it is elsewhere in the official metamod hlsdk.

I guess that if my amxmodx addon has been built with the alliedforum version of hlsdk but the podbot_mm addon is built with the official metamod hlsdk, then I will have problem of compatibility at runtime.

Is there a podbot_mm_src_v3B23 compatibility with hlsdk and metamod-hl1 from alliedmodders?

Thank you.
Best regards.

[1] https://github.com/alliedmodders/amb...33903625d673f1
[2] https://github.com/alliedmodders/hls...b8ea41ec5cb239
[3] https://github.com/alliedmodders/met...febf8881dc9c2d
[4] https://github.com/alliedmodders/amx...84b6d171bd2790
[5] http://filebase.bots-united.com/inde...ct=view&id=380
[6] http://metamod.org/

Last edited by YuGiOhJCJ; 08-25-2016 at 23:50.
YuGiOhJCJ is offline
Arkshine
AMX Mod X Plugin Approver
Join Date: Oct 2005
Old 08-26-2016 , 16:30   Re: New podbot mm beta update
Reply With Quote #4

If you're using the AM version, you need likely to adjust the include paths in makefile, since there is no "multiplayer" folder.
__________________
Arkshine is offline
YuGiOhJCJ
Member
Join Date: Mar 2007
Old 08-26-2016 , 23:37   Re: New podbot mm beta update
Reply With Quote #5

Quote:
Originally Posted by Arkshine View Post
If you're using the AM version, you need likely to adjust the include paths in makefile, since there is no "multiplayer" folder.
Done.
After that I got some other errors (path in makefile, and 'const' missing in dll.cpp and engine.cpp).
Here [1] is the full patch.
The build is a success and this podbot addon is working good on my server
[1] http://yugiohjcj.free.fr/podbot-mm-v3B23.patch

Last edited by YuGiOhJCJ; 08-27-2016 at 01:18.
YuGiOhJCJ is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:09.


Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Theme made by Freecode