Raised This Month: $214 Target: $400
 53% 

Lost connection to MySQL server at 'reading initial communication packet'


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
HiddenConn1
AlliedModders Donor
Join Date: Aug 2009
Location: Cambridge, UK
Old 11-03-2017 , 22:50   Lost connection to MySQL server at 'reading initial communication packet'
Reply With Quote #1

Code:
L 11/04/2017 - 02:43:58: [sourcebans.smx] Database failure: [2013]: Lost connection to MySQL server at 'reading initial communication packet', system error: 111. See FAQ: https://sarabveer.github.io/SourceBans-Fork/faq/
L 11/04/2017 - 02:43:58: [sourcecomms.smx] Connecting to database failed: [2013]: Lost connection to MySQL server at 'reading initial communication packet', system error: 111
L 11/04/2017 - 02:43:58: [SourceSleuth.smx] SourceSleuth: Database connection error: [2013]: Lost connection to MySQL server at 'reading initial communication packet', system error: 111
Code:
[+] SourceBans "Error Connecting()" Debug starting for server 213.32.17.113:27015

[+] Trying to establish UDP connection
[+] UDP connection successfull!
[+] Trying to write to the socket
[+] Successfully requested server info. (That doesn't mean anything on an UDP stream.) Reading...
[+] Got an response! Server: LvN-D ZombieMod :: Unlimited Ammo :: LivinDead.com - FastDL

[+] Trying to establish TCP connection
[+] TCP connection successfull!
[+] Trying to write to TCP socket and authenticate via rcon
[+] Successfully sent authentication request. Reading...
[+] Got an response!
[+] Password correct!
I am unsure as to why I am getting these errors. The handy SB connection tool script says it's connection is fine, yet the database isn't. The details for the database are in the databases.cfg file yet still do not work. I am lost. :/

Databases.cfg:
Code:
"Databases"
{
"driver_default"		"mysql"

	"sourcebans"
	{
		"driver"			"default"
		"host"				"213.32.17.113"
		"database"			"<snip>_bans"
		"user"				"<snip>_bans"
		"pass"				"<snip>"
		//"timeout"			"0"
		"port"			"3306"
	}
	
	"default"
	{
		"driver"			"default"
		"host"				"localhost"
		"database"			"sourcemod"
		"user"				"root"
		"pass"				""
		//"timeout"			"0"
		//"port"			"0"
	}

	"storage-local"
	{
		"driver"			"sqlite"
		"database"			"sourcemod-local"
	}

	"clientprefs"
	{
		"driver"			"sqlite"
		"host"				"localhost"
		"database"			"clientprefs-sqlite"
		"user"				"root"
		"pass"				""
		//"timeout"			"0"
		//"port"			"0"
	}
}
__________________
HiddenConn1 is offline
Send a message via Skype™ to HiddenConn1
Kurtan
AlliedModders Donor
Join Date: Feb 2016
Location: Sweden
Old 01-14-2018 , 07:19   Re: Lost connection to MySQL server at 'reading initial communication packet'
Reply With Quote #2

is this solved or not? I could assist you if it isn't.
__________________
Kurtan is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:32.


Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Theme made by Freecode