Raised This Month: $204 Target: $400
 51% 

Your_Name_Here.justgotowned.com


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
Sonic ;)
Junior Member
Join Date: May 2005
Location: San Jose, CA
Old 04-15-2006 , 01:12   Your_Name_Here.justgotowned.com
Reply With Quote #1

Today I found this site called Aninote.com which has a few sites like justgotowned.com where all you have to do is put a person's name in front of the address (ex. Your_Name_Here.justgotowned.com) and then it displays a slide show with that persons name showing people getting owned. It's very funny (except for the kid in the wood chipper, very sad ). Well what I'd like to do is have an admin only command that you can enable so that when you headshot somebody it shows that person a MOTD window that displays that site with their name. Not all names work for this site though. You can't have spaces or odd characters (ex. []\| etc.) so it in this plugin, it would be cool if it could modify the name to remove spaces and odd characters. Do you think this can be done?
__________________
"They call me sonic, cause I am faster than sound, I keep on jumping arround, blue hedgehog Sonic, with incredible speed, I'm movin my feet....."

Sonic ;) is offline
Send a message via AIM to Sonic ;)
Xanimos
Veteran Member
Join Date: Apr 2005
Location: Florida
Old 04-15-2006 , 01:19  
Reply With Quote #2

Pretty simply.
Xanimos is offline
Send a message via AIM to Xanimos Send a message via MSN to Xanimos
Sonic ;)
Junior Member
Join Date: May 2005
Location: San Jose, CA
Old 04-20-2006 , 19:53  
Reply With Quote #3

Can somebody make this plugin for me?
__________________
"They call me sonic, cause I am faster than sound, I keep on jumping arround, blue hedgehog Sonic, with incredible speed, I'm movin my feet....."

Sonic ;) is offline
Send a message via AIM to Sonic ;)
Xanimos
Veteran Member
Join Date: Apr 2005
Location: Florida
Old 04-20-2006 , 20:13  
Reply With Quote #4

I don't know if it will show properly (The MOTD might cause errors when trying to load flash)

But if that works this should work fine (wasn't tested just compiled)

[EDIT] Don't mind the way its colored the coloring fucks up when it doesn't know that the ^ is the espcape character.

Use the one in green...

Code:
#include <amxmodx> #include <amxmisc> #define MAX_BAD 21 new szBad[MAX_BAD][2] = {     "%",     "^^",     "#",     "@",     "\",     "/",     "*",     "&",     "^"",     "'",     ";",     ":",     "<",     ">",     "|",     "?",     "=",     ",",     "!",     "(",     ")" }; public plugin_init() {     register_plugin("Ownage" , "1.0" , "Suicid3");     register_concmd("amx_own" , "cmdOwn" , ADMIN_KICK , " <Player> -- Shows player Ownage MOTD"); } public cmdOwn(id , level , cid) {     if(!cmd_access(id , level , cid , 2))         return PLUGIN_HANDLED;     new szMotd[256] , szName[36] , tID , szArg[36];     read_argv(1 , szArg , 35);     tID = cmd_target( id , szArg , 11);     if(!is_user_connected(tID))         return PLUGIN_HANDLED;     get_user_safe_name(tID , szName , 35);     format(szMotd , 255 , "<html><head></head><body><iframe width=^"100%^" height=^"100%^" src=^"http://%s.justgotowned.com/^"></iframe></body></html>" , szName);     show_motd(tID , szMotd , "You just got Owned!");     console_print(id , "[AMXX] %s Just got Owned!" , szName);     return PLUGIN_HANDLED; } stock get_user_safe_name( id , szName[] , iLen ) {     get_user_name( id , szName , iLen );     for(new i = 0 ; i < MAX_BAD; i++)         replace_all( szName , iLen , szBad[i] , ""); }

Code:
#include <amxmodx>
#include <amxmisc>

#define MAX_BAD	21

new szBad[MAX_BAD][2] = {
	"%",
	"^^",
	"#",
	"@",
	"\",
	"/",
	"*",
	"&",
	"^"",
	"'",
	";",
	":",
	"<",
	">",
	"|",
	"?",
	"=",
	",",
	"!",
	"(",
	")"
};

public plugin_init()
{
	register_plugin("Ownage" , "1.0" , "Suicid3");
	register_concmd("amx_own" , "cmdOwn" , ADMIN_KICK , " <Player> -- Shows player Ownage MOTD");
}

public cmdOwn(id , level , cid)
{
	if(!cmd_access(id , level , cid , 2))
		return PLUGIN_HANDLED;

	new szMotd[256] , szName[36] , tID , szArg[36];
	read_argv(1 , szArg , 35);
	tID = cmd_target( id , szArg , 11);
	if(!is_user_connected(tID))
		return PLUGIN_HANDLED;

	get_user_safe_name(tID , szName , 35);
	format(szMotd , 255 , "<html><head></head><body><iframe width=^"100%^" height=^"100%^" src=^"http://%s.justgotowned.com/^"></iframe></body></html>" , szName);
	show_motd(tID , szMotd , "You just got Owned!");

	console_print(id , "[AMXX] %s Just got Owned!" , szName);

	return PLUGIN_HANDLED;
}

stock get_user_safe_name( id , szName[] , iLen )
{
	get_user_name( id , szName , iLen );

	for(new i = 0 ; i < MAX_BAD; i++)
		replace_all( szName , iLen , szBad[i] , "");
}
Xanimos is offline
Send a message via AIM to Xanimos Send a message via MSN to Xanimos
v3x
Veteran Member
Join Date: Oct 2004
Location: US
Old 04-20-2006 , 23:47  
Reply With Quote #5

Code:
    "^"",
__________________
What am I doing these days? Well, I run my own Rust server. It's heavily modded. If you'd like to join, the ip is 167.114.101.67:28116

I also created a website called Rust Tools. It will calculate and tell you the raw amounts of resources needed to craft items.
v3x is offline
Xanimos
Veteran Member
Join Date: Apr 2005
Location: Florida
Old 04-20-2006 , 23:57  
Reply With Quote #6

it screws up when using ^^ inside quotes.

Code:
"^^", "^""
Xanimos is offline
Send a message via AIM to Xanimos Send a message via MSN to Xanimos
Sonic ;)
Junior Member
Join Date: May 2005
Location: San Jose, CA
Old 04-21-2006 , 06:02  
Reply With Quote #7

Thanks, I'm gonna test it right now.
__________________
"They call me sonic, cause I am faster than sound, I keep on jumping arround, blue hedgehog Sonic, with incredible speed, I'm movin my feet....."

Sonic ;) is offline
Send a message via AIM to Sonic ;)
Sonic ;)
Junior Member
Join Date: May 2005
Location: San Jose, CA
Old 04-21-2006 , 06:26  
Reply With Quote #8

When I went to compile it I got this error:

//// ugotowned.sma
// C:\dedicated server\cstrike\addons\amxmodx\scripting\ugoto wned.sma(61) : error 017: undefined symbol "replace_all"
//
// 1 Error.
// Could not Locate output file compiled\ugotowned.amx (compile failed).
//
// Compilation Time: 0.75 sec
//------------------------------------------------------
__________________
"They call me sonic, cause I am faster than sound, I keep on jumping arround, blue hedgehog Sonic, with incredible speed, I'm movin my feet....."

Sonic ;) is offline
Send a message via AIM to Sonic ;)
FatalisDK
Senior Member
Join Date: Mar 2006
Location: bacon
Old 04-21-2006 , 07:47  
Reply With Quote #9

Your AMXx version is probably < 1.65. Upgrade to latest version.
__________________
FatalisDK is offline
Sonic ;)
Junior Member
Join Date: May 2005
Location: San Jose, CA
Old 04-29-2006 , 20:45  
Reply With Quote #10

OK I managed to get it compiled. I did the amx_own command on myself and everything worked except when it tried to load the web site it said bad request.
__________________
"They call me sonic, cause I am faster than sound, I keep on jumping arround, blue hedgehog Sonic, with incredible speed, I'm movin my feet....."

Sonic ;) is offline
Send a message via AIM to Sonic ;)
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 00:57.


Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Theme made by Freecode