Raised This Month: $52 Target: $400
 13% 

[TF2]setplayerclass is error on my server.


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
koscar12
Member
Join Date: Jan 2014
Old 02-02-2014 , 04:24   [TF2]setplayerclass is error on my server.
Reply With Quote #1

Hi guys
I open the hidden mod. but i have big bug...
sometime plugin is not working...
and this is a error log...
L 02/02/2014 - 15:51:20: [SM] Native "SetEntProp" reported: Entity 1 (1) is invalid
L 02/02/2014 - 15:51:20: [SM] Displaying call stack trace for plugin "hidden.smx":
L 02/02/2014 - 15:51:20: [SM] [0] Line 345, D:\hm\tf\addons\sourcemod\scripting\include\t f2_stocks.inc::TF2_SetPlayerClass()
L 02/02/2014 - 15:51:20: [SM] [1] Line 657, D:\hm\tf\addons\sourcemod\scripting\hidden.sp :erformRoundInit()
L 02/02/2014 - 15:51:20: [SM] [2] Line 1195, D:\hm\tf\addons\sourcemod\scripting\hidden.sp ::OnGameFrame()

and i attach hidden mod....
Attached Files
File Type: sp Get Plugin or Get Source (hidden.sp - 75 views - 61.8 KB)
koscar12 is offline
bl4nk
SourceMod Developer
Join Date: Jul 2007
Old 02-02-2014 , 10:53   Re: [TF2]setplayerclass is error on my server.
Reply With Quote #2

Try this:
Code:
public OnClientDisconnect(client)
{
#if DEBUG_LOGGING
    PrintToServer("[%s] @OnClientDisconnect", PLUGIN_NAME);
#endif

    if (next_hidden == client)
    {
        next_hidden = 0;
    }

    current_pool[client] = 0;
    RemoveHiddenVision(client);
    kills_as_hidden[client] = 0;
    kills_of_hidden[client] = 0;
    if (client == previous_hidden)
    {
        previous_hidden = 0;
        hidden_previous_class = TFClass_Soldier;
    }
}
bl4nk is offline
koscar12
Member
Join Date: Jan 2014
Old 02-03-2014 , 03:22   Re: [TF2]setplayerclass is error on my server.
Reply With Quote #3

Ty!
but when we play the hidden, sometime hidden is two...
realhidden and other class
what can i change?

have error log...
L 02/03/2014 - 20:479: [SM] Native "ClientCommand" reported: Client 1 is not connected
L 02/03/2014 - 20:479: [SM] Displaying call stack trace for plugin "hidden.smx":
L 02/03/2014 - 20:479: [SM] [0] Line 1655, D:\hm\tf\addons\sourcemod\scripting\hidden.sp ::OverlayCommand()
L 02/03/2014 - 20:479: [SM] [1] Line 1648, D:\hm\tf\addons\sourcemod\scripting\hidden.sp ::RemoveHiddenVision()
L 02/03/2014 - 20:479: [SM] [2] Line 654, D:\hm\tf\addons\sourcemod\scripting\hidden.sp :erformRoundInit()
L 02/03/2014 - 20:479: [SM] [3] Line 1197, D:\hm\tf\addons\sourcemod\scripting\hidden.sp ::OnGameFrame()
L 02/03/2014 - 20:47:44: [SM] Native "IsFakeClient" reported: Client 1 is not connected

what can i fix..?

Last edited by koscar12; 02-03-2014 at 07:54. Reason: added error log
koscar12 is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:31.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode