Raised This Month: $27 Target: $400
 6% 

[SOLVED]Google-Map on Clan-Details not working


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
[WbOF]LuZiFeR
AlliedModders Donor
Join Date: Jun 2004
Old 02-28-2020 , 05:14   [SOLVED]Google-Map on Clan-Details not working
Reply With Quote #1

Hi all...

Everything is working fine regarding Google-Maps on our HLSX...



Except the map that should be visible on the clan-detail-page:



Field is empty evertime… Should be an map, or?

Any suggestions?

Last edited by [WbOF]LuZiFeR; 03-02-2020 at 12:10.
[WbOF]LuZiFeR is offline
Send a message via AIM to [WbOF]LuZiFeR
DarkDeviL
SourceMod Moderator
Join Date: Apr 2012
Old 03-01-2020 , 12:22   Re: Google-Map on Clan-Details not working
Reply With Quote #2

Quote:
Originally Posted by [WbOF]LuZiFeR View Post
Except the map that should be visible on the clan-detail-page:



Field is empty evertime… Should be an map, or?
Your site is https:// -

On your fornt page, you are loading various "http://" content, - e.g. images:

Code:
LuZiFeR <br>
		<a href="https://www.wbof.de/csgo-stats/hlstats.php?mode=playerinfo&player=10"><img src="http://www.wbof.de/csgo-stats/sig.php?player_id=10&background=random" border="0" width="560" height="95" alt=""/></a><br><br>
Note the "http://", that one causes your browser to not load the content, depending on your settings.

You (e.g. HLstatsX:CE) are doing the exact same from from the page you mention above, where it is loading:

Code:
http://maps.google.com/maps/api/js?sensor=false

Quote:
Originally Posted by [WbOF]LuZiFeR View Post
Any suggestions?
Simple fix would be to grep (search) your HLstatsX:CE files, and replace "http://maps.google.com[...]" with "https://maps.google.com[...]", so you make sure you are loading all content over https://.
__________________
Mostly known as "DarkDeviL".

Dropbox FastDL: Public folder will no longer work after March 15, 2017!
For more info, see the [SRCDS Thread], or the [HLDS Thread].
DarkDeviL is offline
[WbOF]LuZiFeR
AlliedModders Donor
Join Date: Jun 2004
Old 03-02-2020 , 02:48   Re: Google-Map on Clan-Details not working
Reply With Quote #3

Hi DarkDevil,

thank you for the helpfull hint.

It loads the map now, but i get the message, that the map could'nt be showed correctly.

It means, that the API-Key is not recognized on the clan-page (on the Servers-page it works).

https://www.wbof.de/csgo-stats/hlstats.php?mode=claninfo&clan=2



Do you have an idea, why the API is only working on the server-page?
[WbOF]LuZiFeR is offline
Send a message via AIM to [WbOF]LuZiFeR
[WbOF]LuZiFeR
AlliedModders Donor
Join Date: Jun 2004
Old 03-02-2020 , 12:09   Re: Google-Map on Clan-Details not working
Reply With Quote #4

Problem solved…

I added the api-key in this Code also (equivalent to the server-page)
[WbOF]LuZiFeR is offline
Send a message via AIM to [WbOF]LuZiFeR
mariozankl
Member
Join Date: May 2012
Location: Austria
Old 04-15-2020 , 12:27   Re: Google-Map on Clan-Details not working
Reply With Quote #5

Quote:
Originally Posted by [WbOF]LuZiFeR View Post
Problem solved…

I added the api-key in this Code also (equivalent to the server-page)
Where can i find the code for the clan page or what do i have to change that this works?

EDIT: Found it. It's in /pages/claninfo.php on line 140.

Last edited by mariozankl; 04-16-2020 at 11:51.
mariozankl is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 20:20.


Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Theme made by Freecode