Raised This Month: $ Target: $400
 0% 

Amx [FAKEMETA] g_pGameRules adress could not be found


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
Stroow_
Junior Member
Join Date: Nov 2022
Old 04-21-2024 , 16:58   Amx [FAKEMETA] g_pGameRules adress could not be found
Reply With Quote #1

Hi,
I try to test and launch a Hlds Cs1.6 with amx plugins, and when a player join the server it crash with this error code :

Error Log :


I see few post with possible solution like change variables in /gamedata/common.games/globalvars.engine.txt but not helped me and I rollback the modifications.

Tools used :
Steam cmd : 8.74.80.95
Hlds : Exe version 1.1.2.7 (cstrike)
Exe build: 11:25:48 Dec 11 2023 (9909)

Amx Mod X : 1.10 (needed to compile sma files that won't compile with 1.8 or 1.9)

Thanks in advance for your possible help.

PS : I'm sorry if it's not the good place to post this problem.

Last edited by Stroow_; 04-22-2024 at 04:15. Reason: hlds correction version
Stroow_ is offline
fysiks
Veteran Member
Join Date: Sep 2007
Location: Flatland, USA
Old 04-21-2024 , 21:06   Re: Amx [FAKEMETA] g_pGameRules adress could not be found
Reply With Quote #2

What is this version of HLDS because I don't see any version numbers anywhere near what you show there based on a server I just downloaded via SteamCMD. In my newly downloaded server via SteamCMD and it shows:

Code:
Protocol version 48
Exe version 1.1.2.7/Stdio (cstrike)
Exe build: 19:52:19 Aug  3 2020 (8684)
The version of SteamCMD should be irrelevant if you're using the real SteamCMD from Valve Software. It automatically updates itself when you run it.
__________________

Last edited by fysiks; 04-21-2024 at 21:06.
fysiks is offline
Stroow_
Junior Member
Join Date: Nov 2022
Old 04-22-2024 , 04:18   Re: Amx [FAKEMETA] g_pGameRules adress could not be found
Reply With Quote #3

Yes, that the last SteamCMD I think, direct from Valve Software

Nvm my bad I write the wrong version, it's updated in first post sorry

Last edited by Stroow_; 04-22-2024 at 04:20.
Stroow_ is offline
mlibre
Veteran Member
Join Date: Nov 2015
Location: return PLUGIN_CONTINUE
Old 04-22-2024 , 10:21   Re: Amx [FAKEMETA] g_pGameRules adress could not be found
Reply With Quote #4

these messages are telling you that you are using a plugin or module whose functions are not present in the latest version of amxx, therefore they probably only work in 182 due to compatibility issues. Failing that, you will have to adapt to the new natives.
__________________
mlibre is offline
JusTGo
Veteran Member
Join Date: Mar 2013
Old 04-22-2024 , 10:32   Re: Amx [FAKEMETA] g_pGameRules adress could not be found
Reply With Quote #5

You might need to download the legacy version of hlds since after 25th update the current gamedata might be outdated.

HTML Code:
app_set_config 90 mod cstrike
app_update 90 -beta steam_legacy validate
__________________
JusTGo is offline
mlibre
Veteran Member
Join Date: Nov 2015
Location: return PLUGIN_CONTINUE
Old 04-22-2024 , 10:40   Re: Amx [FAKEMETA] g_pGameRules adress could not be found
Reply With Quote #6

Quote:
Originally Posted by JusTGo View Post
You might need to download the legacy version of hlds since after 25th update the current gamedata might be outdated.

HTML Code:
app_set_config 90 mod cstrike
app_update 90 -beta steam_legacy validate
why would you ask? Because such an update is currently problematic in terms of stability for setting up a server, you will have to use the aforementioned beta version whose support works with rehlds if you want to try the reverse engineering improvements.
__________________
mlibre is offline
Stroow_
Junior Member
Join Date: Nov 2022
Old 04-22-2024 , 13:46   Re: Amx [FAKEMETA] g_pGameRules adress could not be found
Reply With Quote #7

Quote:
Originally Posted by mlibre View Post
these messages are telling you that you are using a plugin or module whose functions are not present in the latest version of amxx, therefore they probably only work in 182 due to compatibility issues. Failing that, you will have to adapt to the new natives.
Ah AMx version are not retrocompatible ? Because in my hlds I'm using a zombie plague plugin which already exist :Zombie Plague Special Edition.

Quote:
Originally Posted by mlibre View Post
why would you ask? Because such an update is currently problematic in terms of stability for setting up a server, you will have to use the aforementioned beta version whose support works with rehlds if you want to try the reverse engineering improvements.
So if I understand correctly I must use AMX 1.8 instead of 1.10 ? Or try a ReHlds ?
Stroow_ is offline
DJEarthQuake
Veteran Member
Join Date: Jan 2014
Location: Astral planes
Old 04-22-2024 , 17:40   Re: Amx [FAKEMETA] g_pGameRules adress could not be found
Reply With Quote #8

Are you running Core Package without Mod Addon Pack?
__________________
DJEarthQuake is offline
Stroow_
Junior Member
Join Date: Nov 2022
Old 04-23-2024 , 03:49   Re: Amx [FAKEMETA] g_pGameRules adress could not be found
Reply With Quote #9

Quote:
Originally Posted by DJEarthQuake View Post
Are you running Core Package without Mod Addon Pack?
Hmm I don't understand your point you mean if I'm using Amx base with/without the addon package ?
I'm using the installer version of Amx =)

Last edited by Stroow_; 04-23-2024 at 03:50.
Stroow_ is offline
fysiks
Veteran Member
Join Date: Sep 2007
Location: Flatland, USA
Old 04-24-2024 , 01:36   Re: Amx [FAKEMETA] g_pGameRules adress could not be found
Reply With Quote #10

Maybe I'm blind (and I haven't used Windows for years now) but where did you find an installer for version 1.10.0? Though, I suspect that even the installer will allow you to not properly install the mod-specific files (the installer for 1.8.2 does allow this) so you might not have the critical files for Counter-Strike 1.6.
__________________
fysiks is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:17.


Powered by vBulletin®
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Theme made by Freecode