Raised This Month: $87 Target: $400
 21% 

[IMPORTANT] Sourcemod not working!


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
GoGetSomeSleep
Senior Member
Join Date: Dec 2018
Location: Miami/Florida
Old 10-01-2019 , 14:15   [IMPORTANT] Sourcemod not working!
Reply With Quote #1

The result is always the same as I have tried taking VDS from various data hosting companies and installing linux on my local system as a last resort.

Linux version: Ubuntu 16.04
Sourcemod: https://sm.alliedmods.net/smdrop/1.9...2-linux.tar.gz

- I installed l4d2 from steamcmd.
- I downloaded sourcemod from link on top.
- I started l4d2 server normally from startscript.sh
- I stopped l4d2 server
- I've installed sourcemod (right directories)
- I started l4d2 server normally from startscript.sh

It doesn't work as you see below when I install sourcemod.
There are no log records in the game or sourcemod.

Starting messages
PHP Code:
************** WARNING ***************
Running the dedicated server as root
is highly discouraged
It is generally
unnecessary to 
use root privileges to
execute the dedicated server
.
**************************************


Server will auto-restart if there is a crash.dss
#
#Console initialized.
Setting breakpad minidump AppID 222860
#Using breakpad minidump system
Using breakpad crash handler
Forcing breakpad minidump interfaces to load
dlopen failed trying to load
:
/
root/.steam/sdk32/steamclient.so
with error
:
/
root/.steam/sdk32/steamclient.socannot open shared object fileNo such file or directory
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
#Game_srv.so loaded for "Left 4 Dead 2"
Server is hibernating
ConVarRef test_progression_loop doesn
't point to an existing ConVar
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
Parent cvar in server.dll not allowed (spit_scaling_min_scale)
Game supporting (2) split screen players
maxplayers set to 18
exec: couldn'
t exec server.cfg
Unknown command 
"mat_bloom_scalefactor_scalar"
NetworkIP 192.168.1.8mode MPdedicated Yesports 318 SV 0 CL
---- Host_NewGame ----
Host_NewGame on map c8m1_apartment
ConVarRef room_type doesn
't point to an existing ConVar
Executing dedicated server config file
CSpeechScriptBridge initializing...
        HSCRIPT loaded successfully
Initializing Director'
s script
Commentary
Loading commentary data from maps/c8m1_apartment_commentary.txt.
Initializing Director's script
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Setting breakpad minidump AppID = 550
dlopen failed trying to load:
/root/.steam/sdk32/steamclient.so
with error:
/root/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Setting breakpad minidump AppID = 222860
exec: couldn'
t exec server.cfg
Connection to Steam servers successful
.
   
VAC secure mode is activated
i have original sourcemod plugins in .tar.gz and just test for sourcemod is working
PHP Code:
sm plugins
Unknown command 
"sm" 
status text
PHP Code:
status
hostname
Left 4 Dead 2
version 
2.1.5.5 7311 secure  (unknown)
udp/ip  192.168.1.8:318 [ public XXX.42.159.XXX:318 ]
os      Linux Dedicated
map     
c8m1_apartment
players 
0 humans0 bots (4 max) (hibernating) (unreserved)

# userid name uniqueid connected ping loss state rate adr
#end 
GoGetSomeSleep is offline
asherkin
SourceMod Developer
Join Date: Aug 2009
Location: OnGameFrame()
Old 10-01-2019 , 14:50   Re: [IMPORTANT] Sourcemod not working!
Reply With Quote #2

You don't appear to have installed MetaMod:Source.
__________________
asherkin is offline
GoGetSomeSleep
Senior Member
Join Date: Dec 2018
Location: Miami/Florida
Old 10-01-2019 , 15:03   Re: [IMPORTANT] Sourcemod not working!
Reply With Quote #3

thanks for reply

There was a metamod folder in sourcemod tar.gz.
I guess that's why I skipped install metamod, now I'm also going to try install metamod.

edit: working now

Last edited by GoGetSomeSleep; 10-01-2019 at 15:06. Reason: update
GoGetSomeSleep is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 19:12.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode