Raised This Month: $52 Target: $400
 13% 

SV_Rcon not being called?


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
AmXDusT
Member
Join Date: Feb 2019
Location: Italy / Albania
Old 08-13-2019 , 14:52   SV_Rcon not being called?
Reply With Quote #1

Hi, not sure if this is the right place.
I'm using orpheu v2.6.3 and I'm trying to use the SV_Rcon function whenever some user uses rcon in the server. While in windows it seems to work, on linux it doesn't, neither in 1.8.2 nor 1.8.3.
Idk if it's a signature problem since the linux value is always "SV_Rcon".
I use the SV_Rcon_Validate too in the same plugin/server and that one works though.
PHP Code:
public plugin_init()
{
    
register_plugin(PLUGINVERSIONAUTHOR)
    
OrpheuRegisterHook(OrpheuGetFunction("SV_Rcon"), "On_Rcon_Pre"OrpheuHookPre)
}
public 
On_Rcon_Pre(p_Address)
{
    
//client_print(0, print_chat, "asdasdasdadadads")
    
g_Address p_Address

Attached Files
File Type: zip SV_Rcon.zip (355 Bytes, 11 views)

Last edited by AmXDusT; 08-13-2019 at 14:52.
AmXDusT is offline
DruGzOG
Veteran Member
Join Date: Nov 2007
Location: Unknown
Old 08-14-2019 , 23:27   Re: SV_Rcon not being called?
Reply With Quote #2

I believe the signatures for linux are a bit outdated. Could explain why it does not work.
__________________
DruGzOG is offline
Send a message via AIM to DruGzOG
AmXDusT
Member
Join Date: Feb 2019
Location: Italy / Albania
Old 08-17-2019 , 23:28   Re: SV_Rcon not being called?
Reply With Quote #3

Seems so weird though. Would anyone try it with that signature on linux?
Just the client_print to see if it works.

I checked the thread on how to make a signature but I didn't understand much of it. is there anywhere where I can request the signature to be updated or anyone that has a sv_rcon signature that works?
AmXDusT is offline
DarthMan
Veteran Member
Join Date: Aug 2011
Old 08-18-2019 , 06:29   Re: SV_Rcon not being called?
Reply With Quote #4

Quote:
Originally Posted by AmXDusT View Post
Seems so weird though. Would anyone try it with that signature on linux?
Just the client_print to see if it works.

I checked the thread on how to make a signature but I didn't understand much of it. is there anywhere where I can request the signature to be updated or anyone that has a sv_rcon signature that works?
For HLDS:

Code:
{
    "name" : "SV_Rcon",
    "library" : "engine",
    "arguments" :
    [
        {
            "type" : "pointer"
        }
    ],
    "identifiers":
    [
        {
            "os" : "windows",
            "value" : [0x55,0x8B,"*",0x81,"*","*","*","*","*",0x53,0x56,0x57,0xE8,"*","*","*","*",0x8B,"*",0x68,"*","*","*","*",0x89]
        },
        {
            "os" : "linux",
            "value" : "SV_Rcon"
        }
    ]
}
For REHLDS:

Code:
{
    "name" : "SV_Rcon",
    "library" : "engine",
    "arguments" :
    [
        {
            "type" : "pointer"
        }
    ],
    "identifiers":
    [
        {
            "os" : "windows",
            "value" : [0x55,0x8B,"*",0x81,"*","*","*","*","*",0x56,0x57,0xE8,"*","*","*","*",0x68,"*","*","*","*",0x8B,"*",0xE8]
        },
        {
            "os" : "linux",
            "value" : "SV_Rcon"
        }
    ]
}

Last edited by DarthMan; 08-18-2019 at 06:35.
DarthMan is online now
HamletEagle
AMX Mod X Plugin Approver
Join Date: Sep 2013
Location: Romania
Old 08-18-2019 , 08:12   Re: SV_Rcon not being called?
Reply With Quote #5

His signature file was correct, at least for linux. This is not the issue.

Mind telling us your hlds version? Are you sure you had the debug print enabled in linux?
__________________
HamletEagle is offline
AmXDusT
Member
Join Date: Feb 2019
Location: Italy / Albania
Old 08-18-2019 , 16:22   Re: SV_Rcon not being called?
Reply With Quote #6

Hi, yeah I'm sure I had the debug on. I've edited my code multiple times trying to find a solution. the one I posted is just the part not working and I'm sure the rest works.
As I said, on Windows, the same plugin works flawlessly while on Linux nope (just the sv_rcon function isn't called).

Hlds build: 8196 (of 3rd April 2019)
Amxx: 1.9.0.5234
AmXDusT is offline
DarthMan
Veteran Member
Join Date: Aug 2011
Old 08-18-2019 , 18:28   Re: SV_Rcon not being called?
Reply With Quote #7

Quote:
Originally Posted by HamletEagle View Post
His signature file was correct, at least for linux. This is not the issue.

Mind telling us your hlds version? Are you sure you had the debug print enabled in linux?
Ah, so he was using Linux. My bad ...
DarthMan is online now
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 17:48.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode