Raised This Month: $213 Target: $400
 53% 

[HELP] Play sound completely broken in CSGO


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
HvG Community
AlliedModders Donor
Join Date: Sep 2012
Old 12-21-2019 , 07:29   [HELP] Play sound completely broken in CSGO
Reply With Quote #1

I have 5 wav files inside of sound/greetings.

Initially none worked and i had
S_StartSound(): Failed to load sound 'greetings\hello.wav'. File is missing from disk/repository.

I fixed it by adding */ in front of the file path.



Hello 2,3,4 and 5 are no longer showing missing from disk but now they simply don't play.
https://i.gyazo.com/fc6f12f24bf582c0...483ee178f3.png
In above screenshot you can see that it doesn't return any errors for hello3 because it recognizes it exists in directory but it doesn't play the sound.

So because hello.wav works i tried making copies of it and then just renaming it but its still the same issue.
HvG Community is offline
CowGod
Senior Member
Join Date: Feb 2015
Old 12-21-2019 , 11:11   Re: [HELP] Play sound completely broken in CSGO
Reply With Quote #2

Do you have the file added to your FastDL server? Sounds like clients are not downloading it.
CowGod is offline
Send a message via Skype™ to CowGod
HvG Community
AlliedModders Donor
Join Date: Sep 2012
Old 12-21-2019 , 11:48   Re: [HELP] Play sound completely broken in CSGO
Reply With Quote #3

I checked the console, it does get downloaded and i can also see it being downloaded to folder.

Its really weird.
HvG Community is offline
CowGod
Senior Member
Join Date: Feb 2015
Old 12-21-2019 , 16:06   Re: [HELP] Play sound completely broken in CSGO
Reply With Quote #4

Quote:
Originally Posted by HvG Community View Post
I checked the console, it does get downloaded and i can also see it being downloaded to folder.

Its really weird.
Are the sounds not cached on map start?
CowGod is offline
Send a message via Skype™ to CowGod
HvG Community
AlliedModders Donor
Join Date: Sep 2012
Old 12-22-2019 , 13:38   Re: [HELP] Play sound completely broken in CSGO
Reply With Quote #5

Code:
    PrecacheSound("*/greetings/hello.wav");
    PrecacheSound("*/greetings/hello.mp3");
    PrecacheSound("*/greetings/hello2.wav");
    PrecacheSound("*/greetings/hello3.wav");
    PrecacheSound("*/greetings/hello4.wav");

Yeah.
HvG Community is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:19.


Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Theme made by Freecode