Raised This Month: $75 Target: $400
 18% 

Steam ID Based Attribute editing not applying


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
kfskilljoy
AlliedModders Donor
Join Date: Jul 2013
Old 02-23-2019 , 10:10   Steam ID Based Attribute editing not applying
Reply With Quote #1

When trying to apply attributes via STEAMID the attributes don't apply. I even tried adding in admin flag and setting it to root. Which is the current flag that i have. I removed my STEAMID from the config and added in a wild card to test and see if the plugin was reading the file and it was. I removed the wild card again and re-added my steam id and it go's back to the same problem that i had.

Here is the Config Code:
Code:
"custom_weapons_v3"
{
        "STEAM_1:1:36924606"
        {
                "18"
                {
                        "level" "100"
                        "quality" "8"
                        "admin-flags"   "z"

                        "1"     "4 ; 21.0"
                        "2"     "6 ; 0.25"
                }


        }

}
kfskilljoy is offline
asherkin
SourceMod Developer
Join Date: Aug 2009
Location: OnGameFrame()
Old 02-24-2019 , 14:48   Re: Steam ID Based Attribute editing not applying
Reply With Quote #2

Is your server connected to Steam? Are your admin permissions working? (assuming you haven't turned off SteamAuthstringValidation in SM.)
__________________
asherkin is offline
kfskilljoy
AlliedModders Donor
Join Date: Jul 2013
Old 02-24-2019 , 16:04   Re: Steam ID Based Attribute editing not applying
Reply With Quote #3

Quote:
Originally Posted by asherkin View Post
Is your server connected to Steam? Are your admin permissions working? (assuming you haven't turned off SteamAuthstringValidation in SM.)
SteamAuthstringValidation is still enabled in the core config file and the server is still connected to steam .
kfskilljoy is offline
kfskilljoy
AlliedModders Donor
Join Date: Jul 2013
Old 05-04-2019 , 04:12   Re: Steam ID Based Attribute editing not applying
Reply With Quote #4

I hate bumping things. But from looking for a while i still haven't got a valid solution yet.
kfskilljoy is offline
JoinedSenses
Member
Join Date: Sep 2013
Old 06-16-2019 , 11:58   Re: Steam ID Based Attribute editing not applying
Reply With Quote #5

Late response. The steamid should probably be STEAM_0: instead of STEAM_1:
__________________

Last edited by JoinedSenses; 06-16-2019 at 11:58.
JoinedSenses is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 20:24.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode