Raised This Month: $159 Target: $400
 39% 

[L4D] Pills Addiction 1.6.9 (now compatible with KrX upgrades)


Post New Thread Reply   
 
Thread Tools Display Modes
olj
Veteran Member
Join Date: Jun 2009
Old 09-02-2009 , 08:42   Re: [L4D] Pills Addiction 1.6.7 (now compatible with KrX upgrades)
Reply With Quote #131

Quote:
Originally Posted by Whosat View Post
The include is only needed when compiling.

Remember to do a LibraryExists check!
You can look into code i added proper library checks in every place where KrX's natives needed. And it worked fine with Upgrades moved in disabled folder. No idea why he has problems with it.
__________________
olj is offline
Whosat
Senior Member
Join Date: Nov 2007
Location: Singapore
Old 09-02-2009 , 10:02   Re: [L4D] Pills Addiction 1.6.7 (now compatible with KrX upgrades)
Reply With Quote #132

Hmm yeah I looked at it as well.
0.o
__________________
Whosat is offline
olj
Veteran Member
Join Date: Jun 2009
Old 09-02-2009 , 10:03   Re: [L4D] Pills Addiction 1.6.7 (now compatible with KrX upgrades)
Reply With Quote #133

Quote:
Originally Posted by Whosat View Post
Hmm yeah I looked at it as well.
0.o
Your verdict, doctor ?
__________________
olj is offline
Whosat
Senior Member
Join Date: Nov 2007
Location: Singapore
Old 09-02-2009 , 11:55   Re: [L4D] Pills Addiction 1.6.7 (now compatible with KrX upgrades)
Reply With Quote #134

I'm not sure man, I'm guessing its his side's problem since you said it works on your side. I can't run my server on weekdays so I can't say for sure. :/
__________________
Whosat is offline
olj
Veteran Member
Join Date: Jun 2009
Old 09-02-2009 , 13:56   Re: [L4D] Pills Addiction 1.6.7 (now compatible with KrX upgrades)
Reply With Quote #135

Quote:
Originally Posted by Whosat View Post
I'm not sure man, I'm guessing its his side's problem since you said it works on your side. I can't run my server on weekdays so I can't say for sure. :/
EDIT: Ok it finally works without upgrades too.

THIS
PHP Code:
#undef REQUIRE_PLUGIN 
And THIS
PHP Code:
public bool:AskPluginLoad(Handle:myselfbool:lateString:error[], err_max)
{
    
MarkNativeAsOptional("KrXsurupHasUpgrade");
    return 
true;

__________________

Last edited by olj; 09-02-2009 at 14:57.
olj is offline
Number Six
Senior Member
Join Date: Dec 2008
Old 09-02-2009 , 19:13   Re: [L4D] Pills Addiction 1.6.8 (now compatible with KrX upgrades)
Reply With Quote #136

1.6.8 load and no error .log , pills distrib on start working .
Re-testing tomorrow the new version to Vomit Extinguishing , no time this night .
__________________


Number Six is offline
olj
Veteran Member
Join Date: Jun 2009
Old 09-02-2009 , 19:16   Re: [L4D] Pills Addiction 1.6.8 (now compatible with KrX upgrades)
Reply With Quote #137

Quote:
Originally Posted by Number Six View Post
1.6.8 load and no error .log , pills distrib on start working .
Re-testing tomorrow the new version to Vomit Extinguishing , no time this night .
Yeah, glad it's working now, but i advice to use KrX Upgrades though. Its really working nice, almost no glitches

Also, i should add some more compatibility for the cases when you unload upgrades and then reload them. Never included comaptibility code in plugins, so its quite hard for first time.
__________________
olj is offline
Number Six
Senior Member
Join Date: Dec 2008
Old 09-02-2009 , 20:36   Re: [L4D] Pills Addiction 1.6.8 (now compatible with KrX upgrades)
Reply With Quote #138

Quote:
Originally Posted by olj View Post
Yeah, glad it's working now, but i advice to use KrX Upgrades though. Its really working nice, almost no glitches

Also, i should add some more compatibility for the cases when you unload upgrades and then reload them. Never included comaptibility code in plugins, so its quite hard for first time.
Tested a version last month but crawling bloked and more bugs on change maps , im happy with the jerrith upgrades , just witch fire ammos bug is really négative .

Thanks for update 1.6.8 .
__________________


Number Six is offline
olj
Veteran Member
Join Date: Jun 2009
Old 09-03-2009 , 03:42   Re: [L4D] Pills Addiction 1.6.8 (now compatible with KrX upgrades)
Reply With Quote #139

Quote:
Originally Posted by Number Six View Post
Tested a version last month but crawling bloked and more bugs on change maps , im happy with the jerrith upgrades , just witch fire ammos bug is really négative .

Thanks for update 1.6.8 .
Well the last one seems to be quite stable. Anyway i can now add bonus stamina to adrenaline boost and then proceed to 1.7 release.
__________________
olj is offline
berni
SourceMod Plugin Approver
Join Date: May 2007
Location: Austria
Old 09-11-2009 , 12:20   Re: [L4D] Pills Addiction 1.6.9 (now compatible with KrX upgrades)
Reply With Quote #140

This plugin needs KrX_surup include, you should provide a link to that in your post.

And the version convar l4d_pillsaddiction_version should have the ConVar Flag FCVAR_DONTRECORD so it won't get saved.

On Line 353 you are using GetMaxClients() instead of MaxClients like in the other loops (just noticed).
__________________
Why reinvent the wheel ? Download smlib with over 350 useful functions.

When people ask me "Plz" just because it's shorter than "Please" I feel perfectly justified to answer "No" because it's shorter than "Yes"
powered by Core i7 3770k | 32GB DDR3 1886Mhz | 2x Vertex4 SSD Raid0
berni is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:46.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode