Raised This Month: $67 Target: $400
 16% 

CSO Costumes v4.0


Post New Thread Reply   
 
Thread Tools Display Modes
Smilex_Gamer
Senior Member
Join Date: Apr 2017
Location: Portugal
Old 09-13-2019 , 11:44   Re: CSO Costumes v2.5
Reply With Quote #41

Quote:
Originally Posted by Dexon View Post
Thank you so much. It works! Btw, I'm using ZP 4.3 only because there are so many great old plugins for 4.3 version, and 5.0 doesn't compatible with them, even with the compatible plugin.
But there is a big problem, for me. If I active a model, the server starts to create big lags. I don't even know why.

Malformed packet size (2782, 1230) => Console msg.
That's something with your server. Maybe you're using too many plugins that conflict with my plugin (probably about model changing).
Try disabling your 3rd party plugins and test it again to see if you get the same results.
Smilex_Gamer is offline
Dexon
Member
Join Date: Aug 2019
Old 09-13-2019 , 13:02   Re: CSO Costumes v2.5
Reply With Quote #42

I disabled all. Still. And get kicked due to Reliable Channel Overflowed.
Dexon is offline
Dexon
Member
Join Date: Aug 2019
Old 09-13-2019 , 13:39   Re: CSO Costumes v2.5
Reply With Quote #43

May this all could be cuz low limits on the server. (20 player slot currently)
So, I will use everything expect the ct/t models. But could you tell me, why is this model bugs?

https://imgur.com/a/kq0xrlP
Dexon is offline
iceeedr
Veteran Member
Join Date: Apr 2017
Location: Brazil
Old 09-13-2019 , 14:06   Re: CSO Costumes v2.5
Reply With Quote #44

Quote:
Originally Posted by HamletEagle View Post
cs_set_user_model will crash the server,if there are too many players. Use set_user_info instead.
__________________


Quote:
Originally Posted by fysiks View Post
Please stop trying to help. You appear to just be posting random stuff. Wait until you actually understand more about AMX Mod X and how the game works.
iceeedr is online now
Send a message via Skype™ to iceeedr
Smilex_Gamer
Senior Member
Join Date: Apr 2017
Location: Portugal
Old 09-13-2019 , 14:16   Re: CSO Costumes v2.5
Reply With Quote #45

Quote:
Originally Posted by Dexon View Post
I disabled all. Still. And get kicked due to Reliable Channel Overflowed.
I don't really know. Maybe it's some configuration in your server that is conflicting with my plugin. At least for me that didn't happen.
I'm testing right now my plugin on newer versions of AmxModX (ver. 1.10.0.5378 ) and everything seems to be working fine (I tested using: MYSQL Support; ZP Support; ZP Support 4.3; ZP Support + MYSQL Support; ZP Support 4.3 + MYSQL Support). Also along with that earlier version of AmxModX, I am using the newer versions of ReHLDS and ReGameDLL, just in case someone uses my plugin in a ReHLDS or ReGameDLL server (and it works fine as I said before).
When using AmxModX 1.8.2 it works as it should be as well.

Last edited by Smilex_Gamer; 09-13-2019 at 14:22.
Smilex_Gamer is offline
Smilex_Gamer
Senior Member
Join Date: Apr 2017
Location: Portugal
Old 09-13-2019 , 14:21   Re: CSO Costumes v2.5
Reply With Quote #46

Quote:
Originally Posted by Dexon View Post
May this all could be cuz low limits on the server. (20 player slot currently)
So, I will use everything expect the ct/t models. But could you tell me, why is this model bugs?

https://imgur.com/a/kq0xrlP
In version 1.3 of my plugin, I said in the change logs that there were 3 costumes that had a bug when adding them into the sub-models. The same appeared in version 1.7 with that costume that you're using in that image. So I have 4 costumes (Back type) that have that type of bug. If you know someone that knows the fix, please tell me because neither I know (to be honest I could just separate them from the main models and make them single models, but the point of my plugin is to reduce precache using sub-models so... yeah that's it).
Smilex_Gamer is offline
Smilex_Gamer
Senior Member
Join Date: Apr 2017
Location: Portugal
Old 09-13-2019 , 14:28   Re: CSO Costumes v2.5
Reply With Quote #47

Quote:
Originally Posted by iceeedr View Post
Quote:
Originally Posted by HamletEagle View Post
cs_set_user_model will crash the server,if there are too many players. Use set_user_info instead.
I can replace cs_set_user_model and cs_reset_user_model with cs_set_player_model and cs_reset_player_model, without ZP being a requirement for those to be used. But doing that would make cs_player_models_api a requirement for the whole plugin.
Tell me if it's a good idea to do that (for real, no sarcasm).

Last edited by Smilex_Gamer; 09-13-2019 at 14:52.
Smilex_Gamer is offline
Dexon
Member
Join Date: Aug 2019
Old 09-13-2019 , 14:33   Re: CSO Costumes v2.5
Reply With Quote #48

Thank you, for trying help. I don't know what could be the prob. I say may the server limits.

P.S.: May I know someone, if I'll write to you if he could help.

Edit: I just saw your idea, gonna try it.

Last edited by Dexon; 09-13-2019 at 14:37.
Dexon is offline
Smilex_Gamer
Senior Member
Join Date: Apr 2017
Location: Portugal
Old 09-13-2019 , 14:37   Re: CSO Costumes v2.5
Reply With Quote #49

Quote:
Originally Posted by Dexon View Post
Edit: I just saw your idea, gonna try it.
I was answering iceeedr about what he wrote. Plus, when you enable the Zombie Plague Mod Support, my plugin doesn't use cs_set_user_model or cs_reset_user_model. It starts using cs_set_player_model and cs_reset_player_model from cs_player_models_api.

Last edited by Smilex_Gamer; 09-13-2019 at 14:38.
Smilex_Gamer is offline
Old 09-13-2019, 14:38
Dexon
This message has been deleted by Dexon.
Smilex_Gamer
Senior Member
Join Date: Apr 2017
Location: Portugal
Old 09-13-2019 , 14:42   Re: CSO Costumes v2.5
Reply With Quote #50

Quote:
Originally Posted by Dexon View Post
Thank you, for trying help. I don't know what could be the prob. I say may the server limits.
You're welcome. Probably is something about the configuration itself.

Quote:
Originally Posted by Dexon View Post
P.S.: May I know someone, if I'll write to you if he could help.
PM me if you know someone who knows how to fix this. Thanks in advance
Smilex_Gamer is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 19:49.


Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Theme made by Freecode