Raised This Month: $ Target: $400
 0% 

AMXModX not working on Ubuntu-20.04 (64 bit) SteamCMD


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
Nulis
New Member
Join Date: Jul 2020
Old 07-30-2020 , 04:46   AMXModX not working on Ubuntu-20.04 (64 bit) SteamCMD
Reply With Quote #1

Hello fellas. I know how it is hard to talk same for everyone person, so I will try to describe my problem as much as I can, that you can see what I arleady have done for that.

So I have installed server on VPS host with Ubuntu-20.04 (64 bit). For installation I used SteamCMD and used this tutorial:

And my server is runing fine. After that I have installed Metamod v1.20 linux Binary:

and then I installed Mod Addon Packs for Counter-Strike 1.8.2 Linux from there:

with this tutorial:

And I think there is nothing working. amx_help commands isn't working. So maybe there are any commands to check is it work or no? What steps should I do next? Also I'm attaching there some of my files to see is everything fine in it:

libist.gam
Code:
game "Counter-Strike"
url_info "www.counter-strike.net"
url_dl ""
version "1.6"
size "184000000"
svonly "0"
secure "1"
type "multiplayer_only"
cldll "1" 
hlversion "1111"
nomodels "1"
nohimodel "1"
mpentity "info_player_start"
gamedll "dlls\mp.dll"
gamedll_linux "dlls/cs.so"
gamedll_osx "dlls/cs.dylib"
trainmap "tr_1"
edicts	"1800"
gamedll_linux "addons/metamod/dlls/metamod.so"

plugins.ini
in metamod folder
Code:
linux addons/amxmodx/dlls/amxmodx_mm_i386.so
Any help would be great in here.
Nulis is offline
Mordekay
Squirrel of Fortune
Join Date: Apr 2006
Location: Germany
Old 07-30-2020 , 06:40   Re: AMXModX not working on Ubuntu-20.04 (64 bit) SteamCMD
Reply With Quote #2

You need to remove the first gamedll_linux call a few lines above your added line for metamod. It will always use the first one, so i guess even metamod is not loaded. You can check this with "meta list" into the servers console.
__________________


Last edited by Mordekay; 07-30-2020 at 06:41.
Mordekay is offline
Nulis
New Member
Join Date: Jul 2020
Old 07-30-2020 , 08:42   Re: AMXModX not working on Ubuntu-20.04 (64 bit) SteamCMD
Reply With Quote #3

Quote:
Originally Posted by Mordekay View Post
You need to remove the first gamedll_linux call a few lines above your added line for metamod. It will always use the first one, so i guess even metamod is not loaded. You can check this with "meta list" into the servers console.
meta list didn't show anything, so that is what I found there was also missing amx dll, thanks for your help!
Nulis is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:08.


Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Theme made by Freecode