Raised This Month: $165 Target: $400
 41% 

Lag on Server despite trying different things


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
lee_jay98
New Member
Join Date: May 2018
Old 05-14-2018 , 14:28   Lag on Server despite trying different things
Reply With Quote #1

I have 2 servers running on my computer , one of which is pretty much empty.
If there are two or three players, their pings are pretty stable, however if player amount reaches even 6-7, their ping increase, especially if a single player has high ping it apparently makes others pings jump up every now and then. And generally the pings arent stable at all. Variation is about 30-40 ignoring the jumps.

CPU: intel core 2 duo E7400 @ 2.80GHz 2.79Ghz
Ram: 2GB
OS: Win7*64

Uploadspeed is: 6000kbps

raters in current use
sv_maxrate 25000
sv_minrate 0
sv_maxupdaterate 101
sv_minupdaterate 10

Let me know if you need any further details to help me solve the lag and too much vartion in pings
lee_jay98 is offline
Mordekay
Squirrel of Fortune
Join Date: Apr 2006
Location: Germany
Old 05-14-2018 , 15:02   Re: Lag on Server despite trying different things
Reply With Quote #2

Too less RAM for 2 Servers and most likely for one server also, especially if you also play from the same computer.
__________________


Last edited by Mordekay; 05-14-2018 at 15:03.
Mordekay is offline
lee_jay98
New Member
Join Date: May 2018
Old 05-14-2018 , 15:37   Re: Lag on Server despite trying different things
Reply With Quote #3

But the 2 servers combined are running only 20 slots.
Other than that, 2gb ram can't handle even 7..8 players before they start lagging?
lee_jay98 is offline
Mordekay
Squirrel of Fortune
Join Date: Apr 2006
Location: Germany
Old 05-14-2018 , 15:49   Re: Lag on Server despite trying different things
Reply With Quote #4

Check your task-manager. Win7 itself already uses around 1gig of RAM in idle. Not much left to handle a server. Once it starts to write parts onto your harddrive to free memory it starts to lag.
__________________

Mordekay is offline
lee_jay98
New Member
Join Date: May 2018
Old 05-14-2018 , 15:53   Re: Lag on Server despite trying different things
Reply With Quote #5

Quote:
Originally Posted by Mordekay View Post
Check your task-manager. Win7 itself already uses around 1gig of RAM in idle. Not much left to handle a server. Once it starts to write parts onto your harddrive to free memory it starts to lag.
I realize that, but i checked the performance tab and it still showed about 800mb free under ram when there were 7 player playing. So I assume ram shouldn't be a problem until there are more player, or am I wrong?
lee_jay98 is offline
Mordekay
Squirrel of Fortune
Join Date: Apr 2006
Location: Germany
Old 05-14-2018 , 16:08   Re: Lag on Server despite trying different things
Reply With Quote #6

Imo this is the bottleneck, but i can be wrong of course.
__________________

Mordekay is offline
lee_jay98
New Member
Join Date: May 2018
Old 05-15-2018 , 16:26   Re: Lag on Server despite trying different things
Reply With Quote #7

Any other suggestions/views?
lee_jay98 is offline
haZh
Member
Join Date: May 2017
Old 05-15-2018 , 23:18   Re: Lag on Server despite trying different things
Reply With Quote #8

Are you hosting and playing the game on the same PC? If so, not ideal to do that with that hardware.

Bring it down to 1 server. If both servers are popular, choose the one with more popularity.

Install Windows 10 32-bit instead of 64-bit as you have just 2GB RAM. And stop every bit of unwanted processes and services as most of it is just garbage for everyday use. Once you stop it all, your idle RAM usage will come close to 500 MB and you will have a dedicated of at least 1GB RAM free for the HLDS usage. So keep checking the task manager.

Check your server internet connection and make sure you don't have any idle network usage whatsoever. Not even a single usage shown in task manager. And then check speed, if it's not even 2mbits/s UP and DOWN, just forget about hosting a 20 slot server. For more details, refer here.

Are you sure that you can force a sv_maxrate "25000" as that much isn't supported by HLDS? None supported values fall back to default server values so that might be no use. Refer this.

Meanwhile try these values;

sys_ticrate "1000"
sv_maxrate "20000"
sv_minrate "20000"
sv_maxupdaterate "100"
sv_minupdaterate "30"

Forcing a sys_ticrate might be bad, but as you are a server hoster, try tweaking it or remove it completely in case it goes unstable.

Don't run too much HLDS plugins, this involves all types of plugins which I can't even type here. So first try hosting a classic style server with least plugins and check how it performs.

Run a media player like VLC on the Windows background, but not sure if this actually works. Else just dump it because it's annoying.

Overclock your CPU if possible, "do that at your own risk" and disable bullshit motherboard features that you don't really need. Check the airflow of your server PC, and temperature levels as it can cause the server performance to go haywire. Single core performance is really important for HLDS. Get a maximum clock DDR3 RAM stick if your motherboard supports it. Of course these solutions involve spending some money, if not forget about this.

Tried hard yet nothing? Try ReHLDS and follow the above.

Also don't panic when you see some random high pingers, it's just their crappy internet, not the server's fault.
__________________

Last edited by haZh; 05-15-2018 at 23:48.
haZh is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:21.


Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Theme made by Freecode