Raised This Month: $68 Target: $400
 17% 

Problem with Magneto


  
 
 
Thread Tools Display Modes
Author Message
StevnJ9971
Senior Member
Join Date: Sep 2006
Location: California
Old 01-02-2007 , 14:49   Problem with Magneto
#1

Code:
L 01/02/2007 - 10:55:54: Invalid player id 108
L 01/02/2007 - 10:55:54: [AMXX] Displaying debug trace (plugin "sh_magneto.amxx"
)
L 01/02/2007 - 10:55:54: [AMXX] Run time error 10: native error (native "get_use
r_weapons")
L 01/02/2007 - 10:55:54: [AMXX]    [0] sh_magneto.sma::magneto_disarm (line 120)

L 01/02/2007 - 10:55:54: [AMXX]    [1] sh_magneto.sma::magneto_damage (line 99)
Not sure what's wrong...
__________________
[IMG]http://img208.**************/img208/1706/userbar262772da7.gif[/IMG]
StevnJ9971 is offline
Send a message via AIM to StevnJ9971
StevnJ9971
Senior Member
Join Date: Sep 2006
Location: California
Old 01-02-2007 , 14:55   Re: Problem with Magneto
#2

And apparently now there's more:
Code:
L 01/02/2007 - 10:59:52: [ENGINE] Invalid entity 194
L 01/02/2007 - 10:59:52: [AMXX] Displaying debug trace (plugin "sh_magneto.amxx"
)
L 01/02/2007 - 10:59:52: [AMXX] Run time error 10: native error (native "entity_
get_vector")
L 01/02/2007 - 10:59:52: [AMXX]    [0] Vexd_Utilities.inc::Entvars_Get_Vector (l
ine 28)
L 01/02/2007 - 10:59:52: [AMXX]    [1] sh_magneto.sma::magneto_disarm (line 113)

L 01/02/2007 - 10:59:52: [AMXX]    [2] sh_magneto.sma::magneto_damage (line 99)
__________________
[IMG]http://img208.**************/img208/1706/userbar262772da7.gif[/IMG]
StevnJ9971 is offline
Send a message via AIM to StevnJ9971
Sidewinder
Senior Member
Join Date: Aug 2006
Old 01-02-2007 , 14:56   Re: Problem with Magneto
#3

is that with amxx 1.76c?
__________________
Sidewinder is offline
Send a message via AIM to Sidewinder Send a message via MSN to Sidewinder
StevnJ9971
Senior Member
Join Date: Sep 2006
Location: California
Old 01-02-2007 , 15:17   Re: Problem with Magneto
#4

Yes.
__________________
[IMG]http://img208.**************/img208/1706/userbar262772da7.gif[/IMG]
StevnJ9971 is offline
Send a message via AIM to StevnJ9971
vittu
SuperHero Moderator
Join Date: Oct 2004
Location: L.A. County, CA
Old 01-10-2007 , 21:37   Re: Problem with Magneto
#5

Add
Code:
if ( !is_user_alive(victim) ) return
just after line 110, will fix both problems.

Should add is_user_alive check line 92 also to avoid using magneto against dead clients.

-moving to bug reports. Please reply if any further issues after fix above.
vittu is offline
Send a message via AIM to vittu Send a message via MSN to vittu Send a message via Yahoo to vittu
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:54.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode