Raised This Month: $59 Target: $400
 14% 

Error on shaman


  
 
 
Thread Tools Display Modes
Author Message
infernal2
Member
Join Date: May 2006
Old 05-31-2006 , 08:00   Error on shaman
#1

Whell i hawe this error on shaman...dont know what else i can say if i write debug shaman dostn show in the menu wher u can chose heros ...
Code:
Invalid player id 0
[AMXX] Run time error 10 <plugin "sh_shaman.amxx"> - de bug not enabled
[AMXX] To enable debug mode, add "debug" after the plugin name in the plugins.ini <whitout quotes>
__________________
[img]ftp://84.237.128.247/Infernal.jpg[/img]
infernal2 is offline
Send a message via MSN to infernal2
D o o m
Veteran Member
Join Date: Sep 2005
Location: Germany
Old 06-01-2006 , 03:19  
#2

So in the plugins.ini stands
Code:
sh_shaman.amxx debug
?
If yes, it will work and if you write "debug", it's your own fault

I don't know another explanation (is this word right? *lol*).
__________________
Heroes
:+: Deadpool :+:
D o o m is offline
infernal2
Member
Join Date: May 2006
Old 06-01-2006 , 03:49  
#3

w8 so i didnt get it
when i hawe
sh_shaman.amxx debug it dosnt work compleatly and if
sh_shaman.amxx it givs me thos lines
__________________
[img]ftp://84.237.128.247/Infernal.jpg[/img]
infernal2 is offline
Send a message via MSN to infernal2
Emp`
AMX Mod X Plugin Approver
Join Date: Aug 2005
Location: Decapod 10
Old 06-01-2006 , 09:06  
#4

its an error in the hero, ill fix it when i get back from school
Emp` is offline
Send a message via AIM to Emp` Send a message via MSN to Emp` Send a message via Yahoo to Emp` Send a message via Skype™ to Emp`
infernal2
Member
Join Date: May 2006
Old 06-01-2006 , 09:45  
#5

ok ye thx cant w8 =]
__________________
[img]ftp://84.237.128.247/Infernal.jpg[/img]
infernal2 is offline
Send a message via MSN to infernal2
Emp`
AMX Mod X Plugin Approver
Join Date: Aug 2005
Location: Decapod 10
Old 06-01-2006 , 18:56  
#6

change line 145
Code:
	if ( is_user_alive(id) && id != attacker && gIsZombie[id] ) {
to
Code:
	if ( is_user_alive(id) && is_user_alive(attacker) && id != attacker && gIsZombie[id] ) {
that should fix it, tell me if it does
Emp` is offline
Send a message via AIM to Emp` Send a message via MSN to Emp` Send a message via Yahoo to Emp` Send a message via Skype™ to Emp`
infernal2
Member
Join Date: May 2006
Old 06-02-2006 , 08:09  
#7

thx emp evrything is a ok
__________________
[img]ftp://84.237.128.247/Infernal.jpg[/img]
infernal2 is offline
Send a message via MSN to infernal2
infernal2
Member
Join Date: May 2006
Old 06-04-2006 , 07:08  
#8

srry emp about that a ok think cuz whell it was ok but it started 2 show the same thing...
__________________
[img]ftp://84.237.128.247/Infernal.jpg[/img]
infernal2 is offline
Send a message via MSN to infernal2
Emp`
AMX Mod X Plugin Approver
Join Date: Aug 2005
Location: Decapod 10
Old 06-04-2006 , 12:16  
#9

enable debug and whats it print?
Emp` is offline
Send a message via AIM to Emp` Send a message via MSN to Emp` Send a message via Yahoo to Emp` Send a message via Skype™ to Emp`
infernal2
Member
Join Date: May 2006
Old 06-10-2006 , 13:32  
#10

so srry emp about the late replay

Code:
Invalid player id 0
[AMXX] Displaying debug trace <plugin "sh_shaman.amxx">

[AMXX] Run time error 10: native error <native "get_user_attacker">
[AMXX]    [0] sh_shaman.sma::Shaman_damage <line 143>
somthing like that
__________________
[img]ftp://84.237.128.247/Infernal.jpg[/img]
infernal2 is offline
Send a message via MSN to infernal2
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:45.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode