Raised This Month: $68 Target: $400
 17% 

[Editor] Sublime AMXX-Editor v2.2


Post New Thread Reply   
 
Thread Tools Display Modes
perforator
Junior Member
Join Date: Mar 2015
Old 06-27-2016 , 12:50   Re: [Editor] Sublime AMXX-Editor v1.7
Reply With Quote #11

//offtopic
Destro- what is the plugin "auto-mix" you write?)
It is a private plugin ot not?
Sorry for my bad english and offtopic!
perforator is offline
Destro-
Veteran Member
Join Date: Jun 2010
Location: echo $me->location();
Old 06-28-2016 , 22:55   Re: [Editor] Sublime AMXX-Editor v1.7
Reply With Quote #12

Update v1.8!

Quote:
- Bugs fixed
- New: compiler console highlight
I'm not sure other feature could be added in the future :S, should create more color schemes.


______________________________________


Quote:
Originally Posted by perforator View Post
Destro- what is the plugin "auto-mix" you write?)
It is a private plugin ot not?
Sorry for my bad english and offtopic!
is public source, but api is private
auto_mix.sma
__________________

Last edited by Destro-; 06-28-2016 at 23:11.
Destro- is offline
addons_zz
Veteran Member
Join Date: Aug 2015
Location: Dreams, zz
Old 06-29-2016 , 15:10   Re: [Editor] Sublime AMXX-Editor v1.7
Reply With Quote #13

Quote:
Originally Posted by Destro- View Post
Update v1.8!
Hi,

When I use the Syntax 'AMXX-Pawn' or any other on 'View -> Syntax -> amxmodx', it ignores the any other theme I use, including the 'Preferences -> Color Scheme -> amxmodx -> white-pawn'.
Hence, it is always the theme 'amxmodx -> dark-pawn' when using the amxmodx's syntaxes.
__________________
Plugin: Sublime Text Studio , Galileo
Multi-Mod: Manager / Plugin / Server

Help the AlliedModders' website stay online!
addons_zz is offline
KliPPy
AlliedModders Donor
Join Date: May 2013
Location: Serbia
Old 06-29-2016 , 15:15   Re: [Editor] Sublime AMXX-Editor v1.7
Reply With Quote #14

Go to Preferences > Browse Packages... and then open User/amxx-pawn.sublime-settings and comment out "color_scheme" keyvalue in there.
KliPPy is offline
addons_zz
Veteran Member
Join Date: Aug 2015
Location: Dreams, zz
Old 06-29-2016 , 17:32   Re: [Editor] Sublime AMXX-Editor v1.7
Reply With Quote #15

Quote:
Originally Posted by KliPPy View Post
Go to Preferences > Browse Packages... and then open User/amxx-pawn.sublime-settings and comment out "color_scheme" keyvalue in there.
This created another error, and it stills doing it. And when removed the line:
Code:
Sublime Text
AMXX-Editor:
You are not set correctly settings for AMXX-Editor.
No has configurado correctamente el AMXX-Editor.

Error loading colour scheme Packages/amxmodx/-pawn.tmTheme: Unable to open Packages/amxmodx/-pawn.tmTheme
__________________
Plugin: Sublime Text Studio , Galileo
Multi-Mod: Manager / Plugin / Server

Help the AlliedModders' website stay online!

Last edited by addons_zz; 06-29-2016 at 17:43. Reason: update
addons_zz is offline
Destro-
Veteran Member
Join Date: Jun 2010
Location: echo $me->location();
Old 06-29-2016 , 17:45   Re: [Editor] Sublime AMXX-Editor v1.7
Reply With Quote #16

The use of color schemes for general language will not work with AMXX-Pawn syntax.
To switch between color schemes especially for AMXX-Pawn:
AmxMod-X -> Edit User Settings:
change the key "color_scheme": "dark"

Make a color scheme:
- Extract "dark-pawn.tmTheme" and "dark-popup.css" from "amxmodx.sublime-package" (this is a zip file).
- Edit colors and change the "dark" from file's name.
- Import to "amxmodx.sublime-package" or go to Preferences -> Browse Packages and copy files in amxmodx folder.
- AmxMod-X -> Edit User Settings: change "color_scheme"
__________________

Last edited by Destro-; 06-29-2016 at 17:48.
Destro- is offline
Depresie
Veteran Member
Join Date: Nov 2013
Old 07-07-2016 , 17:29   Re: [Editor] Sublime AMXX-Editor v1.8
Reply With Quote #17

@destro

Adding support for amxmodx to an editor which require PAYMENT... facepalm ?

Yet, we have amxx studio, which all it needs is few bugs to be fixed and a nice dark skin to be added...

And btw, the include path is not working, i set up the path to my include folder, yet i get no autocompletion/highlighting/suggestion what ever from my custom includes when im writing the beginning of a native

@addons_zz

Ey you, fucker, you have knowledge outside of pawn, why don't you do something useful and make us a nice editor instead of a 20.000 lines plugin just for map changing ?
__________________

Last edited by Depresie; 07-07-2016 at 18:02.
Depresie is offline
KliPPy
AlliedModders Donor
Join Date: May 2013
Location: Serbia
Old 07-07-2016 , 18:27   Re: [Editor] Sublime AMXX-Editor v1.8
Reply With Quote #18

Quote:
Originally Posted by Depresie View Post
@destro
Adding support for amxmodx to an editor which require PAYMENT... facepalm ?
It doesn't require payment... Just download it from the official site and use it.

Quote:
Originally Posted by Depresie View Post
And btw, the include path is not working, i set up the path to my include folder, yet i get no autocompletion/highlighting/suggestion what ever from my custom includes when im writing the beginning of a native
So you must be doing something wrong, most likely.

Last edited by KliPPy; 07-07-2016 at 18:28.
KliPPy is offline
Depresie
Veteran Member
Join Date: Nov 2013
Old 07-07-2016 , 18:37   Re: [Editor] Sublime AMXX-Editor v1.8
Reply With Quote #19

AmxModX -> Edit User Settings ->
PHP Code:
"include_directory":    "C:\\Users\\PC\\Desktop\\TESTER\\cstrike\\addons\\amxmodx\\scripting\\include",    // Path to includes folder 
Also i have no ideea how to set up the output folder

PHP Code:
"output_directory":     "${file_path}"
Also, it doesn't even show suggestions for plugin_precache or plugin_cfg only plugin_init ...
__________________

Last edited by Depresie; 07-07-2016 at 18:40.
Depresie is offline
addons_zz
Veteran Member
Join Date: Aug 2015
Location: Dreams, zz
Old 07-07-2016 , 20:35   Re: [Editor] Sublime AMXX-Editor v1.8
Reply With Quote #20

Quote:
Originally Posted by Depresie View Post
@addons_zz

Ey you, fucker, you have knowledge outside of pawn, why don't you do something useful and make us a nice editor instead of a 20.000 lines plugin just for map changing ?
I already have I my good editor. It is Notepad++ (with a lot of plugins). It is compatible with every languages and platforms. Of course I miss some times the 'Eclipse' or those 'JetBrains' IDEs, auto-completion and all that fussy; picky; choosy. So, I can think about using them some times for somethings when I am programming on they supported languages. For the rest/other languages, it is Notepad++ almost for sure.

I tried to use sublime as main editor, but his coloring syntax, his search and replaced, and other things could be less powerful/useful. Of course, it has its qualities or plugins, however those little things were boring. But it was an good complementary editor to load the configurations and other less used files.
__________________
Plugin: Sublime Text Studio , Galileo
Multi-Mod: Manager / Plugin / Server

Help the AlliedModders' website stay online!

Last edited by addons_zz; 07-07-2016 at 20:37. Reason: misspellings
addons_zz is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:58.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode