Raised This Month: $ Target: $400
 0% 

[ANY] Log Connections


Post New Thread Reply   
 
Thread Tools Display Modes
maxolahird
Veteran Member
Join Date: Dec 2012
Old 04-08-2013 , 16:00   Re: [ANY] Log Connections
Reply With Quote #21

this is logging every player twice

045:24 PM - <Gamobe> <STEAM_0:1:46955927> <177.141.184.44> CONNECTED from <Brazil>
045:24 PM - <Gamobe> <STEAM_0:1:46955927> <177.141.184.44> CONNECTED from <Brazil>
047:55 PM - <Gamobe> <STEAM_0:1:46955927> <177.141.184.44> DISCONNECTED after 3 minutes. <Gamobe timed out>
047:55 PM - <Gamobe> <STEAM_0:1:46955927> <177.141.184.44> DISCONNECTED after 3 minutes. <Gamobe timed out>
0494 PM - <Gamobe> <Unknown SteamID> <177.141.184.44> DISCONNECTED after -1 minutes. <Gamobe timed out>
0494 PM - <Gamobe> <Unknown SteamID> <177.141.184.44> DISCONNECTED after -1 minutes. <Gamobe timed out>
maxolahird is offline
vodka00
Veteran Member
Join Date: Jun 2012
Location: Los Angeles
Old 10-26-2013 , 16:41   Re: [ANY] Log Connections
Reply With Quote #22

Would be nice to have an option to log either daily or on every mapchange.
__________________
cw main:

cw speedruns:
vodka00 is offline
jeezz
Senior Member
Join Date: Apr 2012
Location: netherlands
Old 02-10-2014 , 04:03   Re: [ANY] Log Connections
Reply With Quote #23

yes twice, could it be fixed?
jeezz is offline
Azet
Member
Join Date: Oct 2013
Old 05-26-2014 , 10:26   Re: [ANY] Log Connections
Reply With Quote #24

Code:
L 05/26/2014 - 16:13:50: SourceMod error session started
L 05/26/2014 - 16:13:50: Info (map "de_dust2") (file "errors_20140526.log")
L 05/26/2014 - 16:13:50: [SM] Plugin encountered error 25: Call was aborted
L 05/26/2014 - 16:13:50: [SM] Native "SetFailState" reported: Failed to create directory at /sourcemod/logs/connections - Please manually create that path and reload this plugin.
L 05/26/2014 - 16:13:50: [SM] Displaying call stack trace for plugin "logconnections.smx":
L 05/26/2014 - 16:13:50: [SM]   [0]  Line 27, /home/groups/alliedmodders/forums/files/1/7/9/3/9/7/115447.attach::OnPluginStart()
L 05/26/2014 - 16:13:51: [SM] Native "ReadFileLine" reported: Invalid file handle 0 (error 4)
Azet is offline
Dr. McKay
Sir Dr. SourceMod Plugin Approver Esq. Ltd. M.D. PhD
Join Date: Aug 2011
Location: Atlantis
Old 05-26-2014 , 13:59   Re: [ANY] Log Connections
Reply With Quote #25

Quote:
Originally Posted by Azet View Post
Code:
L 05/26/2014 - 16:13:50: SourceMod error session started
L 05/26/2014 - 16:13:50: Info (map "de_dust2") (file "errors_20140526.log")
L 05/26/2014 - 16:13:50: [SM] Plugin encountered error 25: Call was aborted
L 05/26/2014 - 16:13:50: [SM] Native "SetFailState" reported: Failed to create directory at /sourcemod/logs/connections - Please manually create that path and reload this plugin.
L 05/26/2014 - 16:13:50: [SM] Displaying call stack trace for plugin "logconnections.smx":
L 05/26/2014 - 16:13:50: [SM]   [0]  Line 27, /home/groups/alliedmodders/forums/files/1/7/9/3/9/7/115447.attach::OnPluginStart()
L 05/26/2014 - 16:13:51: [SM] Native "ReadFileLine" reported: Invalid file handle 0 (error 4)
See:

Quote:
Failed to create directory at /sourcemod/logs/connections - Please manually create that path and reload this plugin.
Make a "connections" folder under /addons/sourcemod/logs.
__________________
Dr. McKay is offline
Azet
Member
Join Date: Oct 2013
Old 05-26-2014 , 14:06   Re: [ANY] Log Connections
Reply With Quote #26

I did it before I posted. Doesn't seem to work.
Azet is offline
Wolfseye
Senior Member
Join Date: Apr 2014
Location: Germany
Old 06-02-2014 , 06:35   Re: [ANY] Log Connections
Reply With Quote #27

Tried this today on my INSURGENCY (Standalone) Server, and it seems not to have any effect. Created the folder "connections" in my Sourcemod log folder. Nothing happens. Also no error that something cannot be created.

Did I miss something else ?

Wolfseye

P.S: Solved now. After reading this post (https://forums.alliedmods.net/showpo...4&postcount=17) I got it working. ;)

Last edited by Wolfseye; 06-02-2014 at 06:48.
Wolfseye is offline
Send a message via Skype™ to Wolfseye
Wolfseye
Senior Member
Join Date: Apr 2014
Location: Germany
Old 06-02-2014 , 11:33   Re: [ANY] Log Connections
Reply With Quote #28

But I have to confirm a other post from before, where it says that the logs have each connect and disconnect double posts those lines.

Code:
13:46:22 - <Sai[N]T> <STEAM_1:0:48252314> <188.134.88.173> CONNECTED from <Russian Federation>
13:46:22 - <Sai[N]T> <STEAM_1:0:48252314> <188.134.88.173> CONNECTED from <Russian Federation>
Code:
14:00:56 - <Sai[N]T> <STEAM_1:0:48252314> <188.134.88.173> DISCONNECTED after 15 minutes. <#DisconnectReason_DisconnectByUser>
14:00:56 - <Sai[N]T> <STEAM_1:0:48252314> <188.134.88.173> DISCONNECTED after 15 minutes. <#DisconnectReason_DisconnectByUser>
Anyone knows why and maybe how to fix this ?

Thanks in advance.

Wolfseye
Wolfseye is offline
Send a message via Skype™ to Wolfseye
Sarona
AlliedModders Donor
Join Date: Jul 2012
Old 06-08-2014 , 04:49   Re: [ANY] Log Connections
Reply With Quote #29

Twe Suggestions: Create a Cvar for Auto-delete logs after "X" days. And add support for UTF-8 names.

Last edited by Sarona; 07-05-2014 at 05:20.
Sarona is offline
allienaded
AlliedModders Donor
Join Date: Feb 2013
Old 08-17-2014 , 10:29   Re: [ANY] Log Connections
Reply With Quote #30

I've made this basic plugin for my own server that just logs connections/disconnections (name, steamid, IP) and map changes in one file named Connections.log. This does not have the double logging bug.

What the log entries look like:
Code:
L 08/16/2014 - 14:53:18: -------- Mapchange to de_nuke --------
L 08/16/2014 - 14:53:18: Player 1<4><STEAM_1:0:********><><85.***.**.***> connected.
L 08/16/2014 - 15:01:33: Player 2<14><STEAM_1:0:********><><5.***.***.**> connected.
L 08/16/2014 - 15:01:59: Player 2<14><STEAM_1:0:********><><5.***.***.**> disconnected.
L 08/16/2014 - 15:15:53: Player 1<4><STEAM_1:0:********><><85.***.**.***> disconnected.
Source:
Spoiler

Source (old version):
Spoiler
Attached Files
File Type: sp Get Plugin or Get Source (connectionlogger.sp - 613 views - 1.1 KB)

Last edited by allienaded; 10-08-2014 at 21:37. Reason: Updated plugin to work more reliably with Sourcemod 1.6.x
allienaded is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 21:43.


Powered by vBulletin®
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Theme made by Freecode