Raised This Month: $7 Target: $400
 1% 

Half-Life GunGame


Post New Thread Reply   
 
Thread Tools Display Modes
DJEarthQuake
Veteran Member
Join Date: Jan 2014
Location: Astral planes
Old 01-10-2019 , 15:17   Re: Half-Life GunGame
Reply With Quote #111

It's strictly a Windows client side issue when the server is Gearbox / OP4. I just realized how old this was after that last comment. You are welcome. Thanks for response.

[AMXX] Run time error 10 (plugin "gungame.amxx") (native "callfunc_begin_i") - debug not enabled!

Commenting out the 2 lines as posted just prolongs the Windows client crash. Instead of Satchel they crash 1 up on tripmine.
No bots. We had 10 reals. I strip down mod so nothing else is running to interfere. I have a long list of disabled plugins just to test this.

L 01/10/2019 - 15:53:54: Public function -1 is invalid
L 01/10/2019 - 15:53:54: [AMXX] Displaying debug trace (plugin "testing/gungame.amxx", version "2.1")
L 01/10/2019 - 15:53:54: [AMXX] Run time error 10: native error (native "callfunc_begin_i")
L 01/10/2019 - 15:53:54: [AMXX] [0] gungame.sma::start_map_vote (line 3626)
L 01/10/2019 - 15:53:54: [AMXX] [1] gungame.sma::endgame (line 3815)
L 01/10/2019 - 15:53:54: [AMXX] [2] gungame.sma::Equip_PlayerWithWeapon (line 2429)
L 01/10/2019 - 15:53:54: [AMXX] [3] gungame.sma::ReEquip_Player (line 2329)
__________________
"It's not the actual programming that's interesting. But it's what you can accomplish with the end results that are important." -Dennis Ritchie
"Mathematics, rightly viewed, possesses not only truth, but supreme beauty a beauty cold and austere, like that of sculpture..." -Bertrand Russell

Last edited by DJEarthQuake; 01-10-2019 at 17:09. Reason: Debug log
DJEarthQuake is offline
GordonFreeman (RU)
Veteran Member
Join Date: Jan 2010
Location: Uzbekistan
Old 01-11-2019 , 10:00   Re: Half-Life GunGame
Reply With Quote #112

Quote:
Originally Posted by DJEarthQuake View Post
Commenting out the 2 lines as posted just prolongs the Windows client crash. Instead of Satchel they crash 1 up on tripmine.
turning off StatusIcon might help
Quote:
Originally Posted by gungame.ini
Code:
gg_icon_enable" "0"
Quote:
Originally Posted by DJEarthQuake View Post
L 01/10/2019 - 15:53:54: Public function -1 is invalid
L 01/10/2019 - 15:53:54: [AMXX] Displaying debug trace (plugin "testing/gungame.amxx", version "2.1")
L 01/10/2019 - 15:53:54: [AMXX] Run time error 10: native error (native "callfunc_begin_i")
L 01/10/2019 - 15:53:54: [AMXX] [0] gungame.sma::start_map_vote (line 3626)
this one is about disabled mapchooser plugin
__________________
The functional way is the right way

Last edited by GordonFreeman (RU); 01-11-2019 at 10:05.
GordonFreeman (RU) is offline
DJEarthQuake
Veteran Member
Join Date: Jan 2014
Location: Astral planes
Old 01-11-2019 , 19:25   Re: Half-Life GunGame
Reply With Quote #113

// draw 3 next levels in hud
// if(!playersData[id][PLAYER_BOT])
// Draw_LevelsInHud(id,3) // TODO: cvar ?


The original suggestion should have done it. Sorry about that. I failed to copy the recompile properly.

I did make a couple other adjustments like put skips in. That speeds up the game by reducing levels. Windows pops after so many levels was initial bug. The Windows player was able to play all the rounds with recompile and skips added. I am retrying with icon back to 1. The non-standard mapchooser I coded into the plugin and it is working fine now too. Thank you.
__________________
"It's not the actual programming that's interesting. But it's what you can accomplish with the end results that are important." -Dennis Ritchie
"Mathematics, rightly viewed, possesses not only truth, but supreme beauty a beauty cold and austere, like that of sculpture..." -Bertrand Russell
DJEarthQuake is offline
DJEarthQuake
Veteran Member
Join Date: Jan 2014
Location: Astral planes
Old 05-14-2019 , 19:07   Re: Half-Life GunGame
Reply With Quote #114

Everything has been super stable both client-side and server-side.
  • One small bug is if somebody is touching ceiling or wall they have to reconnect at warm-up end. They spawn stuck or can not respawn because of the pev flag, FL_FROZEN. When removed the effect/issue vanishes. FL_FROZEN is still nice on game end.
  • Since upgrading to AMX1.9.0 / not using Galileo, the map vote stopped being triggered.

Amx log showed it was using 0 or auto-detect as it was compiled and ignoring the INI parameter of 3 for custom votemap command.
Recompile made it work. Is this by chance AMXX 1.9.0 related or something else?
Code:
487         cvar[CVAR_MAPCHOOSER_TYPE] = register_cvar("gg_mapchooser_type","3")

You've already used this technique on this mod to suppress compiler warnings.
This eliminates a handful in a row.
Code:
1395          #if AMXX_VERSION_NUM < 190 1396 #define ITEM_FLAG_SELECTONEMPTY       1 1397 #define ITEM_FLAG_NOAUTORELOAD        2 1398 #define ITEM_FLAG_NOAUTOSWITCHEMPTY   4 1399 #define ITEM_FLAG_LIMITINWORLD        8 1400 #define ITEM_FLAG_EXHAUSTIBLE        16 1401         #endif
__________________
"It's not the actual programming that's interesting. But it's what you can accomplish with the end results that are important." -Dennis Ritchie
"Mathematics, rightly viewed, possesses not only truth, but supreme beauty a beauty cold and austere, like that of sculpture..." -Bertrand Russell

Last edited by DJEarthQuake; 05-15-2019 at 04:05. Reason: Freeze and reconnect fix
DJEarthQuake is offline
DJEarthQuake
Veteran Member
Join Date: Jan 2014
Location: Astral planes
Old 11-21-2019 , 03:45   Re: Half-Life GunGame
Reply With Quote #115

This should clear up crashing without commenting lines out. Bools were being used as integers half a dozen times.

bool:EQUIP_FULL_PRIMARY,
bool:EQUIP_FULL_SECONDARY,

tag mismatch
lines 1800-1819

Replace
Code:
equipItem[EQUIP_FULL_PRIMARY] = 1
Code:
equipItem[EQUIP_FULL_PRIMARY] = true

Code:
equipItem[EQUIP_FULL_SECONDARY] = 1
Code:
equipItem[EQUIP_FULL_SECONDARY] = true

From float to integer.
Code:
equipItem[EQUIP_CLIP] = -1.0
Code:
equipItem[EQUIP_CLIP] = -1

Code:
//      playersData[id][PLAYER_BOT] = if(is_user_bot(id))         if(is_user_bot(id)){         switch(0,1){         case 0 : playersData[id][PLAYER_BOT] = false         case 1 : playersData[id][PLAYER_BOT] = true         }         }
__________________
"It's not the actual programming that's interesting. But it's what you can accomplish with the end results that are important." -Dennis Ritchie
"Mathematics, rightly viewed, possesses not only truth, but supreme beauty a beauty cold and austere, like that of sculpture..." -Bertrand Russell

Last edited by DJEarthQuake; 05-30-2020 at 03:01. Reason: typo
DJEarthQuake is offline
DJEarthQuake
Veteran Member
Join Date: Jan 2014
Location: Astral planes
Old 05-05-2020 , 15:31   Re: Half-Life GunGame
Reply With Quote #116

Wow almost forget to update. The OP4 crash was traced to setting monster_penguin instead of weapon_penguin. It's hard to find Windows clients who are willing to test.

Giving a player just the ent instead the weapon on INI file. Things get really interesting.
__________________
"It's not the actual programming that's interesting. But it's what you can accomplish with the end results that are important." -Dennis Ritchie
"Mathematics, rightly viewed, possesses not only truth, but supreme beauty a beauty cold and austere, like that of sculpture..." -Bertrand Russell
DJEarthQuake is offline
TheScaryGuy
Junior Member
Join Date: May 2020
Old 05-20-2020 , 12:27   Re: Half-Life GunGame
Reply With Quote #117

I'm having a hard time trying to figure out how to get gungame working for Day of Defeat. I've followed all of the steps, yet it doesn't run. What can I do to solve this problem?
TheScaryGuy is offline
DJEarthQuake
Veteran Member
Join Date: Jan 2014
Location: Astral planes
Old 05-20-2020 , 13:22   Re: Half-Life GunGame
Reply With Quote #118

Quote:
Originally Posted by TheScaryGuy View Post
I'm having a hard time trying to figure out how to get gungame working for Day of Defeat. I've followed all of the steps, yet it doesn't run. What can I do to solve this problem?
Code:
Run time error 10: native error (native "ArraySize")

Wrong size array on block items. Now it's working. It needs more work with block items as I simply bypassed the part it was stumbling on. Block items. DoD isn't like HL with tons of spawn stuff on the ground anyway.
__________________
"It's not the actual programming that's interesting. But it's what you can accomplish with the end results that are important." -Dennis Ritchie
"Mathematics, rightly viewed, possesses not only truth, but supreme beauty a beauty cold and austere, like that of sculpture..." -Bertrand Russell

Last edited by DJEarthQuake; 05-30-2020 at 03:02. Reason: Remove SMA until finished.
DJEarthQuake is offline
TheScaryGuy
Junior Member
Join Date: May 2020
Old 05-27-2020 , 19:13   Re: Half-Life GunGame
Reply With Quote #119

Quote:
Originally Posted by DJEarthQuake View Post
Code:
Run time error 10: native error (native "ArraySize")

Wrong size array on block items. Now it's working. It needs more work with block items as I simply bypassed the part it was stumbling on. Block items. DoD isn't like HL with tons of spawn stuff on the ground anyway.
I'm getting this error when I click on the plugin:
Quote:
Plugin failed to compile! Please try contacting the author.
Welcome to the AMX Mod X 1.8.1-300 Compiler.
Copyright (c) 1997-2006 ITB CompuPhase, AMX Mod X Team

/home/forums/content/files/2/4/5/4/3/0/181549.attach(751) : error 029: invalid expression, assumed zero
/home/forums/content/files/2/4/5/4/3/0/181549.attach(751 -- 755) : error 008: must be a constant expression; assumed zero

2 Errors.
Could not locate output file /home/groups/amxmodx/public_html/compiled3/181549.amx (compile failed).
Trying to compile the sma, I got this:
Quote:
//AMXXPC compile.exe
// by the AMX Mod X Dev Team


//// gungame2020.sma
// H:\Documents-C\E\HL1\DoD\TEK\dod\addons\amxmodx\scripting\ gungame2020.sma(751) : error 029: invalid expression, assumed zero
// H:\Documents-C\E\HL1\DoD\TEK\dod\addons\amxmodx\scripting\ gungame2020.sma(751 -- 755) : error 008: must be a constant expression; assumed zero
//
// 2 Errors.
// Could not locate output file H:\Documents-C\E\HL1\DoD\TEK\dod\addons\amxmodx\scripting\ compiled\gungame2020.amx (compile failed).
//
// Compilation Time: 0.75 sec
// ----------------------------------------

Press enter to exit ...

Last edited by TheScaryGuy; 05-27-2020 at 19:23.
TheScaryGuy is offline
DJEarthQuake
Veteran Member
Join Date: Jan 2014
Location: Astral planes
Old 05-28-2020 , 01:46   Re: Half-Life GunGame
Reply With Quote #120

He only supports 1.8.2. I did it for the newer Amxx. When I compiled it on 1.10 and got it to load on DoD I noticed it did not have a bottomless clip but it did load. All the other stuff I ran into was a Windows crash for the clients on Gearbox. Luckily I never experienced the crash but lots of complaints came my way. Bypassing the next weapon HUD did handle it.
__________________
"It's not the actual programming that's interesting. But it's what you can accomplish with the end results that are important." -Dennis Ritchie
"Mathematics, rightly viewed, possesses not only truth, but supreme beauty a beauty cold and austere, like that of sculpture..." -Bertrand Russell
DJEarthQuake is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:51.


Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Theme made by Freecode