Raised This Month: $ Target: $400
 0% 

Issue with my dev environment, during compile it cannot find files


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
stece
Junior Member
Join Date: May 2021
Old 05-03-2022 , 14:37   Issue with my dev environment, during compile it cannot find files
Reply With Quote #1

A while ago we started writing a Sourcemod, originally our sourcemod dependencies were just in the include folder of our project.

After a while, we divided our include folder into include/engine containing sourcemod and include/thirdparty to include other libraries.

On my computer, Visiual Studio is unable to compile. It gives an error:
Code:
\scripting\include\engine/json.inc(40) : fatal error 183: cannot read from file: "json/definitions"
Which basically is that it doesn't find the correct files in the include/engine/json folder, while it most definitely is there.

My co-author doesn't have this issue and doesn't remember changing any config. So I don't understand why I'm having issues. Is there a config for the Visual Studio Sourcemod plugin where you need to change a sourcemod path or something? I've checked and don't see any. :/
stece is offline
asherkin
SourceMod Developer
Join Date: Aug 2009
Location: OnGameFrame()
Old 05-04-2022 , 09:24   Re: Issue with my dev environment, during compile it cannot find files
Reply With Quote #2

The relative include path behaviour is different pre-1.11 between Linux and Windows (due to a bug).
__________________
asherkin is offline
stece
Junior Member
Join Date: May 2021
Old 05-05-2022 , 02:51   Re: Issue with my dev environment, during compile it cannot find files
Reply With Quote #3

Quote:
Originally Posted by asherkin View Post
The relative include path behaviour is different pre-1.11 between Linux and Windows (due to a bug).
Can I change it somewhere?
stece is offline
nosoop
Veteran Member
Join Date: Aug 2014
Old 05-07-2022 , 07:58   Re: Issue with my dev environment, during compile it cannot find files
Reply With Quote #4

My preferred approach here is to have third-party includes in a separate directory within the project, then pass -i to specify the additional include paths.

Not sure how well your IDE of choice handles project-specific compile flags though; I have my own mostly free-standing build tooling for it.
__________________
I do TF2, TF2 servers, and TF2 plugins.
I don't do DMs over Discord -- PM me on the forums regarding inquiries.
AlliedModders Releases / Github / TF2 Server / Donate (BTC / BCH / coffee)
nosoop is offline
Bacardi
Veteran Member
Join Date: Jan 2010
Location: mom's basement
Old 05-07-2022 , 13:37   Re: Issue with my dev environment, during compile it cannot find files
Reply With Quote #5

...pure guess.
From project "properties", try add folder in here "Additional Include Directories"
Name:  Desktop Screenshot 2022.05.07 - 20.33.18.66.jpg
Views: 31
Size:  94.8 KB
__________________
Do not Private Message @me
Bacardi is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 18:45.


Powered by vBulletin®
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Theme made by Freecode