Raised This Month: $ Target: $400
 0% 

[L4D & L4D2] Use Priority Patch (2.6) [05-May-2024]


Post New Thread Reply   
 
Thread Tools Display Modes
Jerry_21
Member
Join Date: Jun 2017
Old 04-20-2024 , 21:37   Re: [L4D & L4D2] Use Priority Patch (2.5) [22-Nov-2022]
Reply With Quote #31

Quote:
Originally Posted by Silvers View Post
Which game, which OS? Shouldn't be happening. You have a duplicate of the plugin running or another plugin detouring this function?
I get exactly the same error, this for L4D1,
operating system: windows
local server.
Jerry_21 is offline
Silvers
SourceMod Plugin Approver
Join Date: Aug 2010
Location: SpaceX
Old 04-21-2024 , 04:55   Re: [L4D & L4D2] Use Priority Patch (2.5) [22-Nov-2022]
Reply With Quote #32

Maybe local server issue then, SourceMod isn't supported on Local servers and I won't support either. If someone else wants to find the signature for that go ahead and post it.
__________________
Silvers is offline
Jerry_21
Member
Join Date: Jun 2017
Old 04-21-2024 , 13:11   Re: [L4D & L4D2] Use Priority Patch (2.5) [22-Nov-2022]
Reply With Quote #33

Quote:
Originally Posted by Silvers View Post
Maybe local server issue then, SourceMod isn't supported on Local servers and I won't support either. If someone else wants to find the signature for that go ahead and post it.
No problem. Personally, I don't play l4d1, only l4d2. I was making a package of add-ons for a friend who still plays l4d1 but I see that it is more complicated than I thought since I still have a crash and I better leave it alone. It should be noted that this plugin for l4d2 has no flaws even if it is a local server. As a final comment, I am delighted with the great work you do creating and sharing your accessories. good day.
Jerry_21 is offline
Silvers
SourceMod Plugin Approver
Join Date: Aug 2010
Location: SpaceX
Old 04-29-2024 , 06:27   Re: [L4D & L4D2] Use Priority Patch (2.5a) [29-Apr-2024]
Reply With Quote #34

Looks like the latest L4D1 update broke the signature for Windows, and I guess I didn't update my server when testing.

So here, maybe this works on Listen servers too.

Code:
2.5a (29-Apr-2024)
    - Fixed Windows L4D1 signature.
__________________
Silvers is offline
Jerry_21
Member
Join Date: Jun 2017
Old 04-29-2024 , 23:40   Re: [L4D & L4D2] Use Priority Patch (2.5a) [29-Apr-2024]
Reply With Quote #35

Quote:
Originally Posted by Silvers View Post
Looks like the latest L4D1 update broke the signature for Windows, and I guess I didn't update my server when testing.

So here, maybe this works on Listen servers too.

Code:
2.5a (29-Apr-2024)
    - Fixed Windows L4D1 signature.
I added this plugin and the game crashed. There are no error logs, when you remove it the game works normally. This for L4D1
Jerry_21 is offline
HarryPotter
Veteran Member
Join Date: Sep 2017
Location: Taiwan, Asia
Old 05-01-2024 , 07:28   Re: [L4D & L4D2] Use Priority Patch (2.5a) [29-Apr-2024]
Reply With Quote #36

Quote:
Originally Posted by Jerry_21 View Post
I added this plugin and the game crashed. There are no error logs, when you remove it the game works normally. This for L4D1
I install this plugin in l4d1 too, no crash

maybe just not compatible with local sv
__________________

Last edited by HarryPotter; 05-01-2024 at 07:29.
HarryPotter is offline
Jerry_21
Member
Join Date: Jun 2017
Old 05-01-2024 , 12:07   Re: [L4D & L4D2] Use Priority Patch (2.5a) [29-Apr-2024]
Reply With Quote #37

Quote:
Originally Posted by HarryPotter View Post
I install this plugin in l4d1 too, no crash

maybe just not compatible with local sv
Thank you, Harry. Maybe it will work differently for L4D1 since in L4D2 I have this bug-free plugin. It's the answer I was looking for how this plugin worked on a dedicated server.
Jerry_21 is offline
HarryPotter
Veteran Member
Join Date: Sep 2017
Location: Taiwan, Asia
Old 05-01-2024 , 21:52   Re: [L4D & L4D2] Use Priority Patch (2.5a) [29-Apr-2024]
Reply With Quote #38

There is a l4d1 update today, breaks the windows (linux is fine)

Code:
L 05/02/2024 - 09:48:46: [SM] Exception reported: Failed to find "CBaseEntity::GetUsePriority" signature.
L 05/02/2024 - 09:48:46: [SM] Blaming: l4d_use_priority.smx
L 05/02/2024 - 09:48:46: [SM] Call stack trace:
L 05/02/2024 - 09:48:46: [SM]   [0] SetFailState
L 05/02/2024 - 09:48:46: [SM]   [1] Line 117, d:\Github\scripting_1.11\l4d_use_priority.sp::OnPluginStart
L 05/02/2024 - 09:48:46: [SM] Unable to load plugin "l4d_use_priority.smx": Error detected in plugin startup (see error logs)
L 05/02/2024 - 09:48:57: Error log file session closed.
__________________

Last edited by HarryPotter; 05-05-2024 at 07:38.
HarryPotter is offline
Silvers
SourceMod Plugin Approver
Join Date: Aug 2010
Location: SpaceX
Old 05-05-2024 , 16:53   Re: [L4D & L4D2] Use Priority Patch (2.6) [05-May-2024]
Reply With Quote #39

Code:
2.6 (05-May-2024)
    - Switched to using VTable offsets for L4D1 and L4D2 on Windows - due to signatures always breaking. Thanks to "Bakugo" and Arona" for info.
    - Plugin and GameData file updated.
__________________
Silvers is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:02.


Powered by vBulletin®
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Theme made by Freecode