Raised This Month: $28 Target: $400
 7% 

When updating to a newer sourcemod version, I get an error when loading sm plugins


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
Xred
Junior Member
Join Date: Aug 2019
Old 01-16-2020 , 20:27   When updating to a newer sourcemod version, I get an error when loading sm plugins
Reply With Quote #1

When upgrading to a newer sourcemod following steps from https://wiki.alliedmods.net/Upgrading_SourceMod, weird things happen. Plugins coming with sourcemod all get the same error when loading:

Unable to load plugin (no debug string table).

This, of course, means that my admins and I are unable to open the admin menu, and no one has permission to do any commands from plugins defaulting to a higher flag.
Having limited experience in sourcemod, I am unsure of what to do. While using a backup up my server works, it irks me knowing I am being forced to use an earlier version of sourcemod, any tips?
Xred is offline
Silvers
AlliedModders Donor
Join Date: Aug 2010
Location: SpaceX
Old 01-16-2020 , 21:28   Re: When updating to a newer sourcemod version, I get an error when loading sm plugin
Reply With Quote #2

You're updating from what version to what version? Post your "sm version" and "sm exts list" results, maybe "sm plugins list" too.

It sounds like you haven't updated the /sourcemod/bin/ files, or extensions. Running plugins made for 1.10 on a SourceMod version that's < 1.10 cause this error to show up.
__________________
Silvers is offline
Xred
Junior Member
Join Date: Aug 2019
Old 01-16-2020 , 21:50   Re: When updating to a newer sourcemod version, I get an error when loading sm plugin
Reply With Quote #3

When doing "sm version"

SourceMod Version Information:
SourceMod Version: 1.9.0.6281
SourcePawn Engine: 1.9.0.6281, jit-x86 (build 1.9.0.6281)
SourcePawn API: v1 = 4, v2 = 12
Compiled on: May 14 2019 16:03:05
Built from: https://github.com/alliedmodders/sou...commit/c5efe48
Build ID: 6281:c5efe48

When doing "sm exts list"

[SM] Displaying 16 extensions:
[01] Automatic Updater (1.9.0.6281): Updates SourceMod gamedata files
[02] Webternet (1.9.0.6281): Extension for interacting with URLs
[03] TF2Items (1.6.4): TF2 Item Modifier
[04] TF2 Tools (1.9.0.6281): TF2 extended functionality
[05] BinTools (1.9.0.6281): Low-level C/C++ Calling API
[06] SDK Hooks (1.9.0.6281): Source SDK Hooks
[07] SDK Tools (1.9.0.6281): Source SDK Tools
[08] Top Menus (1.9.0.6281): Creates sorted nested menus
[09] Client Preferences (1.9.0.6281): Saves client preference settings
[09] Client Preferences (1.9.0.6281): Saves client preference settings
[10] SQLite (1.9.0.6281): SQLite Driver
[11] <OPTIONAL> file "smrcon.ext.so": /home/container/tf/addons/sourcemod/extensions/smrcon.ext.so: cannot open shared object file: No such file or directory
[12] Regex (1.9.0.6281): Provides regex natives for plugins
[13] SteamTools (0.10.0+54fdc51): SteamWorks for SourceMod
[14] <OPTIONAL> file "SteamWorks.ext.so": /home/container/tf/addons/sourcemod/extensions/SteamWorks.ext.so: cannot open shared object file: No such file or directory
[15] Socket (3.0.1): Socket extension for SourceMod
[16] MySQL-DBI (1.9.0.6281): MySQL driver implementation for DBI

When doing "sm plugins list"

01 "Nextmap" (1.9.0.6281) by AlliedModders LLC
02 "TF2 Set Class" (1.2.2) by Tylerst
03 "Admin Smite" (2.1) by Hipster
04 "AdminCheats" (0.2) by devicenull
05 <Error> "Thriller" (0.2) by linux_lover
06 "Advanced Infinite Ammo" (1.5.3) by Tylerst
07 "Super Spray Handler" (1.3.1) by shavit, Nican132, CptMoore, Lebson506th, and TheWreckingCrew6
08 "Admin Stealth" (1.4) by necavi
09 "SMAC Rcon Locker" (0.8.6.7) by SMAC Development Team (original), Mr. Silence (updated)
10 "[TF2] Thirdperson" (2.1.0) by DarthNinja
11 "Evil Admin - Rocket" (1.0.110) by <eVa>Dog
12 "Basic Ban Commands" (1.9.0.6281) by AlliedModders LLC
13 "Aim Names" (0. by -MCG-Retsam & Antithasys
14 "Basic Comm Control" (1.9.0.6281) by AlliedModders LLC
15 "[Any] SourcePets" (1.18-B) by Oshizu & noodleboy347 (Playa Edit)
16 "SMAC Command Monitor" (0.8.6.7) by SMAC Development Team (original), Mr. Silence (updated)
17 "[TF2] Engineer's Workshop" (1.0.12b) by SirDigby
18 "Advertisements" (2.0.2) by Tsunami
19 "Basic Commands" (1.9.0.6281) by AlliedModders LLC
20 "Fun Commands" (1.9.0.6281) by AlliedModders LLC
21 "Admin Help" (1.9.0.6281) by AlliedModders LLC
22 "Uberspawn" (1.0) by Aderic
23 "TF2 Building God Mode" (1.1.0) by Tylerst
24 "Weddings" (3.0) by Dr. O, Franc1sco franug
25 "Client Preferences" (1.9.0.6281) by AlliedModders LLC
26 "Basic Info Triggers" (1.9.0.6281) by AlliedModders LLC
27 "Basic Votes" (1.9.0.6281) by AlliedModders LLC
28 "Player Commands" (1.9.0.6281) by AlliedModders LLC
29 "Evil Admin - Trails" (1.0.104) by <eVa>Dog
30 "Admin Menu" (1.9.0.6281) by AlliedModders LLC
31 "SMAC Anti-Wallhack" (0.8.6.7) by SMAC Development Team (original), Mr. Silence (updated)
32 "LMAOBAN" (1.4) by Aderic
33 "[Any] SteamTools Game Description Override" (1.1.3) by Dr. McKay
34 "SMAC AutoTrigger Detector" (0.8.6.7) by SMAC Development Team (original), Mr. Silence (updated)
35 "Sound Commands" (1.9.0.6281) by AlliedModders LLC
36 "[CCC Module] Set Tag" (1.0.0) by aIM
37 "AFK Manager" (4.3.0) by Rothgar
38 "[TF2] Friendly Simple" (0.924) by Phil25 (original by Derek D. Howard)
39 "SourceMod Anti-Cheat" (0.8.6.7) by SMAC Development Team (original), Mr. Silence (updated)
40 "Custom Tag" (1.0) by Arkarr
42 "SMAC ConVar Checker" (0.8.6.7) by SMAC Development Team (original), Mr. Silence (updated)
43 "List SourceMod Commands" (1.0) by denormal
44 "[Source 2013] Custom Chat Colors" (3.1.0) by Dr. McKay
45 "Self-Mute" (1.0) by Otokiru
46 "Admin File Reader" (1.9.0.6281) by AlliedModders LLC
47 "[TF2] Be Robin Walker" (1.7.0) by Whai
48 "Class is dead voice systeam" (1.2) by Classic
49 "[TF2] Rate of Fire" (1.2) by EHG
50 "[TF2] Building Hats" (2.0) by Pelipoika
51 "[TF2] SourcePets" (1.185) by Oshizu, noodleboy347 & Nanochip
52 "SMAC Aimbot Detector" (0.8.6.7) by SMAC Development Team (original), Mr. Silence (updated)
53 "TF2 Taunts TF2IDB" (1.6.3.66-tf2idb) by fakuivan
54 "Be the Robot" (1.3) by MasterOfTheXP
55 "Fish Humiliation" (0.2) by retsam
56 "SMAC Anti-Speedhack" (0.8.6.7) by SMAC Development Team (original), Mr. Silence (updated)
57 "VAC Status Checker" (2.5.0) by StevoTVR
58 "Be the Robot: Sentry Buster" (1.3) by MasterOfTheXP
59 "Rules Plugin" (1.3) by haN
60 "[TF2Items] Give Weapon" (3.14159) by FlaminSarge (orig by asherkin)
61 "Spray tracer" (3.1) by Nican132
62 "[TF2] TF2Attributes" (1.2.1) by FlaminSarge
63 "Basic Chat" (1.9.0.6281) by AlliedModders LLC
64 "SMAC ESEA Global Banlist" (0.8.6.7) by SMAC Development Team (original), Mr. Silence (updated)
65 "Custom Chat Colors Menu" (2.1) by ReFlexPoison
66 "Killstreak" (1. by Dr_Knuckles / Kredit
67 "SMAC Spinhack Detector" (0.8.6.7) by SMAC Development Team (original), Mr. Silence (updated)
68 "Resize Players" (1.5.1) by 11530
69 "Anti-Flood" (1.9.0.6281) by AlliedModders LLC
70 "Godmode with Effects!" (1.0) by Twin_Future
71 "Frog Chance" (1.0) by MasterOfTheXP
72 "Reserved Slots" (1.9.0.6281) by AlliedModders LLC
73 "SMAC Client Protection" (0.8.6.7) by SMAC Development Team (original), Mr. Silence (updated)
74 "Fun Votes" (1.9.0.6281) by AlliedModders LLC
75 "GameVoting" (1.8. by Neatek
76 "[Any] Deluxe Godmode" (2.3.1) by DarthNinja
77 "Scout-a-Pult" (1.0) by SadScrub & [SM] Striker
78 "TF2IDB" (0.93) by Bottiger
79 "[TF2] Rainbowize" (1.7.0) by Dr. McKay
80 "Chdata's Car data" (0x0D) by Chdata
81 "Simple Chat Processor (Redux)" (2.3.0) by Simple Plugins, Mini
82 "In-game Help Menu" (0.5) by chundo, emsit, joinedsenses
83 "Fun Commands X" (2.5) by Spazman0 and Arg!

I did add the files from a fresh copy of 1.10 into my extensions, maybe I should have deleted the preexisting ones? Sorry if this post looks bad, I don't have much experience in text formatting here.
Xred is offline
Silvers
AlliedModders Donor
Join Date: Aug 2010
Location: SpaceX
Old 01-16-2020 , 21:51   Re: When updating to a newer sourcemod version, I get an error when loading sm plugin
Reply With Quote #4

Ok do you see the problem?

Quote:
SourceMod Version: 1.9.0.6281
All the plugins also 1.9. Did you turn off server, replace files, restart server?

Also not just extensions, but all the files listed in the link you posted. /bin/ folder etc.
__________________

Last edited by Silvers; 01-16-2020 at 21:52.
Silvers is offline
Xred
Junior Member
Join Date: Aug 2019
Old 01-16-2020 , 22:11   Re: When updating to a newer sourcemod version, I get an error when loading sm plugin
Reply With Quote #5

I followed every step in https://wiki.alliedmods.net/Upgrading_SourceMod which included turning off the server, replacing the files in /bin, /extensions, /gamedata, /translations, and /plugins.

The current list is from when I reloaded a backup. I assume you wanted the plugins and extensions list from when I attempted to install a new sourcemod version?
Xred is offline
Xred
Junior Member
Join Date: Aug 2019
Old 01-17-2020 , 07:26   Re: When updating to a newer sourcemod version, I get an error when loading sm plugin
Reply With Quote #6

I realized my problem. I was downloading sourcemod for Windows when I was supposed to download Linux. Thanks for trying to help me through my idiocy . Everything's working now!
Xred is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:43.


Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Theme made by Freecode