It's absolutely NOT fine. It doesn't matter that you are using it only once. Quick, without googling anything tell me what this line does:
get_pdata_cbase(id, 373, 5)
You can't, even tho I used it only once. What in the world is 373? What is this supposed to do? You don't know unless you just so happen to know that offset 373 is m_pActiveItem. Now, look at the following line:
get_pdata_cbase(id, m_pActiveItem, XO_PLAYER)
You know instantly what it does. A number doesn't say anything, but a name does.
Not having magic values in your plugin is a requirement for approval, for a very good reason. Doing otherwise is asking for unmaintainable, unreadable and crappy code.
Use 1.8.2, it's fine, in fact it's even recommended if it can be reasonably done as it is still the latest stable release. Just name things properly, it's not hard.