Raised This Month: $404 Target: $400
 101% 

[L4D & L4D2] Bots Control In Coop Mode


Post New Thread Reply   
 
Thread Tools Display Modes
exstream
Member
Join Date: Feb 2013
Old 10-13-2013 , 00:22   Re: [L4D & L4D2] Bots Control In Coop Mode
Reply With Quote #21

I updated the game data files need to be tested please let me know how it works has not been tested yet
Attached Files
File Type: txt respawn.txt (1.7 KB, 341 views)
File Type: txt l4dsb.txt (1.2 KB, 156 views)
exstream is offline
nicocg
New Member
Join Date: Sep 2013
Old 01-03-2014 , 14:40   Re: [L4D & L4D2] Bots Control In Coop Mode
Reply With Quote #22

Hello exstream, these gamedata, go with the version of SilentBr (# 20), or the original first post?
With the release of SilentBr, bots are not kicked when a player disconnect.

[spoiler] 01/03/2014 - 16:17:19: SourceMod error session started
L 01/03/2014 - 16:17:19: Info (map "c3m1_plankcountry") (file "errors_20140103.log")
L 01/03/2014 - 16:17:19: [SM] Error parsing gameconfig file "C:\l4d2_ds\left4dead2\addons\sourcemod\gamed ata\l4dsb.txt":
L 01/03/2014 - 16:17:19: [SM] Error 9 on line 1, col 115: Line contained too many invalid tokens
L 01/03/2014 - 16:17:19: [SM] Native "LoadGameConfigFile" reported: Unable to open l4dsb: Line contained too many invalid tokens
L 01/03/2014 - 16:17:19: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx
L 01/03/2014 - 16:17:19: [SM] [0] Line 209, bot_l4d_fixed.sp::TakeOverBot()
L 01/03/2014 - 16:17:19: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/03/2014 - 16:17:19: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/03/2014 - 16:17:19: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx
L 01/03/2014 - 16:17:19: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/03/2014 - 16:17:19: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/03/2014 - 16:18:52: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/03/2014 - 16:18:52: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx
L 01/03/2014 - 16:18:52: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/03/2014 - 16:18:52: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/03/2014 - 16:25:17: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/03/2014 - 16:25:17: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx
L 01/03/2014 - 16:25:17: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/03/2014 - 16:25:17: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/03/2014 - 16:25:42: Error log file session closed.
L 01/03/2014 - 16:40:03: SourceMod error session started
L 01/03/2014 - 16:40:03: Info (map "c8m3_sewers") (file "errors_20140103.log")
L 01/03/2014 - 16:40:03: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/03/2014 - 16:40:03: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx
L 01/03/2014 - 16:40:03: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/03/2014 - 16:40:03: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/03/2014 - 16:42:15: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/03/2014 - 16:42:15: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx
L 01/03/2014 - 16:42:15: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/03/2014 - 16:42:15: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/03/2014 - 16:45:56: Error log file session closed.
L 01/03/2014 - 16:56:09: SourceMod error session started
L 01/03/2014 - 16:56:09: Info (map "c8m5_rooftop") (file "errors_20140103.log")
L 01/03/2014 - 16:56:09: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/03/2014 - 16:56:09: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx
L 01/03/2014 - 16:56:09: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/03/2014 - 16:56:09: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/03/2014 - 17:177: Error log file session closed.
L 01/03/2014 - 17:43:53: SourceMod error session started
L 01/03/2014 - 17:43:53: Info (map "c1m1_hotel") (file "errors_20140103.log")
L 01/03/2014 - 17:43:53: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/03/2014 - 17:43:53: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx
L 01/03/2014 - 17:43:53: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/03/2014 - 17:43:53: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/03/2014 - 17:449: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/03/2014 - 17:449: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx
L 01/03/2014 - 17:449: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/03/2014 - 17:449: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/03/2014 - 17:46:46: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/03/2014 - 17:46:46: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx
L 01/03/2014 - 17:46:46: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/03/2014 - 17:46:46: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/03/2014 - 17:46:51: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/03/2014 - 17:46:51: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx
L 01/03/2014 - 17:46:51: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/03/2014 - 17:46:51: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/03/2014 - 17:48:59: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/03/2014 - 17:48:59: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx
L 01/03/2014 - 17:48:59: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/03/2014 - 17:48:59: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()[ /spoiler]:

Last edited by nicocg; 01-03-2014 at 14:53.
nicocg is offline
nicocg
New Member
Join Date: Sep 2013
Old 01-04-2014 , 16:38   Re: [L4D & L4D2] Bots Control In Coop Mode
Reply With Quote #23

I sorry for the delay, I tried the gamedata your message above and the error persists, every so often causes the server crashing. If I use the gamedata of SilentBr no error messages, the problem is that it does not kick bots when a player disconnects, not even when the round restarts. It will be that the plugin does not work properly, or is a matter of updating the gamedata?

L 01/04/2014 - 18:05:47: SourceMod error session started
L 01/04/2014 - 18:05:47: Info (map "c8m2_subway") (file "errors_20140104.log")
L 01/04/2014 - 18:05:47: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/04/2014 - 18:05:47: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx":
L 01/04/2014 - 18:05:47: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/04/2014 - 18:05:47: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/04/2014 - 18:06:05: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/04/2014 - 18:06:05: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx":
L 01/04/2014 - 18:06:05: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/04/2014 - 18:06:05: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/04/2014 - 18:061: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/04/2014 - 18:061: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx":
L 01/04/2014 - 18:061: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/04/2014 - 18:061: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/04/2014 - 18:08:59: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/04/2014 - 18:08:59: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx":
L 01/04/2014 - 18:08:59: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/04/2014 - 18:08:59: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/04/2014 - 18:09:48: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/04/2014 - 18:09:48: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx":
L 01/04/2014 - 18:09:48: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/04/2014 - 18:09:48: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/04/2014 - 18:136: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/04/2014 - 18:136: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx":
L 01/04/2014 - 18:136: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/04/2014 - 18:136: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/04/2014 - 18:13:55: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/04/2014 - 18:13:55: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx":
L 01/04/2014 - 18:13:55: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/04/2014 - 18:13:55: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/04/2014 - 18:197: Error log file session closed.
nicocg is offline
exstream
Member
Join Date: Feb 2013
Old 01-04-2014 , 17:13   Re: [L4D & L4D2] Bots Control In Coop Mode
Reply With Quote #24

use this
Attached Files
File Type: txt l4dsb.txt (1.3 KB, 300 views)
exstream is offline
nicocg
New Member
Join Date: Sep 2013
Old 01-04-2014 , 22:17   Re: [L4D & L4D2] Bots Control In Coop Mode
Reply With Quote #25

Still not working. We play 4 hours, with 10 players, and bots are not kicked. But within 4 hours the server is not crashed. I tried to try the Fix Sappy, but have the same effect, the bots are not kicked. And if I use bebop, spawn bots dead.

L 01/05/2014 - 01:14:25: SourceMod error session started
L 01/05/2014 - 01:14:25: Info (map "c10m1_caves") (file "errors_20140105.log")
L 01/05/2014 - 01:14:25: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/05/2014 - 01:14:25: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx":
L 01/05/2014 - 01:14:25: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/05/2014 - 01:14:25: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/05/2014 - 01:15:11: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/05/2014 - 01:15:11: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx":
L 01/05/2014 - 01:15:11: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/05/2014 - 01:15:11: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()
L 01/05/2014 - 01:15:27: [SM] Native "SDKCall" reported: Invalid Handle 0 (error 4)
L 01/05/2014 - 01:15:27: [SM] Displaying call stack trace for plugin "bot_l4d_fixed.smx":
L 01/05/2014 - 01:15:27: [SM] [0] Line 230, bot_l4d_fixed.sp::TakeOverBot()
L 01/05/2014 - 01:15:27: [SM] [1] Line 58, bot_l4d_fixed.sp::ClientInServer()

Interestingly, when I first installed the plugin, created the cfg (bot_l4d.cfg) contained only this:

// This file was auto-generated by SourceMod (v1.5.2)
// ConVars for plugin "bot_l4d_fixed.smx"


// max bots
// -
// Default: "8"
l4d_bot_max "18"

// teleport the new bot to a palyer
// -
// Default: "1"
l4d_bot_teleport "1"

I added missing lines, but it seems strange not to come when the file is created, it seems not to recognize the missing commands.

Last edited by nicocg; 01-04-2014 at 22:27.
nicocg is offline
regret
New Member
Join Date: Jan 2014
Old 01-06-2014 , 03:13   Re: [L4D & L4D2] Bots Control In Coop Mode
Reply With Quote #26

Good to see this is still recently updated. Appreciate all your great work.
regret is offline
Dscheng
Member
Join Date: Sep 2013
Old 02-04-2014 , 00:02   Re: [L4D & L4D2] Bots Control In Coop Mode
Reply With Quote #27

Pls update again ~!! It not working and lead to server crashed.
Dscheng is offline
Marcus101RR
Veteran Member
Join Date: Aug 2009
Location: Tampa, FL
Old 02-04-2014 , 01:25   Re: [L4D & L4D2] Bots Control In Coop Mode
Reply With Quote #28

Just use Super Versus.
__________________
Marcus101RR is offline
Send a message via AIM to Marcus101RR Send a message via Skype™ to Marcus101RR
huynhnhatkhai
Junior Member
Join Date: Sep 2014
Old 09-02-2014 , 14:27   Re: [L4D & L4D2] Bots Control In Coop Mode
Reply With Quote #29

hope someone will fix it. Bot spawn well but when player disconnected, the bot not kicked (` 0 ^0)
huynhnhatkhai is offline
cookieee
New Member
Join Date: Oct 2014
Old 10-08-2014 , 10:40   Re: [L4D & L4D2] Bots Control In Coop Mode
Reply With Quote #30

Can anyone fix this plugin? It doesn't kick bots when a players leaves... Someone said use Super Versus but I've tried it and I don't like to always have 8 bots... Using also the sappy fix, but doesn't help either... Can someone tell me what do to to make it working, any tip or information would be much appreciated.
cookieee is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:26.


Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Theme made by Freecode