Raised This Month: $276 Target: $400
 69% 

Stripper & Keeper


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
regimen
Junior Member
Join Date: Jun 2010
Old 03-13-2020 , 22:38   Stripper & Keeper
Reply With Quote #1

[SOLVED] - I don't see how to mark this as such, but this is all fixed now!!!

Some here may be aware of the old HL2DM server [____Skul`Shock____]...if not, well, it was pretty popular for a time, due to it's over-the-top & arcade-like settings (lots of sounds, mods, infinite sprint, low gravity, etc).

Anyway, I have become curator of the files and am trying to bring it back online. So far, I've gotten most things working (mainly Sourcemod & plugins for that), except for two Metamod plugins: Stripper and Keeper, which seem to be abandon and no longer working. The last time this server was 100% working, was in 2017. It was previously running on a Windows server, but I've had to convert it to Linux now (though I can't imagine that matters...for the most part, I have a LOT of experience with this stuff, especially on Linux).

Code:
meta list
Listing 5 plugins:
  [01] <FAILED>
  [02] <ERROR>
  [03] SourceMod (1.10.0.6478) by AlliedModders LLC
  [04] SDK Tools (1.10.0.6478) by AlliedModders LLC
  [05] SDK Hooks (1.10.0.6478) by AlliedModders LLC
The failure is Keeper, the error is Stripper.

The only thing I've been able to find in the server logs is as follows, and I'm not sure how to find more, but I did look at every file that matched the expression to be sure, but this is literally everything I could find regardless:

Code:
grep -rnw -E "stripper|keeper|kp_"
l0314041.log:4:L 03/14/2020 - 01:47:42: [META] Failed to load plugin addons/stripper/bin/stripper_mm: Failed to get API
l0314047.log:7:L 03/14/2020 - 01:49:09: [META] Failed to load plugin addons/stripper/bin/stripper_mm: Failed to get API
l0314049.log:4:L 03/14/2020 - 01:50:42: [META] Failed to load plugin addons/stripper/bin/stripper_mm: Failed to get API
l0314053.log:4:L 03/14/2020 - 02:11:33: [META] Failed to load plugin addons/keeper/bin/keeper_sounds: 
l0314053.log:5:L 03/14/2020 - 02:11:33: [META] Failed to load plugin addons/stripper/bin/stripper_mm: Failed to get API
l0314045.log:4:L 03/14/2020 - 01:48:51: [META] Failed to load plugin addons/stripper/bin/stripper_mm: Failed to get API
I am aware of options to replace Keeper with Sourcemod plugins, which is fine if it is too dead, but I'm not sure how to replace Stripper. It was responsible for quite a few features of the server, but mainly just giving the players a specific spawn loadout, and spawning text entities to put fancy looking adverts at the top & bottom of the players' screens every few minutes.

I greatly appreciate any insight. Thank you for reading either way!

p.s. I'm reading through the Keeper thread (linked above) and some memories of offsets and kvf files are slowly coming back to me. I tried a few dllinfo.kvf solutions offered, but same result each time.

Oh I almost forgot, the server console also gets spammed with this:

Code:
L 03/14/2020 - 03:34:26: MetaMod:Source is loaded - Your server will be more stable if you load KEEPER_SOUNDS as a MMS plugin!!!
MetaMod:Source is loaded - Your server will be more stable if you load KEEPER_SOUNDS as a MMS plugin!!!
And also:

Code:
~/hl2mp/logs$ cat * | grep "kp_"
L 03/14/2020 - 03:26:42: "kp_sounds_version" = "2.3.1.0 VSP"
L 03/14/2020 - 03:26:42: "kp_build_date" = "Sep 25 2015 08:32:22"
UPDATE:
So Keeper's plugin is listed as failed..

Code:
meta list
Listing 5 plugins:
  [01] <FAILED>
  [02] Stripper (1.2.2) by BAILOPAN
  [03] SourceMod (1.10.0.6478) by AlliedModders LLC
  [04] SDK Tools (1.10.0.6478) by AlliedModders LLC
  [05] SDK Hooks (1.10.0.6478) by AlliedModders LLC
However, Keeper's plugin is now mostly tested/working on the server, despite apparently fialing to load?....I'm VERY confused. And server console is still getting spammed with those "Your server will be more stable if you load KEEPER_SOUNDS as a MMS plugin!!!" messages.

Last edited by regimen; 03-14-2020 at 11:31.
regimen is offline
Silvers
AlliedModders Donor
Join Date: Aug 2010
Location: SpaceX
Old 03-13-2020 , 23:36   Re: Stripper & Keeper
Reply With Quote #2

Stripper:Source should still work. Maybe it needs to be recompiled (however I still use the 2011 version without issue): http://www.bailopan.net/stripper/snapshots/1.2/ here are 2019 versions that have a binary compiled for HL2DM. Have you tried with that?
__________________

Last edited by Silvers; 03-17-2020 at 00:07.
Silvers is offline
regimen
Junior Member
Join Date: Jun 2010
Old 03-13-2020 , 23:45   Re: Stripper & Keeper
Reply With Quote #3

Quote:
Originally Posted by Silvers View Post
Stripper:Source should still work. Maybe it needs to be recompiled (however I still use the 2011 version without issue): http://www.bailopan.net/stripper/snapshots/1.2/ here are 2015 versions that has a binary compiled for HL2DM. Have you tried with that?
Thank you very much. This solved half of my problem. I do not know how my couple hours of searching overlooked that these snapshots. I thought I read over most of his main website.
regimen is offline
Silvers
AlliedModders Donor
Join Date: Aug 2010
Location: SpaceX
Old 03-13-2020 , 23:48   Re: Stripper & Keeper
Reply With Quote #4

The website is outdated but the link is from the forum thread: https://forums.alliedmods.net/showthread.php?t=39439
__________________
Silvers is offline
asherkin
SourceMod Developer
Join Date: Aug 2009
Location: OnGameFrame()
Old 03-14-2020 , 05:57   Re: Stripper & Keeper
Reply With Quote #5

The message from Keeper Sounds appears to indicate that it is loaded as a VSP instead of a MM:S plugin (look in plugin_print), it is probably failing to load as an MM:S plugin because of the fact it is already loaded. You likely have VDF files for it in both addons/ and addons/metamod/, try removing the one in addons/.
__________________
asherkin is offline
regimen
Junior Member
Join Date: Jun 2010
Old 03-14-2020 , 11:29   Re: Stripper & Keeper
Reply With Quote #6

Quote:
Originally Posted by asherkin View Post
The message from Keeper Sounds appears to indicate that it is loaded as a VSP instead of a MM:S plugin (look in plugin_print), it is probably failing to load as an MM:S plugin because of the fact it is already loaded. You likely have VDF files for it in both addons/ and addons/metamod/, try removing the one in addons/.
So I went to bed after noting the plugin was at least working in some capacity. When I woke up, I remembered that Keeper can run without MM:S...So you're right, there was a VDF file that got installed when I extracted the archive.

Thank you for replying tho. Every thing is working now

Last edited by regimen; 03-14-2020 at 11:31.
regimen is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:55.


Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Theme made by Freecode