Raised This Month: $68 Target: $400
 17% 

no model and no healing - basebuilder


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
Inside1
New Member
Join Date: Jul 2019
Old 07-18-2019 , 17:30   no model and no healing - basebuilder
Reply With Quote #1

Hey, im trying to add for special zombie class, to heal "other zombies". I edited a medic plugin and i only hear a sound healing. the second thing, i cant see model of zombie (i see cts model, only for new class), idk why.

edited medic code:
Code:
public heal_targets_uhp(id, Float:health_amount){  //unlimited heal points
	static healerid
	static targetid
	static Float:targethp
	static i

	if (zc5_max_heal_others[id] <= 0)
	{
		zc5_max_heal_others[id] = 0
		ColorChat(id, GREEN, "test");
		return;
	}

	i = 1
	while(i <= g_list_healers[PTR_LC])
	{
		healerid = g_list_healers[i]
		targetid = g_p_target[healerid]
		if (bb_get_user_zombie_class(id) == 4)
		{
			if(g_p_dmg[targetid] > NO_DAMAGE && is_user_alive(healerid))
			{
				pev(targetid, pev_health, targethp)
				if(health_amount < g_p_dmg[targetid])
				{
					set_pev(targetid, pev_health, targethp + health_amount)
					g_p_dmg[targetid] -= health_amount
					i++
                
					message_begin(MSG_BROADCAST, SVC_TEMPENTITY)
					write_byte(TE_BEAMENTS); // TE_BEAMENTS 8
					write_short(targetid); // Start entity
					write_short(healerid); // End entity
					write_short(g_sprite); // Sprite index
					write_byte(1); // Starting frame
					write_byte(1); // frame rate in 0.1's
					write_byte(3); // life in 0.1's
					write_byte(50); // line width in 0.1's
					write_byte(0); // noise amplitude in 0.01's
					write_byte(255); // R
					write_byte(0); // G
					write_byte(0); // B
					write_byte(150); // brightness
					write_byte(15); // scroll speed in 0.1's
					message_end()
				}
				else
				{
					set_pev(targetid, pev_health, targethp + g_p_dmg[targetid])
					g_p_dmg[targetid] = NO_DAMAGE
					stop_healing_process(healerid)
				}
			}
		}
		else
		{
		stop_healing_process(healerid)
		}
	}
}
and for zombie:
Code:
new const zclass5_name[] = { "Pielegniarka" }
new const zclass5_info[] = { "Zycie(++) Leczenie(+)" }
new const zclass5_model[] = { "bb_pielegniarka" }
new const zclass5_clawmodel[] = { "v_pielegniarka" }
const zclass5_health = 4000
const zclass5_speed = 250
const Float:zclass5_gravity = 1.0
const zclass5_adminflags = ADMIN_ALL
bb_register_zombie_class(zclass5_name, zclass5_info, zclass5_model, zclass5_clawmodel, zclass5_health, zclass5_speed, zclass5_gravity, 0.0, zclass5_adminflags)
Yes, i have correct directory of model zombie.
"/cstrike/models/basebuilder/bb_pielegniarka/bb_pielegniarka.dll"
i have basebuilder 5.4 cause 6.4+ archives is broken?
Please help, thanks.
Inside1 is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 21:17.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode