Raised This Month: $75 Target: $400
 18% 

Server 1.6 crashs


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
GALAXY
Senior Member
Join Date: Jun 2004
Location: Koblenz
Old 03-05-2014 , 05:26   Server 1.6 crashs
Reply With Quote #1

Hi
For several weeks I have the problem that my Cs 1.6 server crashes.

Here is the error message

L 03/04/2014 - 19:13:51: [AMXX] Run time error 4 (plugin "hlstatsx_commands_cstrike.amxx") - debug not enabled!
L 03/04/2014 - 19:13:51: [AMXX] To enable debug mode, add "debug" after the plugin name (without quotes) in plugins.ini.
L 03/04/2014 - 19:13:51: FATAL ERROR (shutting down): New message started When msg '86 'has not been sent yet
FATAL ERROR (shutting down): New message started When msg '86 'has not been sent yet

I have no explanation for it.
Perhaps I can help a. Post Wanted in the German forum but that's all no more unfortunately.
greetings
__________________
GALAXY is offline
Send a message via ICQ to GALAXY
YamiKaitou
Has a lovely bunch of coconuts
Join Date: Apr 2006
Location: Texas
Old 03-05-2014 , 06:33   Re: Server 1.6 crashs
Reply With Quote #2

Enable debug as the message states. Then post the new error
__________________
ProjectYami Laboratories

I do not browse the forums regularly anymore. If you need me for anything (intervening in a thread, asking questions or anything else), then PM me (be descriptive in your PM, message containing only a link to a thread will be ignored).
YamiKaitou is offline
Xongie
New Member
Join Date: Mar 2014
Old 03-11-2014 , 14:59   Re: Server 1.6 crashs
Reply With Quote #3

Hello,

Iīve got the same error on a CS 1.6 server.
With debug enabled I get following message:

Quote:
L 03/11/2014 - 13:05:59: [AMXX] Displaying debug trace (plugin "hlstatsx_commands_cstrike.amxx")
L 03/11/2014 - 13:05:59: [AMXX] Run time error 4: index out of bounds
L 03/11/2014 - 13:05:59: [AMXX] [0] hlstatsx_commands_cstrike.sma::psay (line 627)
L 03/11/2014 - 13:05:59: [AMXX] [1] hlstatsx_commands_cstrike.sma::hlx_amx_bulkps ay (line 685)
L 03/11/2014 - 13:05:59: FATAL ERROR (shutting down): New message started when msg '86' has not been sent yet
FATAL ERROR (shutting down): New message started when msg '86' has not been sent yet
I use version 1.6.19 (HL1).
If you need further information just let me know.

Thanks for your help.

Kind regrads,
Robert

Last edited by Xongie; 03-11-2014 at 15:01.
Xongie is offline
YamiKaitou
Has a lovely bunch of coconuts
Join Date: Apr 2006
Location: Texas
Old 03-11-2014 , 18:45   Re: Server 1.6 crashs
Reply With Quote #4

You are missing a line of the error message, there should be 1 before what you show
__________________
ProjectYami Laboratories

I do not browse the forums regularly anymore. If you need me for anything (intervening in a thread, asking questions or anything else), then PM me (be descriptive in your PM, message containing only a link to a thread will be ignored).
YamiKaitou is offline
Perlendieb
New Member
Join Date: Mar 2014
Old 03-12-2014 , 07:27   Re: Server 1.6 crashs
Reply With Quote #5

cancle.

Last edited by Perlendieb; 03-12-2014 at 08:42.
Perlendieb is offline
Xongie
New Member
Join Date: Mar 2014
Old 03-12-2014 , 16:47   Re: Server 1.6 crashs
Reply With Quote #6

Hi and thanks for your help!
Quote:
Originally Posted by YamiKaitou View Post
You are missing a line of the error message, there should be 1 before what you show
No, thatīs all. What makes you think, there are more error lines regarding this problem?

As far as I can debug this problem, this seems to be a real bug.
Apparently, the code makes it possbile that a message wants to be written while another one is still being processed.

The only thing I am wondering about is, that there are always the same lines involved. There are other messages being sent which do not cause the problem (yet).

Last edited by Xongie; 03-12-2014 at 17:04.
Xongie is offline
YamiKaitou
Has a lovely bunch of coconuts
Join Date: Apr 2006
Location: Texas
Old 03-12-2014 , 16:51   Re: Server 1.6 crashs
Reply With Quote #7

Quote:
Originally Posted by Xongie View Post
No, thatīs all. What makes you think, there are more error lines regarding this problem?
Because there almost always is the actual error message before the stack trace. I'll take a look when I get the chance to see if I see something
__________________
ProjectYami Laboratories

I do not browse the forums regularly anymore. If you need me for anything (intervening in a thread, asking questions or anything else), then PM me (be descriptive in your PM, message containing only a link to a thread will be ignored).
YamiKaitou is offline
YamiKaitou
Has a lovely bunch of coconuts
Join Date: Apr 2006
Location: Texas
Old 03-14-2014 , 09:24   Re: Server 1.6 crashs
Reply With Quote #8

Are you guys able to reproduce this error with ease? If I was to create a debugged version, would somebody be willing to install it and reproduce the error?
__________________
ProjectYami Laboratories

I do not browse the forums regularly anymore. If you need me for anything (intervening in a thread, asking questions or anything else), then PM me (be descriptive in your PM, message containing only a link to a thread will be ignored).
YamiKaitou is offline
Xongie
New Member
Join Date: Mar 2014
Old 03-14-2014 , 19:50   Re: Server 1.6 crashs
Reply With Quote #9

Hi!
Quote:
Originally Posted by YamiKaitou View Post
Are you guys able to reproduce this error with ease? If I was to create a debugged version, would somebody be willing to install it and reproduce the error?
We would like to help by installing a debug version of the plugin.

So far we were not able to reproduce the error. Today some people could play without any issues for 3 to 4 hours.

It seems the error comes only into effect randomly.
Xongie is offline
jonnzus
Epic Member
Join Date: Oct 2010
Location: Finland
Old 03-16-2014 , 06:57   Re: Server 1.6 crashs
Reply With Quote #10

I have also noticed those random crashes with hlx:ce and counter-strike 1.6 server.
If you make debug version I'm also willing to test it if it is also suitable for public server.

Code:
L 02/02/2014 - 16:06:48: Start of error session.
L 02/02/2014 - 16:06:48: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20140202.log")
L 02/02/2014 - 16:06:48: [AMXX] Displaying debug trace (plugin "hlstatsx_commands_cstrike.amxx")
L 02/02/2014 - 16:06:48: [AMXX] Run time error 4: index out of bounds
L 02/02/2014 - 16:06:48: [AMXX]    [0] hlstatsx_commands_cstrike.sma::psay (line 629)
L 02/02/2014 - 16:06:48: [AMXX]    [1] hlstatsx_commands_cstrike.sma::hlx_amx_bulkpsay (line 687)
__________________
Quote:
367. Everyone's copyright will be broken. No exceptions.
jonnzus is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 17:12.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode