Raised This Month: $128 Target: $400
 32% 

[EXTENSION][L4D2] Left4Fix (2.0.3)


Post New Thread Reply   
 
Thread Tools Display Modes
spumer
Senior Member
Join Date: Aug 2011
Old 07-05-2013 , 13:25   Re: [EXTENSION] Left4Fix (1.0.0.5)
Reply With Quote #11

Quote:
Originally Posted by Martijn79 View Post
btw does this work on l4d1 as well?
Heh. Obviously not.

Quote:
Originally Posted by bl4nk View Post
Compiling isn't the issue, it's getting the signatures for the functions the extension uses. It's not easy stuff, takes lots of time, and most will have to be rediscovered after every game update.
You are right. But i'm read tons of asm code when write the extension and get new signatures/offsets very quickly. My changes is very specific, and you are right again i need check them from every update.
__________________
spumer is offline
spumer
Senior Member
Join Date: Aug 2011
Old 07-08-2013 , 03:07   Re: [EXTENSION] Left4Fix (1.0.0.6)
Reply With Quote #12

Linux version is released: https://github.com/spumer/Left4Fix/releases
Files in first post is updated.
__________________
spumer is offline
Martijn79
Member
Join Date: Jan 2013
Old 07-08-2013 , 08:08   Re: [EXTENSION] Left4Fix (1.0.0.6)
Reply With Quote #13

Thanks for the update! However I can't get it to load:

Code:
13:07:43 [SM] Extension left4fix.ext.so failed to load: Could not read pDirector signature
Any idea?
Martijn79 is offline
spumer
Senior Member
Join Date: Aug 2011
Old 07-08-2013 , 10:08   Re: [EXTENSION] Left4Fix (1.0.0.6)
Reply With Quote #14

You placed left4fix.sig.txt to gamedata folder?
__________________
spumer is offline
Martijn79
Member
Join Date: Jan 2013
Old 07-08-2013 , 10:52   Re: [EXTENSION] Left4Fix (1.0.0.6)
Reply With Quote #15

Quote:
Originally Posted by spumer View Post
You placed left4fix.sig.txt to gamedata folder?
Yes, tried the one from github and the one attached.
Martijn79 is offline
spumer
Senior Member
Join Date: Aug 2011
Old 07-08-2013 , 11:33   Re: [EXTENSION] Left4Fix (1.0.0.6)
Reply With Quote #16

I have no idea.
Check your sourcemod installation.



I'm use:
Quote:
sm version
SourceMod Version Information:
SourceMod Version: 1.5.0-dev+3849
SourcePawn Engine: SourcePawn 1.1, jit-x86 (build 1.5.0-dev+3849)
SourcePawn API: v1 = 4, v2 = 4
Compiled on: Jul 6 2013 09:10:09
Build ID: 3849:15b8d092304d
http://www.sourcemod.net/
meta version
Metamod:Source version 1.9.3-dev
Build ID: 821:0f0657d5c910-dev
Loaded As: Valve Server Plugin
Compiled on: Jul 6 2013
Plugin interface version: 15:14
SourceHook version: 5:5
http://www.metamodsource.net/
Attached Thumbnails
Click image for larger version

Name:	all_systems_fork_fine.PNG
Views:	1064
Size:	1.3 KB
ID:	122356  
__________________

Last edited by spumer; 07-08-2013 at 11:34.
spumer is offline
Martijn79
Member
Join Date: Jan 2013
Old 07-08-2013 , 17:38   Re: [EXTENSION] Left4Fix (1.0.0.6)
Reply With Quote #17

Quote:
Originally Posted by spumer View Post
I have no idea.
Check your sourcemod installation.



I'm use:
Yeah it's def. me. I've tested it on another server and it loads fine. So must be something wrong with my install.

Thanks.
Martijn79 is offline
winniethepooh
SourceMod Donor
Join Date: Sep 2012
Old 07-09-2013 , 04:24   Re: [EXTENSION] Left4Fix (1.0.0.6)
Reply With Quote #18

I'm getting <FAILED> file "left4fix.ext.so": /lib/libm.so.6: version `GLIBC_2.15' not found (required by bin/libvstdlib.so) using the same sm and mm version you posted

Are you sure this was recompiled against the correct (_srv) versions of the SDK libs?
winniethepooh is offline
bl4nk
SourceMod Developer
Join Date: Jul 2007
Old 07-09-2013 , 04:55   Re: [EXTENSION] Left4Fix (1.0.0.6)
Reply With Quote #19

The extension was compiled using a newer version of glibc than you have on your server. You wouldn't happen to be running CentOS 6.4, would you?
bl4nk is offline
psychonic

BAFFLED
Join Date: May 2008
Old 07-09-2013 , 08:31   Re: [EXTENSION] Left4Fix (1.0.0.6)
Reply With Quote #20

Quote:
Originally Posted by bl4nk View Post
The extension was compiled using a newer version of glibc than you have on your server. You wouldn't happen to be running CentOS 6.4, would you?
It's from being linked against libvstdlib.so (from the linux client, which has a higher glibc req), rather than libvstdlib_srv.so.
psychonic is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 21:17.


Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Theme made by Freecode