Raised This Month: $68 Target: $400
 17% 

Release SourceBans++ (v1.6.3) [Updated: 2018-04-09]


Post New Thread Closed Thread   
 
Thread Tools Display Modes
Werewolf_UK
AlliedModders Donor
Join Date: Oct 2010
Location: United Kingdom
Old 08-06-2018 , 12:23   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1291

I have a custom banning plugin that was written for Sourcebans, but now no longer works with Sourcebans++. The plugin is not here on AlliedModders.

I would ask the author of that plugin to edit it himself, but he has since gone off steam for a couple years now. I however have the source (.sp) file for the plugin so I could edit it myself, if I knew what to do.

I am presuming that I need to remove the part of the code that tells it to use Sourcebans and replace it with Sourcebans++. So my question is, how would I do that? Would someone be able to explain to be like I'm 5 how to do this please?
__________________

Last edited by Werewolf_UK; 08-06-2018 at 12:23.
Werewolf_UK is offline
kills
AlliedModders Donor
Join Date: Sep 2008
Location: ROU
Old 08-07-2018 , 03:47   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1292

Quote:
Originally Posted by sneaK View Post
You mean to tell me you have no error_*.log in your logs folder?
No error !!! is true
kills is offline
Lapinou
New Member
Join Date: Oct 2016
Old 09-07-2018 , 05:10   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1293

For those who get the error error: the xml response that was returned from the server is invalid... on admin pages, i fixed it by editing hostname in cfg/server.cfg and remove special character and/or not more than 40 characters.
Hope it will help.

Last edited by Lapinou; 09-07-2018 at 05:11.
Lapinou is offline
Doulos
AlliedModders Donor
Join Date: Aug 2007
Old 09-26-2018 , 06:17   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1294

I have recently began getting this error:
Code:
L 09/25/2018 - 23:26:08: SourceMod error session started
L 09/25/2018 - 23:26:08: Info (map "de_final_solution") (file "errors_20180925.log")
L 09/25/2018 - 23:26:08: [sbpp_comms.smx] You must set valid `ServerID` value in sourcebans.cfg!
Server ID according to the web admin is "1", but bans are working and getting posted to the database when according to sourcebans.cfg server ID is "-1". I don't remember setting it to -1 and haven't changed anything since the original setup 1/3/2017.

Would change this to 1 (instead of -1) cause more problems, or just cause the sourcecomms errors to stop?

Last edited by Doulos; 09-26-2018 at 06:19.
Doulos is offline
sneaK
SourceMod Moderator
Join Date: Feb 2015
Location: USA
Old 09-26-2018 , 11:59   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1295

Quote:
Originally Posted by Doulos View Post
I have recently began getting this error:
Code:
L 09/25/2018 - 23:26:08: SourceMod error session started
L 09/25/2018 - 23:26:08: Info (map "de_final_solution") (file "errors_20180925.log")
L 09/25/2018 - 23:26:08: [sbpp_comms.smx] You must set valid `ServerID` value in sourcebans.cfg!
Server ID according to the web admin is "1", but bans are working and getting posted to the database when according to sourcebans.cfg server ID is "-1". I don't remember setting it to -1 and haven't changed anything since the original setup 1/3/2017.

Would change this to 1 (instead of -1) cause more problems, or just cause the sourcecomms errors to stop?
You probably accidentally replaced that config file when upgrading at some point, change it back to 1 and you're good to go.
__________________
sneaK is offline
Doulos
AlliedModders Donor
Join Date: Aug 2007
Old 09-28-2018 , 05:35   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1296

Ya, I did change it and am no longer getting the errors. Thanks.
Doulos is offline
ThisIsAUsername
Junior Member
Join Date: Nov 2017
Old 09-28-2018 , 23:29   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1297

Pardon me if this was asked before, but how does one make it so when a player rejoined the server while banned he receives a kick notification to check console which lists out the reason, timing etc

Last edited by ThisIsAUsername; 09-29-2018 at 00:04.
ThisIsAUsername is offline
ocampas
Junior Member
Join Date: Oct 2010
Old 10-04-2018 , 15:10   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1298

I may be in the wrong spot but this is the only forum I can find that may help.

I am using sourcebans 1.6.3 and no matter what I do I always get "Error connecting (wgb.ddns.net:27015)". Everything is correct, ports not blocked via testing. HLSW has no problem as with any other program, only sourcebans has a problem. Although it does not show the hostname I can still connect, go figure. I extracted the code for the PHP @fsockopen and it tested fine for the port. ONLY SOURCBANS HAS THIS ISSUE. Is there an update to the code or a bug fix.

This all started when I upgraded from 1.6.2 to 1.6.3.

If this is the wrong spot for this issue, please direct me to the correct forum.

Please don't respond with "your ISP is blocking the port". My ports are not blocked. I confirmed that.

Thank you.
ocampas is offline
GnomeChompski
Member
Join Date: Jul 2012
Old 10-18-2018 , 05:15   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1299

Any support for PHP 7 on the webui yet?
__________________
GnomeChompski is offline
Groruk
AlliedModders Donor
Join Date: Jul 2016
Old 10-18-2018 , 06:44   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1300

Quote:
Originally Posted by GnomeChompski View Post
Any support for PHP 7 on the webui yet?
PHP 7.0 compatibility was given in almost all versions of SourceBans++.

Version 1.6.0 was the first version to mainly focus on PHP 7.0 and higher during the development process
and Version 1.6.3 made SourceBans++ fully compatible for PHP 7.2 and higher.

Last edited by Groruk; 10-18-2018 at 06:48.
Groruk is offline
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:27.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode