Raised This Month: $37 Target: $400
 9% 

Custom player models not working on map with its own player models


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
Garlicvideos
Junior Member
Join Date: Nov 2018
Old 01-12-2019 , 03:01   Custom player models not working on map with its own player models
Reply With Quote #1

Hey there.

So I have a Jailbreak server and a Tower Defense server. On the JB Server, i have Zephyrus Store and custom player models working just fine. Custom player models will display when equipped. However, it is not the same on my Tower Defense server. The player models will not show. One difference I noticed was that on the JB Server, itís map does not have already preloaded custom player models, meaning thereís only default models. But on the TD server, the map has its own zombie player models. The player models are all present and in the correct folders and the store is configured correctly.

Anyone have any ideas?
Garlicvideos is offline
wolvez04
Senior Member
Join Date: Feb 2016
Location: Andora
Old 01-12-2019 , 12:35   Re: Custom player models not working on map with its own player models
Reply With Quote #2

Maybe map sets model after zephyr store equips it on spawn. Could try equipping skin mid game if you have that cvar enabled. Test of other map to see if you change instantly mod game. If confirmed, then you could use stripper to remove those models being equipped (if stripper works on tf2) or maybe worst case edit zephyr store plugin to equip again x seconds after spawn. Stripper sounds like easiest option

Link me the map
__________________
Hiring developers of all sorts for small or big jobs.
Paying nicely. Just PM for any available jobs.

wolvez04 is offline
Garlicvideos
Junior Member
Join Date: Nov 2018
Old 01-13-2019 , 08:18   Re: Custom player models not working on map with its own player models
Reply With Quote #3

Quote:
Originally Posted by wolvez04 View Post
Maybe map sets model after zephyr store equips it on spawn. Could try equipping skin mid game if you have that cvar enabled. Test of other map to see if you change instantly mod game. If confirmed, then you could use stripper to remove those models being equipped (if stripper works on tf2) or maybe worst case edit zephyr store plugin to equip again x seconds after spawn. Stripper sounds like easiest option

Link me the map
Here's the map. https://steamcommunity.com/sharedfil.../?id=787980533

Also, I just changed
Code:
sm_store_playerskin_delay
from -1 to 1, making it work. Looks like the map does set the model after zephyrus! Adding a delay worked. Thanks!
Garlicvideos is offline
wolvez04
Senior Member
Join Date: Feb 2016
Location: Andora
Old 01-13-2019 , 10:47   Re: Custom player models not working on map with its own player models
Reply With Quote #4

Quote:
Originally Posted by Garlicvideos View Post
Here's the map. https://steamcommunity.com/sharedfil.../?id=787980533

Also, I just changed
Code:
sm_store_playerskin_delay
from -1 to 1, making it work. Looks like the map does set the model after zephyrus! Adding a delay worked. Thanks!
Okay great. Problem solved
__________________
Hiring developers of all sorts for small or big jobs.
Paying nicely. Just PM for any available jobs.

wolvez04 is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 19:55.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode