Raised This Month: $12 Target: $400
 3% 

failed to dlopen cstrike/addons/metamod/bin/linux64/server.so


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
Jawesome99
Junior Member
Join Date: Apr 2013
Location: Germany
Old 04-13-2024 , 22:27   failed to dlopen cstrike/addons/metamod/bin/linux64/server.so
Reply With Quote #1

Hello folks, unfortunately a Google and Forum search haven't brought me very far, so I'm creating a post here.

I'm attempting to install Metamod and SourceMod into my CS:S server, however, when loading the server I get the following error:

Code:
server_srv.so loaded for "Counter-Strike: Source"
 failed to dlopen /home/emosewaj/gs/cs-source/cstrike/addons/metamod/bin/server.so error=/lib/i386-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /home/emosewaj/gs/cs-source/cstrike/addons/metamod/bin/server.so)
Now, this error seems quite similar to one of the common issues listed on the installation guide:

Quote:
  • An error indicating that it could not be loaded because "/path/to/server_install/bin/libgcc_s.so.1: version `GCC_7.0.0` not found (required by /some_system_path_to/libstdc++.so.6". This is because Valve ships their own copies of those libraries. As modern systems will have newer versions, you can safely delete the listed file from the server install. Do not delete the file in the system path (usually "lib" or "lib32").
However, since the indicated file in the server install is "metamod/bin/server.so" I probably shouldn't delete that one.

I also tried running the "apt install gcc-multilib" command listed in the solution below this one, however my system already has the latest version of that package installed.

I'm running this on a dedicated Linux server running Debian 10 with amd64 architecture.

I'm not really sure how to continue, any help would be greatly appreciated!
Jawesome99 is offline
tschumann
Junior Member
Join Date: Jun 2017
Location: Australia
Old 04-14-2024 , 04:29   Re: failed to dlopen cstrike/addons/metamod/bin/linux64/server.so
Reply With Quote #2

I might be wrong but I think I've had a similar issue - I think SteamCMD comes packaged with its own outdated version of libstdc++ - if you delete it from somewhere in the SteamCMD directory and try again it should hopefully work.
tschumann is offline
Jawesome99
Junior Member
Join Date: Apr 2013
Location: Germany
Old 04-14-2024 , 17:07   Re: failed to dlopen cstrike/addons/metamod/bin/linux64/server.so
Reply With Quote #3

I'm not quite sure what file(s) I should specifically be looking for, I checked for any file containing "libgcc" system wide and didn't find any paths mentioning SteamCMD, nor the CS:S game folder, only my CS:GO and GMod have a libgcc_s.so.1 each (and other system paths of course).
Jawesome99 is offline
Jawesome99
Junior Member
Join Date: Apr 2013
Location: Germany
Old 04-20-2024 , 15:24   Re: failed to dlopen cstrike/addons/metamod/bin/linux64/server.so
Reply With Quote #4

To anyone stumbling upon this thread in search of an answer:

My issue is that my server OS, Debian 10 "Buster", doesn't officially support glibc 2.29, only up to 2.28. I've read elsewhere that careless upgrading via building from source is dangerous, as the OS "heavily depends on the correct version of glibc being present." So as to not break anything, my solution is upgrading the operating system to Debian 12 "Bookworm."

Last edited by Jawesome99; 04-20-2024 at 15:24.
Jawesome99 is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:09.


Powered by vBulletin®
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Theme made by Freecode