Raised This Month: $ Target: $400
 0% 

SourceMod 1.7 released!


Post New Thread Closed Thread   
 
Thread Tools Display Modes
Coin0p
Member
Join Date: Dec 2013
Old 03-07-2015 , 02:56   Re: SourceMod 1.7 released!
#81

Quote:
Originally Posted by ddhoward View Post
So next time a game update causes SourceMod to stop working on that game, the SM developers should spend their time complaining to Valve rather than take the few hours to fix SM around the new changes. Got it.
Maybe if Valve had these on their upgrade pages they might.

Quote:
When upgrading SourceMod, backwards compatibility is guaranteed except in rare cases.
Quote:
Note: If a plugin stops working due to a SourceMod upgrade, file a bug report and the development team will assess the situation.
Look, I get it. I'm not trying to come across as an ungrateful user of sourcemod. Nor am I trying to start a fight. I just asked if the Sourcebans issue was going to be fixed. Others had mentioned the problem in previous posts with some things to try. I didn't expect to get jumped on when I asked.

Sourcmod inadvertently broke something that my servers rely on. The Sourcebans project seems to be dead. So now I'm faced with a new install of an unofficial Sourcebans fork or downgrading Souremod. Neither of which sounds too great.

At any rate, I have the utmost respect for the Sourcemod devs.

Be Well,

Coin0p
Coin0p is offline
asherkin
SourceMod Developer
Join Date: Aug 2009
Location: OnGameFrame()
Old 03-07-2015 , 09:54   Re: SourceMod 1.7 released!
#82

Quote:
Originally Posted by Coin0p View Post
The Sourcebans project seems to be dead. So now I'm faced with a new install of an unofficial Sourcebans fork or downgrading Souremod. Neither of which sounds too great.
Dead... apart from the fact it was already fixed.
__________________
asherkin is offline
Coin0p
Member
Join Date: Dec 2013
Old 03-07-2015 , 11:10   Re: SourceMod 1.7 released!
#83

Quote:
Originally Posted by asherkin View Post
I really, really, appreciate this. Thank you!
Coin0p is offline
8guawong
AlliedModders Donor
Join Date: Dec 2013
Location: BlackMarke7
Old 03-09-2015 , 03:12   Re: SourceMod 1.7 released!
#84

1.7 broke
https://forums.alliedmods.net/showthread.php?t=112651

Code:
L 03/09/2015 - 00:31:34: [SM] Native "OpenDirectory" reported: Invalid file path
L 03/09/2015 - 00:31:34: [SM] Displaying call stack trace for plugin "servercleanup.smx":
L 03/09/2015 - 00:31:34: [SM]   [0]  Line 451, /home/groups/alliedmodders/forums/files/3/8/6/4/9/55638.attach::CleanServer()
L 03/09/2015 - 00:31:34: [SM]   [1]  Line 200, /home/groups/alliedmodders/forums/files/3/8/6/4/9/55638.attach::OnConfigsExecuted()
is there a fix?
8guawong is offline
psychonic

BAFFLED
Join Date: May 2008
Old 03-09-2015 , 08:52   Re: SourceMod 1.7 released!
#85

Quote:
Originally Posted by 8guawong View Post
1.7 broke
https://forums.alliedmods.net/showthread.php?t=112651

Code:
L 03/09/2015 - 00:31:34: [SM] Native "OpenDirectory" reported: Invalid file path
L 03/09/2015 - 00:31:34: [SM] Displaying call stack trace for plugin "servercleanup.smx":
L 03/09/2015 - 00:31:34: [SM]   [0]  Line 451, /home/groups/alliedmodders/forums/files/3/8/6/4/9/55638.attach::CleanServer()
L 03/09/2015 - 00:31:34: [SM]   [1]  Line 200, /home/groups/alliedmodders/forums/files/3/8/6/4/9/55638.attach::OnConfigsExecuted()
is there a fix?
That definitely looks like an SM bug if it was working before. I'll look into it.
psychonic is offline
VoiDeD
AlliedModders Donor
Join Date: Mar 2009
Location: Illinois, USA
Old 03-09-2015 , 15:38   Re: SourceMod 1.7 released!
#86

Quote:
Originally Posted by 8guawong View Post
1.7 broke
https://forums.alliedmods.net/showthread.php?t=112651

Code:
L 03/09/2015 - 00:31:34: [SM] Native "OpenDirectory" reported: Invalid file path
L 03/09/2015 - 00:31:34: [SM] Displaying call stack trace for plugin "servercleanup.smx":
L 03/09/2015 - 00:31:34: [SM]   [0]  Line 451, /home/groups/alliedmodders/forums/files/3/8/6/4/9/55638.attach::CleanServer()
L 03/09/2015 - 00:31:34: [SM]   [1]  Line 200, /home/groups/alliedmodders/forums/files/3/8/6/4/9/55638.attach::OnConfigsExecuted()
is there a fix?
I think there needs to be more information in order to diagnose this one. Can you recompile that plugin with `DEBUG` defined to 1 and attach the relevant log messages when the plugin attempts to clean up?
__________________
VoiDeD is offline
8guawong
AlliedModders Donor
Join Date: Dec 2013
Location: BlackMarke7
Old 03-10-2015 , 10:31   Re: SourceMod 1.7 released!
#87

Quote:
Originally Posted by VoiDeD View Post
I think there needs to be more information in order to diagnose this one. Can you recompile that plugin with `DEBUG` defined to 1 and attach the relevant log messages when the plugin attempts to clean up?
Spoiler


Attached is the version with DEBUG enabled
Attached Files
File Type: sp Get Plugin or Get Source (servercleanup.sp - 275 views - 16.1 KB)

Last edited by 8guawong; 03-10-2015 at 10:31.
8guawong is offline
KyleS
SourceMod Plugin Approver
Join Date: Jul 2009
Location: Segmentation Fault.
Old 03-10-2015 , 21:49   Re: SourceMod 1.7 released!
#88

Quote:
Originally Posted by psychonic View Post
That definitely looks like an SM bug if it was working before. I'll look into it.
PHP Code:
#pragma semicolon 1
#include <sourcemod>

public OnPluginStart()
{
    static 
String:sFace[] = ":(";
    if (
DirExists(""))
    {
        new 
Handle:hDirectory OpenDirectory("");
        
PrintToServer("Handle: %x"hDirectory);
        
CloseHandle(hDirectory);
        
FormatEx(sFacesizeof(sFace), ":)");
    }

    
PrintToServer("%s"sFace);

Quote:
Originally Posted by SM1.6
sm plugins load FaceTest
Handle: 2cde0384

[SM] Loaded plugin FaceTest.smx successfully.
Quote:
Originally Posted by SM1.8
sm plugins reload FaceTest
[Thread 0xe9342b40 (LWP 2273) exited]
L 03/10/2015 - 20:48:08: [SM] Native "OpenDirectory" reported: Invalid file path
L 03/10/2015 - 20:48:08: [SM] Displaying call stack trace for plugin "FaceTest.smx":
L 03/10/2015 - 20:48:08: [SM] [0] Line 9, /groups/sourcemod/upload_tmp/textBN8JDy.sp::OnPluginStart()
[SM] Plugin FaceTest.smx reloaded successfully.
r=me on half-reverting https://github.com/alliedmodders/sou...ec5e33887ca9da or making DirExists return false on "".
KyleS is offline
psychonic

BAFFLED
Join Date: May 2008
Old 03-10-2015 , 22:50   Re: SourceMod 1.7 released!
#89

Quote:
Originally Posted by psychonic View Post
That definitely looks like an SM bug if it was working before. I'll look into it.
The bug in SM is throwing an error for OpenDirectory("") and not DirExists(""). Both should be errors. The plugin asking if the directory "" exists makes no sense. "" is not a valid directory name regardless of previous behavior.
psychonic is offline
4bdul
AlliedModders Donor
Join Date: Dec 2011
Location: United Kingdom
Old 03-11-2015 , 19:31   Re: SourceMod 1.7 released!
#90

I'm having trouble with mysql admin groups access, I opened a bug here but I'm not even sure if it's a sourcemod bug.

Edit: Just to clarify, this was working fine in 1.6 - stopped the moment I updated.

Can anyone confirm if they have the same problem or not?
__________________

Last edited by 4bdul; 03-11-2015 at 19:41.
4bdul is offline
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 19:01.


Powered by vBulletin®
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Theme made by Freecode