Raised This Month: $344 Target: $400
 86%   Almost there!

TF2 no item server when set to public sv_lan 0


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
goodBEan
Senior Member
Join Date: Jul 2010
Location: St. Louis Mo USA
Old 08-15-2022 , 19:03   TF2 no item server when set to public sv_lan 0
Reply With Quote #1

I got a strange one here. I recently dusted off my tf2 server config for a game night, updated to the latest version of sourcemod and metamod. The weirdest thing is that I had a server that would work perfectly fine hen in lan mode (sv_lan 1) but will not connect to the item server in internet public mode (sv_lan 0 with the game server login token and all that added to the command line). If it out in the public there are no cosmetics or custom weapons. I have checked it in and out of virtualization. no luck.



This is the command string I use for lan:
./srcds_run -game tf -port 27015 +sv_pure 0 +maxplayers 24 -console -usercon -replay +mapcyclefile mapcycle_quickplay_koth.txt +randommap +hostname "Laclede's_LAN_TF2_Freeplay" +rcon_password [redacted] +sv_lan 1

The command for internet
./srcds_run -game tf -port 27015 +sv_pure 0 +maxplayers 24 -console -usercon -replay +mapcyclefile mapcycle_quickplay_koth.txt +randommap +sv_setsteamaccount [redacted] +tf_server_identity_account_id [redacted] +tf_server_identity_token [redacted] +hostname "Laclede's_LAN_TF2_Freeplay" +rcon_password [redacted] +sv_lan 0

here are my config files
https://github.com/LacledesLAN/games...master/dist/tf

Im just stuck. I also was avoiding having the server listed on the master list.
goodBEan is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 16:14.


Powered by vBulletin®
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Theme made by Freecode