Raised This Month: $70 Target: $400
 17% 

L4DToolZ Metamod plugin (l4d1 & l4d2)


Post New Thread Reply   
 
Thread Tools Display Modes
Spirit_12
Veteran Member
Join Date: Dec 2012
Location: Toronto, CA
Old 10-11-2020 , 00:41   Re: L4DToolZ Metamod plugin (l4d1 & l4d2)
Reply With Quote #1441

Quote:
Originally Posted by maclarens View Post
Debian 10 log compile l4d2
--------------------------
mkdir -p l4d2_release
ln -sf ../hl2sdk-l4d2/lib/linux/libvstdlib_srv.so
ln -sf ../hl2sdk-l4d2/lib/linux/libtier0_srv.so
gcc -I. -I../mmsource-1.10/core -I../mmsource-1.10/core/sourcehook -I../hl2sdk-l4d2/public -I../hl2sdk-l4d2/public/tier0 -I../hl2sdk-l4d2/public/tier1 -I../hl2sdk-l4d2/public/e ngine -I../hl2sdk-l4d2/public/mathlib -I../hl2sdk-l4d2/public/appframework -DSOURCE_ENGINE=9 -D__GIT_VERSION=\"1.1\" -DSE_EPISODEONE=1 -DSE_DARKMESSIAH=2 -DSE_ORANGEBOX=3 -DSE_ BLOODYGOODTIME=4 -DSE_EYE=5 -DSE_CSS=6 -DSE_ORANGEBOXVALVE=7 -DSE_LEFT4DEAD=8 -DSE_LEFT4DEAD2=9 -DSE_ALIENSWARM=10 -DSE_PORTAL2=11 -DSE_CSGO=12 -DPOSIX -Dstricmp=strcasecmp -D_ stricmp=strcasecmp -D_strnicmp=strncasecmp -Dstrnicmp=strncasecmp -D_snprintf=snprintf -D_vsnprintf=vsnprintf -D_alloca=alloca -Dstrcmpi=strcasecmp -DCOMPILER_GCC -Wno-overload ed-virtual -Wno-switch -Wno-unused -msse -DSOURCEMOD_BUILD -DHAVE_STDINT_H -m32 -DNDEBUG -O2 -funroll-loops -pipe -fno-strict-aliasing -D_LINUX -mfpmath=sse -fvisibility=hidden -Wno-non-virtual-dtor -fno-exceptions -fno-rtti -fvisibility-inlines-hidden -std=c++11 -Wall -Werror -o l4d2_release/l4dtoolz_mm.o -c l4dtoolz_mm.cpp
In file included from ../hl2sdk-l4d2/public/tier1/utlvector.h:23,
from ../hl2sdk-l4d2/public/tier1/convar.h:21,
from ../hl2sdk-l4d2/public/eiface.h:16,
from ../mmsource-1.10/core/ISmmAPI.h:46,
from ../mmsource-1.10/core/ISmmPlugin.h9,
from l4dtoolz_mm.h:4,
from l4dtoolz_mm.cpp:1:
../hl2sdk-l4d2/public/tier1/utlmemory.h: In member function ‘void CUtlMemory<T, I>::Swap(CUtlMemory<T, I>&)’:
../hl2sdk-l4d2/public/tier1/utlmemory.h30:2: error: there are no arguments to ‘V_swap’ that depend on a template parameter, so a declaration of ‘V_swap’ must be available [-f permissive]
V_swap( m_nGrowSize, mem.m_nGrowSize );
^~~~~~
../hl2sdk-l4d2/public/tier1/utlmemory.h30:2: note: (if you use ‘-fpermissive’, G++ will accept your code, but allowing the use of an undeclared name is deprecated)
../hl2sdk-l4d2/public/tier1/utlmemory.h32:2: error: there are no arguments to ‘V_swap’ that depend on a template parameter, so a declaration of ‘V_swap’ must be available [-f permissive]
V_swap( m_nAllocationCount, mem.m_nAllocationCount );
^~~~~~
make: *** [l4d2_make:95: all] Error 1
Use Clang. The new gcc is not compatible with the code.
__________________
Spirit_12 is offline
Accelerator74
AlliedModders Donor
Join Date: Dec 2010
Location: Russia
Old 10-11-2020 , 00:53   Re: L4DToolZ Metamod plugin (l4d1 & l4d2)
Reply With Quote #1442

Quote:
Originally Posted by maclarens View Post
Debian 10 log compile l4d2
[...]
Add
Code:
#include "mathlib/mathlib.h"
in ./hl2sdk-l4d2/public/tier1/utlmemory.h
__________________

Last edited by Accelerator74; 10-11-2020 at 00:55.
Accelerator74 is offline
Send a message via ICQ to Accelerator74
maclarens
Member
Join Date: Jul 2020
Old 10-11-2020 , 02:29   Re: L4DToolZ Metamod plugin (l4d1 & l4d2)
Reply With Quote #1443

Quote:
Originally Posted by Accelerator74 View Post
Add
Code:
#include "mathlib/mathlib.h"
in ./hl2sdk-l4d2/public/tier1/utlmemory.h
it work it thx!

Last edited by maclarens; 10-11-2020 at 02:51.
maclarens is offline
maks
Member
Join Date: Dec 2011
Location: Russia
Old 10-11-2020 , 02:47   Re: L4DToolZ Metamod plugin (l4d1 & l4d2)
Reply With Quote #1444

I recommend using ubuntu 14.04 lts for the build. The build is adapted for GCC v4. New versions of GCC will have errors.
maks is offline
Accelerator74
AlliedModders Donor
Join Date: Dec 2010
Location: Russia
Old 10-11-2020 , 03:14   Re: L4DToolZ Metamod plugin (l4d1 & l4d2)
Reply With Quote #1445

Quote:
Originally Posted by maclarens View Post
it work it thx!
Updated for clang - https://github.com/Accelerator74/l4dtoolz
__________________
Accelerator74 is offline
Send a message via ICQ to Accelerator74
Spirit_12
Veteran Member
Join Date: Dec 2012
Location: Toronto, CA
Old 10-11-2020 , 22:23   Re: L4DToolZ Metamod plugin (l4d1 & l4d2)
Reply With Quote #1446

Quote:
Originally Posted by Accelerator74 View Post
Don't you think updating the whole project to Ambuilds is a better idea? That's what Sourcemod is using right now anyway and it avoids the cross compatibility issues.
__________________
Spirit_12 is offline
Accelerator74
AlliedModders Donor
Join Date: Dec 2010
Location: Russia
Old 10-11-2020 , 23:35   Re: L4DToolZ Metamod plugin (l4d1 & l4d2)
Reply With Quote #1447

I mostly always build for myself and use the latest versions of the sourcemod, metamod and sdk sources. I never experience any compatibility problems. And this is just a small extension, not some big project. I don't see the difference how to build it
__________________
Accelerator74 is offline
Send a message via ICQ to Accelerator74
Spirit_12
Veteran Member
Join Date: Dec 2012
Location: Toronto, CA
Old 10-12-2020 , 00:41   Re: L4DToolZ Metamod plugin (l4d1 & l4d2)
Reply With Quote #1448

Quote:
Originally Posted by Accelerator74 View Post
I mostly always build for myself and use the latest versions of the sourcemod, metamod and sdk sources. I never experience any compatibility problems. And this is just a small extension, not some big project. I don't see the difference how to build it
You say that and yet a lot of your projects are released here. I didn't mean in terms of compatibility, I meant in terms of maintaining it for the future. You are really updating 2-3 scripts, while with ambuilds you can use the same script for both platforms.
__________________
Spirit_12 is offline
Ocela
Junior Member
Join Date: Oct 2020
Old 10-20-2020 , 01:06   Re: L4DToolZ Metamod plugin (l4d1 & l4d2)
Reply With Quote #1449

Quote:
Originally Posted by Accelerator74 View Post
I mostly always build for myself and use the latest versions of the sourcemod, metamod and sdk sources. I never experience any compatibility problems. And this is just a small extension, not some big project. I don't see the difference how to build it
Hi Accelerator, I know this may be a dumb question, but how do you compile your fork? I was reading some of the old posts and got a little lost, the version of l4dtoolz out right now is a little bit buggy and was wanting something more up to date of course. Thanks for your time and help!
Ocela is offline
Accelerator74
AlliedModders Donor
Join Date: Dec 2010
Location: Russia
Old 10-20-2020 , 02:25   Re: L4DToolZ Metamod plugin (l4d1 & l4d2)
Reply With Quote #1450

You can use my build script. Just install git, clang and g++-multilib (apt-get install git clang g++-multilib) and run ./l4d2_build.sh.
Attached Files
File Type: zip l4d2_build.zip (623 Bytes, 22 views)
__________________

Last edited by Accelerator74; 10-20-2020 at 02:30.
Accelerator74 is offline
Send a message via ICQ to Accelerator74
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 16:10.


Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Theme made by Freecode