Raised This Month: $170 Target: $400
 42% 

End Round Sounds


Post New Thread Reply   
 
Thread Tools Display Modes
Arsenal_Fan
Member
Join Date: Nov 2004
Location: Highbury
Old 12-11-2004 , 17:14  
Reply With Quote #21

Cool plugin. TNX to autor.
Arsenal_Fan is offline
MeTaL69
Senior Member
Join Date: Jun 2004
Location: England
Old 12-11-2004 , 21:35  
Reply With Quote #22

So r u all still getting lag from this??
__________________
We own alll ya asses ;)
MeTaL69 is offline
Arsenal_Fan
Member
Join Date: Nov 2004
Location: Highbury
Old 12-12-2004 , 01:27  
Reply With Quote #23

I'm not getting lags on my server.
Arsenal_Fan is offline
Shalfey
New Member
Join Date: Dec 2004
Old 12-23-2004 , 10:39  
Reply With Quote #24

A little upgrade
So, then client executes
setinfo no_winsound 1
no sound will be played at the end of round...

Code:
//RoundSound.amxx -by PaintLancer

#include <amxmodx>

public plugin_init()
{
  register_cvar("cl_round_end", "1");
  register_plugin("RoundSound","1.1","PaintLancer&Sha!")
  register_event("SendAudio", "t_win", "a", "2&%!MRAD_terwin")
  register_event("SendAudio", "ct_win", "a", "2&%!MRAD_ctwin")
}

public t_win()
{
new no_winsound[32]
new i=1
while(i<31)
{
  get_user_info(i, "no_winsound", no_winsound, 31)

  if(!(str_to_num(no_winsound)))
  {
  new rand = random_num(0,4)
  client_cmd(i,"stopsound")
  switch(rand)
  {
    case 0: client_cmd(i,"spk misc/twinnar1")
    case 1: client_cmd(i,"spk misc/twinnar2")
    case 2: client_cmd(i,"spk misc/twinnar3")
    case 3: client_cmd(i,"spk misc/twinnar4")
    case 4: client_cmd(i,"spk misc/twinnar5")
  }
  }
  i=i+1
}
return PLUGIN_HANDLED
}

public ct_win()
{
new no_winsound[32]
new i=1
while(i<31)
{
  get_user_info(i, "no_winsound", no_winsound, 31)

  if(!(str_to_num(no_winsound)))
  {
  new rand = random_num(0,4)
  client_cmd(i,"stopsound")
  switch(rand)
  {
    case 0: client_cmd(i,"spk misc/ctwinnar1")
    case 1: client_cmd(i,"spk misc/ctwinnar2")
    case 2: client_cmd(i,"spk misc/ctwinnar3")
    case 3: client_cmd(i,"spk misc/ctwinnar4")
    case 4: client_cmd(i,"spk misc/ctwinnar5")
  }
  }
  i=i+1
}
return PLUGIN_HANDLED
}

public plugin_precache()
{
  precache_sound("misc/ctwinnar1.wav")
  precache_sound("misc/ctwinnar2.wav")
  precache_sound("misc/ctwinnar3.wav")
  precache_sound("misc/ctwinnar4.wav")
  precache_sound("misc/ctwinnar5.wav")
  precache_sound("misc/twinnar1.wav")
  precache_sound("misc/twinnar2.wav")
  precache_sound("misc/twinnar3.wav")
  precache_sound("misc/twinnar4.wav")
  precache_sound("misc/twinnar5.wav")

  return PLUGIN_CONTINUE
}
Sorry for my english
Shalfey is offline
MP5Navyboy
Member
Join Date: Apr 2004
Location: Orland Park, IL.
Old 12-23-2004 , 15:21  
Reply With Quote #25

Quote:
Originally Posted by TruuSti
it didnt work .. i put the sounds and the .amxx file in the plugins folder but nothing came.. and wrote roundsound.amxx in the plugins.ini. do i have to do something else?
If you put the sounds in the plugin folder theres ur problem, the sounds stuff should go in the sounds folder located in the cstrike folder not the plugins folder, thats where the amxx file goes.

Navy
__________________
MP5Navyboy is offline
Send a message via AIM to MP5Navyboy
-=STN=- MaGe
Veteran Member
Join Date: Apr 2004
Location: Asault World
Old 12-31-2004 , 09:29  
Reply With Quote #26

im getting alot of runtime errors with this upgrade. sounds not playing will post details asap

here
Code:
L 12/31/2004 - 09:25:14: [AMXX] Native error in "get_user_info" on line 45 (file "roundsound.sma"). L 12/31/2004 - 09:27:49: [AMXX] Native error in "get_user_info" on line 45 (file "roundsound.sma"). L 12/31/2004 - 09:28:34: [AMXX] Native error in "get_user_info" on line 19 (file "roundsound.sma"). L 12/31/2004 - 09:29:55: [AMXX] Native error in "get_user_info" on line 19 (file "roundsound.sma"). L 12/31/2004 - 09:30:40: [AMXX] Native error in "get_user_info" on line 19 (file "roundsound.sma"). L 12/31/2004 - 09:31:43: [AMXX] Native error in "get_user_info" on line 19 (file "roundsound.sma"). L 12/31/2004 - 09:32:43: [AMXX] Native error in "get_user_info" on line 19 (file "roundsound.sma"). L 12/31/2004 - 09:34:07: [AMXX] Native error in "get_user_info" on line 19 (file "roundsound.sma"). L 12/31/2004 - 09:34:56: [AMXX] Native error in "get_user_info" on line 19 (file "roundsound.sma"). L 12/31/2004 - 09:35:53: [AMXX] Native error in "get_user_info" on line 45 (file "roundsound.sma"). L 12/31/2004 - 09:37:55: [AMXX] Native error in "get_user_info" on line 19 (file "roundsound.sma"). L 12/31/2004 - 09:39:17: [AMXX] Native error in "get_user_info" on line 19 (file "roundsound.sma"). L 12/31/2004 - 09:40:06: [AMXX] Native error in "get_user_info" on line 45 (file "roundsound.sma"). L 12/31/2004 - 09:40:52: [AMXX] Native error in "get_user_info" on line 19 (file "roundsound.sma"). L 12/31/2004 - 09:41:20: [AMXX] Native error in "get_user_info" on line 19 (file "roundsound.sma").
__________________



-=STN=- MaGe is offline
Send a message via Yahoo to -=STN=- MaGe
Front Line
Senior Member
Join Date: Jan 2005
Old 01-30-2005 , 21:02  
Reply With Quote #27

Just a quick question do u just have to ova lap the songs as in replace,
or can u add sum lik ctwinnar6.wav etc, is there away i have to do this coz i dunt have aproggy that can read those type of files e.g sma etc. but can i just do that or do i need to ova lap.
Front Line is offline
God_squad
New Member
Join Date: Feb 2005
Old 02-19-2005 , 20:48   ugh
Reply With Quote #28

how do i add my own sounds????
i renamed the wavs (24 Khz 8 bit mono) to twinnar1, twinnar2, etc....
and i put them into sounds/misc overwritting the old ones and i restarted my server but it still plays the default ones
God_squad is offline
snoboi182
Junior Member
Join Date: Feb 2005
Old 03-01-2005 , 17:08   Re: ugh
Reply With Quote #29

Quote:
Originally Posted by God_squad
how do i add my own sounds????
i renamed the wavs (24 Khz 8 bit mono) to twinnar1, twinnar2, etc....
and i put them into sounds/misc overwritting the old ones and i restarted my server but it still plays the default ones
u cant rename them, then the players wont download it, cus their sound folder has the existing ones.
snoboi182 is offline
Send a message via AIM to snoboi182
Dontask-jello
Member
Join Date: Mar 2005
Old 03-22-2005 , 01:57  
Reply With Quote #30

Anyone got any more PimPed out sounds?
Dontask-jello is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:07.


Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Theme made by Freecode