Raised This Month: $77 Target: $400
 19% 

[Source 2013] Custom Chat Colors


Post New Thread Reply   
 
Thread Tools Display Modes
SaudierX
New Member
Join Date: Feb 2016
Old 09-21-2016 , 23:45   Re: [Source 2013] Custom Chat Colors
Reply With Quote #1261

I tried alot different configs but no work for me, I'm doing something wrong?


my custom-chatcolors.cfg

"Admin_colors"

}
"STEAM_0:0:87316575" //Soldier
{
"Tag" "[Owner]"
"Tagcolor" "#FF0000"
"Namecolor" "#FFFFFF"
"Textcolor" "#FF0000"


}
}
SaudierX is offline
Dr. McKay
Sir Dr. SourceMod Plugin Approver Esq. Ltd. M.D. PhD
Join Date: Aug 2011
Location: Atlantis
Old 09-22-2016 , 09:13   Re: [Source 2013] Custom Chat Colors
Reply With Quote #1262

Your first curly brace is flipped.
__________________
Dr. McKay is offline
SaudierX
New Member
Join Date: Feb 2016
Old 09-22-2016 , 10:04   Re: [Source 2013] Custom Chat Colors
Reply With Quote #1263

thanks for the reply

I think I found the problem, the plugin is not installed even when in the right place and installed with simple chat it does not Appear in the list of installed plugins, l trying for days make this work in my server

I never had a problem with the dedicated server, now I'm having problems installing on a vps.




inc and sp, are on right place,
I do not know what is wrong grateful if someone can help me.

Last edited by SaudierX; 09-22-2016 at 10:05.
SaudierX is offline
alster551
Junior Member
Join Date: Sep 2016
Old 09-22-2016 , 11:07   Re: [Source 2013] Custom Chat Colors
Reply With Quote #1264

I have a problem with this plugin running on a CS:GO server. I'ts not a problem with colors or anything, I just simply cant get it to work.

I have the simple chat processor redux installed and i've tried to reinstall everything, but nothing happens when I type in the chat.

The only thing i did in the config was change it to my steam ID:

Code:
"admin_colors"
{
	"<my steam ID>"
	{
		"tag"				"[BAILOPAN] "
		"tagcolor"			"O"
	}
	"VIP"
	{
		"flag"				"a"
		"tag"				"[VIP] "
		"tagcolor"			"#9EC34FAA"
		"namecolor"			"#00CCFF"
		"textcolor"			"#000000AA"
	}
}
Could you think of anything I have forgotten to do?
alster551 is offline
condolent
AlliedModders Donor
Join Date: Jan 2016
Location: gc_sLocation;
Old 09-25-2016 , 08:08   Re: [Source 2013] Custom Chat Colors
Reply With Quote #1265

Installed this (Mitchell's CSGO version) plugin on another server of mine and the plugin shows up in sm plugins list together with simple chat processor.

Though I do not get any changed color/tag to my name in chat? The config is copied from my other server.

Don't even get an error in console. Anybody have any idea how this can be?
condolent is offline
DingdongJR
New Member
Join Date: Oct 2016
Old 10-16-2016 , 07:35   Re: [Source 2013] Custom Chat Colors
Reply With Quote #1266

Quote:
Originally Posted by SaudierX View Post
thanks for the reply

I think I found the problem, the plugin is not installed even when in the right place and installed with simple chat it does not Appear in the list of installed plugins, l trying for days make this work in my server

I never had a problem with the dedicated server, now I'm having problems installing on a vps.




inc and sp, are on right place,
I do not know what is wrong grateful if someone can help me.
Just to start, thanks a lot for all your work Dr. McKay, but I am now having this same problem. Everything is installed in the correct place and I have all the files, but for some reason CCC is not registering as being installed. Forcing the plugin to load using console just states that it does not exist. I have tried a fresh install of the plugin.

Last edited by DingdongJR; 10-16-2016 at 07:38.
DingdongJR is offline
Xenoadria
Member
Join Date: Oct 2016
Old 10-16-2016 , 08:33   Re: [Source 2013] Custom Chat Colors
Reply With Quote #1267

Hey guys. I'm having problems with this plugin. I am using Mitchell's version for CSGO. And everything was working flawlessly until last CSGO update came and when Sourcemod needed to be upgraded. Basically problems I am having now are the following:
-My admins tags are randomly being switched (example my Admin has tag ADMIN (as it should), next map he has tag VIP)
-Tag and chat colors are being lost when we retry/reconnect in the middle of the round, next map tag is back until they reconnect again

I think that's all of them atm. I hope someone will be able to help me out
Xenoadria is offline
Mitchell
~lick~
Join Date: Mar 2010
Old 10-16-2016 , 13:56   Re: [Source 2013] Custom Chat Colors
Reply With Quote #1268

Quote:
Originally Posted by Xenoadria View Post
Hey guys. I'm having problems with this plugin. I am using Mitchell's version for CSGO. And everything was working flawlessly until last CSGO update came and when Sourcemod needed to be upgraded. Basically problems I am having now are the following:
-My admins tags are randomly being switched (example my Admin has tag ADMIN (as it should), next map he has tag VIP)
-Tag and chat colors are being lost when we retry/reconnect in the middle of the round, next map tag is back until they reconnect again

I think that's all of them atm. I hope someone will be able to help me out
That's a very interesting glitch, could you post your "sm version", "sm plugins list", "sm exts list" just in case?
It sounds like you're not on the latest build of SM.
__________________

Last edited by Mitchell; 10-16-2016 at 13:57.
Mitchell is offline
Xenoadria
Member
Join Date: Oct 2016
Old 10-16-2016 , 14:17   Re: [Source 2013] Custom Chat Colors
Reply With Quote #1269

Quote:
Originally Posted by Mitchell View Post
That's a very interesting glitch, could you post your "sm version", "sm plugins list", "sm exts list" just in case?
It sounds like you're not on the latest build of SM.
Here are the lists:

SM Version
Spoiler


SM Plugins list
Spoiler


SM Exts list
Spoiler



...And while I was writing this reply. I actually decided to check on the latest builds of SM, and apperently it appears I am not using the latest one. I will update SM tonight and tell you if the problems persist with the "actual" latest build... I feel ashamed
Xenoadria is offline
Xenoadria
Member
Join Date: Oct 2016
Old 10-17-2016 , 18:00   Re: [Source 2013] Custom Chat Colors
Reply With Quote #1270

I just wanted to notify you that for now I do not have problems anymore with this plugin. It was the problem with the build of the actual SM. However still makes me wonder how come it worked for some time and it started causing problems after some time.

Thank you Mitchell, without your reply It would take me some time to figure out to check the SM version
Xenoadria is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:49.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode