Raised This Month: $91 Target: $400
 22% 

Release SourceBans++ (v1.6.3) [Updated: 2018-04-09]


Post New Thread Closed Thread   
 
Thread Tools Display Modes
paulo_crash
AlliedModders Donor
Join Date: May 2016
Location: Brazil
Old 07-25-2019 , 15:42   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1371

Quote:
Originally Posted by `666 View Post
Yes. In "date format" I have it "d-m-y H:i T" https://www.bmbans.nn.pe/sourcebans/index.php?p=banlist

edit: and in webhost cpanel -> multiphp ini editor for domain I had to add new line: date.timezone = "Europe/London"
Also make sure that the host where your game servers are set up is properly Date and Timezone.

I was having the same problem, after I configured the Web Host I configured Server Host too and solved my problem.
__________________
paulo_crash is offline
Send a message via Skype™ to paulo_crash
8guawong
AlliedModders Donor
Join Date: Dec 2013
Location: BlackMarke7
Old 07-26-2019 , 03:46   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1372

Quote:
Originally Posted by `666 View Post
Yes. In "date format" I have it "d-m-y H:i T" https://www.bmbans.nn.pe/sourcebans/index.php?p=banlist

edit: and in webhost cpanel -> multiphp ini editor for domain I had to add new line: date.timezone = "Europe/London"
Quote:
Originally Posted by paulo_crash View Post
Also make sure that the host where your game servers are set up is properly Date and Timezone.

I was having the same problem, after I configured the Web Host I configured Server Host too and solved my problem.
Quote:
Originally Posted by DarkDeviL View Post
I am very sure that I've seen it in settings previously (of the official SourceBans), as I also advise over here.

If that doesn't fit in your SB++, you can try the advise given here instead.
thx for all the responses
fixed the timezone problem by adding date_default_timezone_set("Europe/Copenhagen"); to the config.php like DarkDeviL suggested
__________________
8guawong is offline
jouluvalo
Junior Member
Join Date: Mar 2014
Location: Finland
Old 07-26-2019 , 11:36   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1373

Hello!
This week I noticed that my Sourcebans is not working as it should.

I added a ban beginning of this week and it didn't show up on the sourcebans page.
Now I added a mute and it didn't appear either.

The ban and mute was given on different servers. When I added the mute I got this in logs:
Saving punishment for STEAM_0:XXX into queue
Lost connection to DB. Reconnect after delay
Query_AddBlockInsert failed: Subquery returns more than 1 row

All servers recognize admins and you can use commands.
Servers are also preventing banned users from connecting. Something is now wrong with the sql as it tries to write. I can manually add mutes and bans via webpage
jouluvalo is offline
egorka2
Member
Join Date: Jun 2010
Old 08-03-2019 , 18:49   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1374

How to disable logging? Now sourcebans.log is flooding by all DB queries...
egorka2 is offline
asdfxD
Veteran Member
Join Date: Apr 2011
Old 08-21-2019 , 14:16   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1375

Any fix for this?

mysql is utf8mb4_general_ci

L 08/11/2019 - 12:55:42: [sbpp_main.smx] Verify Insert Query Failed: Incorrect string value: '\xF0\x9D\x95\xB5\xF0\x9D...' for column 'name' at row 1
L 08/20/2019 - 21:51:55: [sbpp_main.smx] Verify Insert Query Failed: Incorrect string value: '\xC3 \xBCvbe...' for column 'reason' at row 1
L 08/20/2019 - 21:52:58: [sbpp_main.smx] Verify Insert Query Failed: Incorrect string value: '\xC3 \xBCvbe...' for column 'reason' at row 1
L 08/20/2019 - 21:538: [sbpp_main.smx] Verify Insert Query Failed: Incorrect string value: '\xC3 \xBCvbe...' for column 'reason' at row 1
L 08/20/2019 - 22:20:03: [sbpp_main.smx] Verify Insert Query Failed: Incorrect string value: '\xC3 \xBCvbe...' for column 'reason' at row 1
L 08/20/2019 - 22:23:58: [sbpp_main.smx] Verify Insert Query Failed: Incorrect string value: '\xC3 \xBCvbe...' for column 'reason' at row 1

Last edited by asdfxD; 08-21-2019 at 14:27.
asdfxD is offline
trotinetaidg
New Member
Join Date: Feb 2017
Old 09-06-2019 , 15:08   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1376

Hello guys, just installed sourbenas on my server and don't work for me.

This is my error, server can't connect on database

Quote:
[sbpp_main.smx] Database failure: [2013]: Lost connection to MySQL server at 'reading initial communication packet', system error: 110. See Docs: https://sbpp.github.io/docs/
trotinetaidg is offline
asdfxD
Veteran Member
Join Date: Apr 2011
Old 09-13-2019 , 01:43   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1377

Quote:
Originally Posted by asdfxD View Post
Any fix for this?

mysql is utf8mb4_general_ci

L 08/11/2019 - 12:55:42: [sbpp_main.smx] Verify Insert Query Failed: Incorrect string value: '\xF0\x9D\x95\xB5\xF0\x9D...' for column 'name' at row 1
L 08/20/2019 - 21:51:55: [sbpp_main.smx] Verify Insert Query Failed: Incorrect string value: '\xC3 \xBCvbe...' for column 'reason' at row 1
L 08/20/2019 - 21:52:58: [sbpp_main.smx] Verify Insert Query Failed: Incorrect string value: '\xC3 \xBCvbe...' for column 'reason' at row 1
L 08/20/2019 - 21:538: [sbpp_main.smx] Verify Insert Query Failed: Incorrect string value: '\xC3 \xBCvbe...' for column 'reason' at row 1
L 08/20/2019 - 22:20:03: [sbpp_main.smx] Verify Insert Query Failed: Incorrect string value: '\xC3 \xBCvbe...' for column 'reason' at row 1
L 08/20/2019 - 22:23:58: [sbpp_main.smx] Verify Insert Query Failed: Incorrect string value: '\xC3 \xBCvbe...' for column 'reason' at row 1
Got this shit error fixed finally, system is ubuntu.

Added in /etc/mysql/mysql.conf.d/mysqld.cnf and restart mysql.

[mysqld]
collation-server = utf8mb4_unicode_ci
character-set-server = utf8mb4
init-connect='SET NAMES utf8mb4'

[client]
default-character-set=utf8mb4

[mysql]
default-character-set=utf8mb4

service mysql restart

Change in /var/www/html/sourcebans_dir/config.php

define('DB_CHARSET', 'utf8'); // The Database charset (Default: utf

utf8 => utf8mb4

and changed all utf8 entrys to utf8mb4 in the sourcebans database and now it works without this errors, tested twice with old changes and new changes.

Last edited by asdfxD; 09-13-2019 at 01:46.
asdfxD is offline
RumbleFrog
Great Tester of Whatever
Join Date: Dec 2016
Location: US
Old 09-20-2019 , 23:45   Re: [RELEASE] SourceBans++ (v1.6.3) [Updated: 2018-04-06]
#1378

Please post each request in its own thread (and check if it exists already) in the new SourceBans subforum instead of this big old one.

https://forums.alliedmods.net/forumdisplay.php?f=152



.
__________________


Fingerprint: 91CC4E84AE4BFA89F2E431DD462F405E7D61ED35

Reach me @ https://keybase.io/rumblefrog

Github: https://github.com/rumblefrog


Last edited by RumbleFrog; 09-20-2019 at 23:46.
RumbleFrog is online now
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:56.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode