Raised This Month: $115 Target: $400
 28% 

How to make episdoe1 plugin load in Linux


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
taansari
Member
Join Date: Nov 2011
Old 02-06-2012 , 09:04   How to make episdoe1 plugin load in Linux
Reply With Quote #1

Hi!

I've made a cross platform plug-in that works fine under Windows (Orange box valve (TF, HL2DM), and episode 1 (Fortress forver)).

However, my episode1 plugin does not load under linux, it just gives me this error:
Code:
Listing 1 plugin:
  [01] <ERROR>
When I try to get its information, I get this:
Code:
meta info 1
Plugin 1 is not loaded.
File: /media/2d9c079a-7c97-4221-98f4-c7f1d713ff1f/HLServer/episode1/fortressforever/addons/my_plugin/bin/my_plugin.so
And when I try to reload it, it gives me:
Code:
meta retry 1
Error reloading plugin: [111]
I've made sure I'm linking against the right SDK, just like in Windows (and its HL2SDK original).

If it were giving me at least one line of human readable error, I would have taken that point as lead, but its either error or just a magic number (111) that I cannot understand.

Can some one please highlight what could I be doing wrong?

Thanks for your guidance!

Last edited by taansari; 02-06-2012 at 09:07.
taansari is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:40.


Powered by vBulletin®
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Theme made by Freecode