Raised This Month: $ Target: $400
 0% 

[Any] Chat-Processor (Replacement for Simple Chat Processor)


Post New Thread Reply   
 
Thread Tools Display Modes
whtevrwt
AlliedModders Donor
Join Date: Apr 2015
Old 10-02-2017 , 18:12   Re: [Any] Chat-Processor (Replacement for Simple Chat Processor)
Reply With Quote #181

For some odd reason, 2.0.7 works fine but when I upgrade to 2.0.8 or 2.0.9 the chat disappears. No one is able to chat in game.
__________________
whtevrwt is offline
TheXeon
Member
Join Date: May 2016
Location: GetClientAbsOrigin(Zeron
Old 10-09-2017 , 18:34   Re: [Any] Chat-Processor (Replacement for Simple Chat Processor)
Reply With Quote #182

Quote:
Originally Posted by SytekBox View Post
Which Custom Chat Colors work with this Processor? I've been trying to find one that works for hours upon hours and can't find one that works properly. Anybody has it laying around perhaps?
The one in the repo should work. The compiled one is missing a feature that the source file has (the ability to use default colors with {3} in the format file). It works even better if you compile it yourself: https://github.com/Drixevel/Chat-Pro...atcolors-cp.sp
__________________


EVERYTHING BREAKS ALWAYS!
TheXeon is offline
TheXeon
Member
Join Date: May 2016
Location: GetClientAbsOrigin(Zeron
Old 10-09-2017 , 18:36   Re: [Any] Chat-Processor (Replacement for Simple Chat Processor)
Reply With Quote #183

Is there a way to change the order in which plugins change messages? I want it to only apply the custom-chat-colors after a shop plugin's chat colors are applied. Maybe something with removecolors?
__________________


EVERYTHING BREAKS ALWAYS!
TheXeon is offline
whtevrwt
AlliedModders Donor
Join Date: Apr 2015
Old 10-22-2017 , 05:33   Re: [Any] Chat-Processor (Replacement for Simple Chat Processor)
Reply With Quote #184

I've been trying to figure this out for days but I really need help now:

Quote:
L 10/22/2017 - 04: 30:57: [chat-processor.smx] Message formats generated for game 'csgo'.
L 10/22/2017 - 04: 30:57: [chat-processor.smx] Successfully hooked either SayText or SayText2 chat hooks.
But when I type in chat nothing shows and I get this message in console:
Quote:
Tried to look up command say as if it were a variable.
This is the only chat processor I have installed. I also have no errors in the logs.
__________________

Last edited by whtevrwt; 10-22-2017 at 05:43.
whtevrwt is offline
Totenfluch
AlliedModders Donor
Join Date: Jan 2012
Location: Germany
Old 10-22-2017 , 07:48   Re: [Any] Chat-Processor (Replacement for Simple Chat Processor)
Reply With Quote #185

This is actually extremly usefull.

Thanks!
__________________
Notable Projects:
Event Item Spawner | Scissors, Rock, Paper for ZephStore
tVip | Smart Link Remover
PLG & GGC - CS:GO Roleplay

and countless more...

I can make a helicopter shoot missles if you want me to...
Totenfluch is offline
ImACow
AlliedModders Donor
Join Date: Feb 2015
Old 10-22-2017 , 17:21   Re: [Any] Chat-Processor (Replacement for Simple Chat Processor)
Reply With Quote #186

How can I fix this?

__________________
ImACow is offline
Surprised
Junior Member
Join Date: Oct 2017
Old 11-07-2017 , 13:21   Re: [Any] Chat-Processor (Replacement for Simple Chat Processor)
Reply With Quote #187

Hi, I'm noob

I have to use this plugin, because: https://forums.alliedmods.net/showthread.php?t=290926 -chat colors

error logs:
L 11/07/2017 - 19:07:17: Info (map "surf_mai_remix_ctgo") (file "errors_20171107.log")
L 11/07/2017 - 19:07:17: [SM] Exception reported: Config file missing
L 11/07/2017 - 19:07:17: [SM] Blaming: custom-chatcolors-cp.smx
L 11/07/2017 - 19:07:17: [SM] Call stack trace:
L 11/07/2017 - 19:07:17: [SM] [0] SetFailState
L 11/07/2017 - 19:07:17: [SM] [1] Line 82, custom-chatcolors-cp.sp::LoadConfig
L 11/07/2017 - 19:07:17: [SM] [2] Line 71, custom-chatcolors-cp.sp::OnPluginStart
L 11/07/2017 - 19:07:17: [SM] Unable to load plugin "custom-chatcolors-cp.smx": Error detected in plugin startup (see error logs)

How can I fix it? Why plugin isn't loading?

I hope You will help me, thanks

Sorry for my english..

Regards -Surprised
Surprised is offline
Cripix
Senior Member
Join Date: Sep 2016
Location: French, Bordeaux
Old 11-07-2017 , 13:26   Re: [Any] Chat-Processor (Replacement for Simple Chat Processor)
Reply With Quote #188

Quote:
Originally Posted by Surprised View Post
Hi, I'm noob

I have to use this plugin, because: https://forums.alliedmods.net/showthread.php?t=290926 -chat colors

error logs:
L 11/07/2017 - 19:07:17: Info (map "surf_mai_remix_ctgo") (file "errors_20171107.log")
L 11/07/2017 - 19:07:17: [SM] Exception reported: Config file missing
L 11/07/2017 - 19:07:17: [SM] Blaming: custom-chatcolors-cp.smx
L 11/07/2017 - 19:07:17: [SM] Call stack trace:
L 11/07/2017 - 19:07:17: [SM] [0] SetFailState
L 11/07/2017 - 19:07:17: [SM] [1] Line 82, custom-chatcolors-cp.sp::LoadConfig
L 11/07/2017 - 19:07:17: [SM] [2] Line 71, custom-chatcolors-cp.sp::OnPluginStart
L 11/07/2017 - 19:07:17: [SM] Unable to load plugin "custom-chatcolors-cp.smx": Error detected in plugin startup (see error logs)

How can I fix it? Why plugin isn't loading?

I hope You will help me, thanks

Sorry for my english..

Regards -Surprised
Config file missing
__________________
My jailbreak Server :
Cripix is offline
Surprised
Junior Member
Join Date: Oct 2017
Old 11-07-2017 , 13:32   Re: [Any] Chat-Processor (Replacement for Simple Chat Processor)
Reply With Quote #189

Quote:
Originally Posted by Cripix View Post
Config file missing

But how? This file is in the right place..
Then what can be wrong?
Surprised is offline
Surprised
Junior Member
Join Date: Oct 2017
Old 11-07-2017 , 16:16   Re: [Any] Chat-Processor (Replacement for Simple Chat Processor)
Reply With Quote #190

Quote:
Originally Posted by Surprised View Post
But how? This file is in the right place..
Then what can be wrong?

Never mind..

Scrap of code:
HTML Code:
BuildPath(Path_SM, path, sizeof(path), "configs/custom-chatcolors.cfg");
if(!FileToKeyValues(configFile, path)) {
SetFailState("Config file missing");
Seems like "custom-chatcolors.cfg" Isn't creating, so I created It manually..


After restart error is the same:

logs:
L 11/07/2017 - 19:07:17: Info (map "surf_mai_remix_ctgo") (file "errors_20171107.log")
L 11/07/2017 - 19:07:17: [SM] Exception reported: Config file missing
L 11/07/2017 - 19:07:17: [SM] Blaming: custom-chatcolors-cp.smx
L 11/07/2017 - 19:07:17: [SM] Call stack trace:
L 11/07/2017 - 19:07:17: [SM] [0] SetFailState
L 11/07/2017 - 19:07:17: [SM] [1] Line 82, custom-chatcolors-cp.sp::LoadConfig
L 11/07/2017 - 19:07:17: [SM] [2] Line 71, custom-chatcolors-cp.sp::OnPluginStart
L 11/07/2017 - 19:07:17: [SM] Unable to load plugin "custom-chatcolors-cp.smx": Error detected in plugin startup (see error logs)
Surprised is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 13:52.


Powered by vBulletin®
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Theme made by Freecode