Raised This Month: $119 Target: $400
 29% 

Entity Resources Replacement[ V 1.4 ]


Post New Thread Reply   
 
Thread Tools Display Modes
Arkshine
AMX Mod X Plugin Approver
Join Date: Oct 2005
Old 09-30-2017 , 17:48   Re: Entity Resources Replacement[ V 1.4 ]
Reply With Quote #251

There is no need to change, it's just a warning anyway. A Warning is NOT an error. It has no effect on the compilation.
I don't know what you did (you provided no modified source code, no full output from the compiler, people are not clairvoyant fyi), but you probably modified wrongly, like a syntax error or something.
__________________
Working on : CS Weapon Mod (72%) , MonsterAI (PAUSED),


Last edited by Arkshine; 09-30-2017 at 17:49.
Arkshine is offline
Ricky
Senior Member
Join Date: Jul 2005
Old 09-30-2017 , 20:56   Re: Entity Resources Replacement[ V 1.4 ]
Reply With Quote #252

Tried using a fresh copy of 5138 and installed the proper includes. I still get the same compiling issue that wickedd doesn't seem to have. The plugin works with the error ignored but it's weird that I can't compile with the new native, or compile it using the original socket_change instead after editing the sma. I simply interchanged "socket_change" with "socket_is_readable" and back and still receive compile failed error for both.

When switched to new native.

Code:
c:\....entities_resources_replacement.sma(1): error 010: invalid function or declaration
c:\....entities_resources_replacement.sma(372); warning 233: symbol "socket_change" is marked as deprecated: Use socket_is_readable() instead

1. Error.
Could not locate output file c:\.... entities_resources_replacement.amx (compile failed).
When edited back to old native, socket_change.

Code:
c:\....entities_resources_replacement.sma(1): error 010: invalid function or declaration

1. Error.
Could not locate output file c:\.... entities_resources_replacement.amx (compile failed).
Ricky is offline
wickedd
Veteran Member
Join Date: Nov 2009
Old 09-30-2017 , 21:31   Re: Entity Resources Replacement[ V 1.4 ]
Reply With Quote #253

What editor are you using to edit the .sma?
Because when I change the encoding of the .sma from "UTF-8" to "UTF-8-BOM" I get the same error.
Code:
c:\....entities_resources_replacement.sma(1): error 010: invalid function or declaration
So I think your editor is changing the Ecoding. Convert it back to "UTF-8" then try compiling it.

P.S. I use Notepad++

Edit: If it doesn't work for you, PM me the .sma ( the one you edited )that you are trying compile.
__________________
Just buy the fucking game!!!!
I hate No-Steamers and lazy ass people.

Last edited by wickedd; 09-30-2017 at 21:41.
wickedd is offline
Ricky
Senior Member
Join Date: Jul 2005
Old 10-02-2017 , 05:46   Re: Entity Resources Replacement[ V 1.4 ]
Reply With Quote #254

Thanks for pinpointing the problem. I've been using the standard notepad from Windows XP through 10 and only had issues with a handful of newer plugins. Converted to Notepad ++.
Ricky is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:37.


Powered by vBulletin®
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Theme made by Freecode