Raised This Month: $299 Target: $400
 74% 

CSGO Server Slots help?


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
newtonz
New Member
Join Date: Jan 2022
Old 01-25-2022 , 08:38   CSGO Server Slots help?
Reply With Quote #1

Hello can someone help me,i cant change slots to 32 i have only 1 slot on server in console say here:


Maxplayers is deprecated, set it in gamemodes_server.txt.example or use -maxplayers_override instead.

I chnage in gamemodes_server.txt.expamle but still 1 slot and i try to put in server startup -maxplayers_override but still 1 slot.And i try to chnage in gamemodes.txt but still 1 slot.


Can i miss to change slots in other file?

./srcds_run -game csgo -console -usercon +net_public_adr [ip] -port 1066 +ip 0.0.0.0 +map de_dust2 -strictportbind -norestart +sv_setsteamaccount [token]

Last edited by newtonz; 01-25-2022 at 08:45.
newtonz is offline
Ryan2
Senior Member
Join Date: Jul 2020
Old 01-25-2022 , 18:25   Re: CSGO Server Slots help?
Reply With Quote #2

Just starters if you are using a file called "gamemodes_server.txt.expamle" that is the wrong format. Game modes are .cfg format.
Ryan2 is offline
Bacardi
Veteran Member
Join Date: Jan 2010
Location: mom's basement
Old 01-25-2022 , 23:22   Re: CSGO Server Slots help?
Reply With Quote #3

In CS:GO, in startup parameters, -maxplayers is no longer in use.

When using dynamic max. players value:
- By default, cs:go game change dynamically max. player count on different game modes.
You can look yourself from gamemodes.txt file.
Code:
casual = 20
competitive = 10
scrimcomp2v2 = 4
scrimcomp5v5 = 10
gungameprogressive = 10
gungametrbomb = 10
deathmatch = 16
training = 1
custom = 100
cooperative = 20
coopmission = 10
skirmish = 12
survival = 16
To override these default Valve game mode settings, you use override file, if you need change.
gamemodes_server.txt
Code:
"GameModes_Server.txt"
{
	"gameTypes"
	{
		"classic"
		{
			"gameModes"
			{
				"casual"
				{
					"maxplayers"		"30"
				}
	
				"competitive"
				{
					"maxplayers"		"20"
				}
			}
		}
	}
}
When using static max. player value:
- Using server startup parameter -maxplayers_override you can force max. player count, what ever the game mode settings is, it always to be that static max. player count.
Code:
./srcds_run -console -usercon -game csgo -maxplayers_override 32 +map de_dust2


Still problems ?
- Are you using another server host ? Perhaps server provider have set max. player count and you can't change that. Ask from them.

- Do map have enough spawn points ?
And sometimes, maps have bad spawn points, too close each other. This can be seen by loading map in your own game, not server, and use: sv_cheats 1; map_showspawnpoints

- Have you change SourceMod plugin "reserved slots" settings ? Adding more reserved slots will change sv_visiblemaxplayers cvar value and will show your server slot count differently.
sv_visiblemaxplayers -1 is default.

*edit
from status you can check current maxplayers.
Code:
] status
hostname: 'Bacardi
version : 1.38.1.5/13815 1408/8460 insecure  [A:1:3832137738:19441] 
udp/ip  : 192.168.1.20:27015
os      :  Windows
type    :  listen
map     : de_dust2 at: 384 x, 2504 y, -55 z
connected to loopback
players : 1 humans, 9 bots (20/0 max) (not hibernating)
__________________
Do not Private Message @me

Last edited by Bacardi; 01-25-2022 at 23:27.
Bacardi is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 22:47.


Powered by vBulletin®
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Theme made by Freecode