Raised This Month: $115 Target: $400
 28% 

[EXTENSION] Left 4 Downtown 2 (0.5.4.2) - L4D2 Only, Updated Left4Downtown


Post New Thread Reply   
 
Thread Tools Display Modes
Randons Gamers
Junior Member
Join Date: Feb 2014
Old 07-25-2019 , 12:36   Re: [EXTENSION] Left 4 Downtown 2 (0.5.4.2) - L4D2 Only, Updated Left4Downtown
Reply With Quote #1041

Quote:
Originally Posted by xerox8521 View Post
THX
Randons Gamers is offline
paul92
Senior Member
Join Date: Sep 2010
Old 08-25-2019 , 11:24   Re: [EXTENSION] Left 4 Downtown 2 (0.5.4.2) - L4D2 Only, Updated Left4Downtown
Reply With Quote #1042

So i got a question... I see there are many versions on different githubs.

I'm using accelerator one now (https://github.com/Accelerator74/Left4Downtown2), but the question i have is: do these versions include the playerslot or not?

In the Original OP there was a choice, but i see no mention of it in these githubs. Just asking to understand if i need l4dtoolz to increase the slots or it's already included in these latest versions.

l4d_maxplayers doesn't exist as a convar in these latest versions, for instance.

EDIT: I'm on Left 4 dead 2, just to be precise.
Also if you are able to tell me which version is the latest and more stable I'd really appreciate that.

Asking because i'm getting multiple crashes with the version i downloaded of left4downtown. Using Accelerator crash site i can see it's something that others are experiencing too.

Sharing here some crashes hoping it can help out. Note that even running only metamod, sourcemod, left4downtown2 will still cause crashes. So it's definitely left4downtown2.

https://crash.limetech.org/57c6ngdl5out
https://crash.limetech.org/yombytepkdh7

Last edited by paul92; 08-25-2019 at 12:00. Reason: Adding infos
paul92 is offline
nubz4lif
Junior Member
Join Date: Aug 2019
Old 08-25-2019 , 12:47   Re: [EXTENSION] Left 4 Downtown 2 (0.5.4.2) - L4D2 Only, Updated Left4Downtown
Reply With Quote #1043

Quote:
Originally Posted by paul92 View Post
So i got a question... I see there are many versions on different githubs.

I'm using accelerator one now (https://github.com/Accelerator74/Left4Downtown2), but the question i have is: do these versions include the playerslot or not?

In the Original OP there was a choice, but i see no mention of it in these githubs. Just asking to understand if i need l4dtoolz to increase the slots or it's already included in these latest versions.

l4d_maxplayers doesn't exist as a convar in these latest versions, for instance.

EDIT: I'm on Left 4 dead 2, just to be precise.
Also if you are able to tell me which version is the latest and more stable I'd really appreciate that.

Asking because i'm getting multiple crashes with the version i downloaded of left4downtown. Using Accelerator crash site i can see it's something that others are experiencing too.

Sharing here some crashes hoping it can help out. Note that even running only metamod, sourcemod, left4downtown2 will still cause crashes. So it's definitely left4downtown2.

https://crash.limetech.org/57c6ngdl5out
https://crash.limetech.org/yombytepkdh7
I am also getting the same crash on L4D2, along with me just getting a different one while typing this and it seems to be random, it happens with both Accelerator74's and Spirit_12's

https://crash.limetech.org/SQMJYKCZLXBG
https://crash.limetech.org/IYEGMZVJHWAL
nubz4lif is offline
Accelerator74
AlliedModders Donor
Join Date: Dec 2010
Location: Russia
Old 08-25-2019 , 13:09   Re: [EXTENSION] Left 4 Downtown 2 (0.5.4.2) - L4D2 Only, Updated Left4Downtown
Reply With Quote #1044

What function does the crash occur on?

P.S.: nobody guarantees stability on windows
__________________
Accelerator74 is offline
Send a message via ICQ to Accelerator74
paul92
Senior Member
Join Date: Sep 2010
Old 08-25-2019 , 13:20   Re: [EXTENSION] Left 4 Downtown 2 (0.5.4.2) - L4D2 Only, Updated Left4Downtown
Reply With Quote #1045

Quote:
Originally Posted by Accelerator74 View Post
What function does the crash occur on?

P.S.: nobody guarantees stability on windows
How/where can i check that?
paul92 is offline
Accelerator74
AlliedModders Donor
Join Date: Dec 2010
Location: Russia
Old 08-25-2019 , 14:22   Re: [EXTENSION] Left 4 Downtown 2 (0.5.4.2) - L4D2 Only, Updated Left4Downtown
Reply With Quote #1046

Iterate over all plugins that use this extension. Find the failed plugin and attach it here.

P.S.: Version with playerslots is not supported! Use l4dtoolz.
__________________

Last edited by Accelerator74; 08-25-2019 at 14:23.
Accelerator74 is offline
Send a message via ICQ to Accelerator74
paul92
Senior Member
Join Date: Sep 2010
Old 08-25-2019 , 14:52   Re: [EXTENSION] Left 4 Downtown 2 (0.5.4.2) - L4D2 Only, Updated Left4Downtown
Reply With Quote #1047

Oh well, i'm only using 2 plugins lol, so it shouldn't be a problem at all.

Actually both plugins crash it. I tried playing using each one by themselves, and the result is the same... I thought it was left4downtown2 by itself. I'm going to try to play using only left4downtown2 without plugins.

Here the 2 plugins by the way:

1) https://forums.alliedmods.net/showthread.php?t=195037
(Specifically this version posted on the thread: https://forums.alliedmods.net/showpo...5&postcount=39)


2) https://forums.alliedmods.net/showthread.php?t=142216

Here another crashlog: https://crash.limetech.org/coxbrllkwsy6

Last edited by paul92; 08-25-2019 at 17:48.
paul92 is offline
paul92
Senior Member
Join Date: Sep 2010
Old 08-25-2019 , 17:42   Re: [EXTENSION] Left 4 Downtown 2 (0.5.4.2) - L4D2 Only, Updated Left4Downtown
Reply With Quote #1048

By the way i can confirm that even without plugins (just metamod 1.11 - build 1127, sourcemod 1.9 - build 6281, and left4downtown2 from Accelerator74) it crashes. It's not as often as when i used one of the listed plugins, but it still does.

Actually to be extra accurate i'm still using the defaults plugins shipped with sourcemod... But noone of these rely on Left4downtown2.
Just to be complete i'm going to list them here:

01 "Admin File Reader" (1.9.0.6281) by AlliedModders LLC
02 "Admin Help" (1.9.0.6281) by AlliedModders LLC
03 "Admin Menu" (1.9.0.6281) by AlliedModders LLC
04 "Anti-Flood" (1.9.0.6281) by AlliedModders LLC
05 "Basic Ban Commands" (1.9.0.6281) by AlliedModders LLC
06 "Basic Chat" (1.9.0.6281) by AlliedModders LLC
07 "Basic Comm Control" (1.9.0.6281) by AlliedModders LLC
08 "Basic Commands" (1.9.0.6281) by AlliedModders LLC
09 "Basic Info Triggers" (1.9.0.6281) by AlliedModders LLC
10 "Basic Votes" (1.9.0.6281) by AlliedModders LLC
11 "Client Preferences" (1.9.0.6281) by AlliedModders LLC
12 "Fun Commands" (1.9.0.6281) by AlliedModders LLC
13 "Fun Votes" (1.9.0.6281) by AlliedModders LLC
14 Disabled: "Nextmap" (1.9.0.6281) by AlliedModders LLC
15 "Player Commands" (1.9.0.6281) by AlliedModders LLC
16 "Reserved Slots" (1.9.0.6281) by AlliedModders LLC
17 "Sound Commands" (1.9.0.6281) by AlliedModders LLC


I'll post here the accelerator crashlog that i got. I didn't use any plugins that required Left4Downtown2.
https://crash.limetech.org/nh2buucmsuja

I see many others are crashing with the same crashlog. All started around last week of July. Interesting enough the 24th of July there was a Left 4 dead 2 Update. Don't know if that has anything to do with it.

Last edited by paul92; 08-25-2019 at 17:51. Reason: Extra infos
paul92 is offline
nubz4lif
Junior Member
Join Date: Aug 2019
Old 08-25-2019 , 17:49   Re: [EXTENSION] Left 4 Downtown 2 (0.5.4.2) - L4D2 Only, Updated Left4Downtown
Reply With Quote #1049

Quote:
Originally Posted by Accelerator74 View Post
Iterate over all plugins that use this extension. Find the failed plugin and attach it here.

P.S.: Version with playerslots is not supported! Use l4dtoolz.
I did some testing, I removed all plugins but 2 and made sure the extension was loaded and it did not crash, I added one plugin that used it and it instantly crashed.

https://crash.limetech.org/re2kghw6347h

https://forums.alliedmods.net/showthread.php?p=2511824

This may be the plugins fault and not the extensions though, or I could just be dumb and be installing the extension wrong which is also possible.
nubz4lif is offline
paul92
Senior Member
Join Date: Sep 2010
Old 08-25-2019 , 18:27   Re: [EXTENSION] Left 4 Downtown 2 (0.5.4.2) - L4D2 Only, Updated Left4Downtown
Reply With Quote #1050

Quote:
Originally Posted by nubz4lif View Post
I did some testing, I removed all plugins but 2 and made sure the extension was loaded and it did not crash, I added one plugin that used it and it instantly crashed.

https://crash.limetech.org/re2kghw6347h

https://forums.alliedmods.net/showthread.php?p=2511824

This may be the plugins fault and not the extensions though, or I could just be dumb and be installing the extension wrong which is also possible.
Interesting. In my case it did crash after almost an hour of playtime. How long did you play to see if it crashes without plugins?

Also can you list which left4downtown2, metamod and sourcemod versions are you using? Maybe they're more stable than mines. Is your server also on Windows?
paul92 is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 21:56.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode