Raised This Month: $77 Target: $400
 19% 

[ANY] ServerAdvertisement3 - MultiLang | *UPDATED 16.02.2019* | *VERSION 3.1.3a


Post New Thread Reply   
 
Thread Tools Display Modes
ANDREL0
Junior Member
Join Date: Apr 2007
Location: Argentina
Old 02-18-2019 , 18:35   Re: [ANY] ServerAdvertisement3 - MultiLang | *UPDATED 16.02.2019* | *VERSION 3.1.3a
Reply With Quote #721

Quote:
Originally Posted by ESK0 View Post
[*]Hud messages - Type: H. / R G B color
Hello! , thanks for this excellent plugin. How could I change the message size for this type?

"5" // HUD MESSAGE
{
"enabled" "1"
"maps" "de_"
"en" "TEXT TEXT TEXT "
"type" "h"
"color" "255 112 0" // RGB (R G B)
"color2" "255 255 51" // RGB (R G B)
"effect" "2" // 0,1,2
"channel" "5" // Any number
"posx" "-1.0" //left to right
"posy" "0.05" //top to bottom
"fadein" "0.2" //Fade in time
"fadeout" "0.3" //Fade out time
"holdtime" "8.0" //Message hold time
}
ANDREL0 is offline
ESK0
Veteran Member
Join Date: May 2014
Location: Czech Republic
Old 02-19-2019 , 00:56   Re: [ANY] ServerAdvertisement3 - MultiLang | *UPDATED 16.02.2019* | *VERSION 3.1.3a
Reply With Quote #722

Quote:
Originally Posted by ANDREL0 View Post
Hello! , thanks for this excellent plugin. How could I change the message size for this type?

"5" // HUD MESSAGE
{
"enabled" "1"
"maps" "de_"
"en" "TEXT TEXT TEXT "
"type" "h"
"color" "255 112 0" // RGB (R G B)
"color2" "255 255 51" // RGB (R G B)
"effect" "2" // 0,1,2
"channel" "5" // Any number
"posx" "-1.0" //left to right
"posy" "0.05" //top to bottom
"fadein" "0.2" //Fade in time
"fadeout" "0.3" //Fade out time
"holdtime" "8.0" //Message hold time
}
You cant change text size.
__________________
Feel free to add me for private plugins My steam profile.
ESK0 is offline
pAC2k
New Member
Join Date: Oct 2018
Old 03-02-2019 , 19:25   Re: [ANY] ServerAdvertisement3 - MultiLang | *UPDATED 16.02.2019* | *VERSION 3.1.3a
Reply With Quote #723

I have issue, heres full error
[SM] Exception reported: [SA3] Unable to find Settings in addons/sourcemod/configs/ServerAdvertisements3.cfg
L 01/20/2019 - 18:58:57: [SM] Blaming: ServerAdvertisements3.smx
L 01/20/2019 - 18:58:57: [SM] Call stack trace:
L 01/20/2019 - 18:58:57: [SM] [0] SetFailState
L 01/20/2019 - 18:58:57: [SM] [1] Line 373, D:\Sourcemod\ServerAdvertisements3\ServerAdve rtisements3.sp::LoadConfig
L 01/20/2019 - 18:58:57: [SM] [2] Line 61, D:\Sourcemod\ServerAdvertisements3\ServerAdve rtisements3.sp::OnMapStart

Down below cfg, I literally checked every single line and nothing, adv doesnt work...
Attached Files
File Type: cfg ServerAdvertisements3.cfg (5.6 KB, 47 views)
pAC2k is offline
ESK0
Veteran Member
Join Date: May 2014
Location: Czech Republic
Old 03-03-2019 , 07:27   Re: [ANY] ServerAdvertisement3 - MultiLang | *UPDATED 16.02.2019* | *VERSION 3.1.3a
Reply With Quote #724

Quote:
Originally Posted by pAC2k View Post
I have issue, heres full error
[SM] Exception reported: [SA3] Unable to find Settings in addons/sourcemod/configs/ServerAdvertisements3.cfg
L 01/20/2019 - 18:58:57: [SM] Blaming: ServerAdvertisements3.smx
L 01/20/2019 - 18:58:57: [SM] Call stack trace:
L 01/20/2019 - 18:58:57: [SM] [0] SetFailState
L 01/20/2019 - 18:58:57: [SM] [1] Line 373, D:\Sourcemod\ServerAdvertisements3\ServerAdve rtisements3.sp::LoadConfig
L 01/20/2019 - 18:58:57: [SM] [2] Line 61, D:\Sourcemod\ServerAdvertisements3\ServerAdve rtisements3.sp::OnMapStart

Down below cfg, I literally checked every single line and nothing, adv doesnt work...
Wrong text encoding.. You should save config in UTF-8 without BOM
Attached Files
File Type: cfg ServerAdvertisements3.cfg (5.6 KB, 50 views)
__________________
Feel free to add me for private plugins My steam profile.
ESK0 is offline
YenFong
Junior Member
Join Date: Feb 2019
Old 04-05-2019 , 10:16   Re: [ANY] ServerAdvertisement3 - MultiLang | *UPDATED 16.02.2019* | *VERSION 3.1.3a
Reply With Quote #725

cant reload message
YenFong is offline
headhunterzcph
Member
Join Date: Nov 2012
Old 04-19-2019 , 05:11   Re: [ANY] ServerAdvertisement3 - MultiLang | *UPDATED 16.02.2019* | *VERSION 3.1.3a
Reply With Quote #726

is there anyone who can help me
with make me code
https://gyazo.com/9d34b57a4e0acaecb27090644b92fa32
headhunterzcph is offline
Nerus
Senior Member
Join Date: Aug 2010
Location: Poland
Old 05-04-2019 , 13:38   Re: [ANY] ServerAdvertisement3 - MultiLang | *UPDATED 16.02.2019* | *VERSION 3.1.3a
Reply With Quote #727

@ESK0 could you please provide this plugin with newest SteamWorks exts?

Quote:
./compile.sh ServerAdvertisements3.sp

Compiling ServerAdvertisements3.sp...
SourcePawn Compiler 1.9.0.6280
Copyright (c) 1997-2006 ITB CompuPhase
Copyright (c) 2004-2017 AlliedModders LLC

files/misc.sp(462) : error 017: undefined symbol "hHTTPRequest"
files/misc.sp(462) : error 115: cannot use delete, type ::ft:hHTTPRequest:110352:110352 has no destructor
files/misc.sp(464) : error 139: could not find type "EHTTPStatusCode"
files/misc.sp(472) : error 017: undefined symbol "SteamWorks_GetHTTPResponseBodySize"
files/misc.sp(47 : error 017: undefined symbol "SteamWorks_GetHTTPResponseBodyData"
Problem solved: needs to change name of steamworks include file to new one in main plugin file in line 8.
Quote:
#tryinclude <SteamWorks>

Last edited by Nerus; 05-04-2019 at 13:55.
Nerus is offline
YenFong
Junior Member
Join Date: Feb 2019
Old 05-05-2019 , 10:35   Re: [ANY] ServerAdvertisement3 - MultiLang | *UPDATED 16.02.2019* | *VERSION 3.1.3a
Reply With Quote #728

After giving someone flag a but on the message the vip online wont show up the guy i give flag a
YenFong is offline
painlesstgp
Junior Member
Join Date: May 2019
Old 06-07-2019 , 13:55   ServerAdvertisements3
Reply With Quote #729

Hello, recently my serveradvertisements3 plugin stopped to load idk why, but it says this when i do sm plugins list in console:

Errors:
ServerAdvertisements3.smx (ServerAdvertisements3): [SA3] 'EN' translation missing in message "4"
painlesstgp is offline
NomisCZ
AlliedModders Donor
Join Date: Mar 2014
Location: $this->Czech_Republic
Old 06-07-2019 , 14:32   Re: ServerAdvertisements3
Reply With Quote #730

Hi,
you probably forgot to add 'en' to your message.

PHP Code:
  "Settings"
  
{
    ...
    
"Languages"  "EN;CZ" <-- first language key EN is required in all messages
    
...
  }
 
"Messages"
  
{
    
"1"
    
{
     ...
      
"en" "Message in English ..." <-- this is required, if you have EN language as main language
      
"cz" "Message in Czech ..."
     
...
    }
    ...
}
... 
__________________



Steam: NomisCZ
NomisCZ is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 21:01.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Theme made by Freecode