Raised This Month: $13 Target: $400
 3% 

get_user_team is not fixed yet!


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
GasmoN
Member
Join Date: Jul 2014
Old 12-18-2018 , 18:55   get_user_team is not fixed yet!
Reply With Quote #1

So, I saw in this post that allegedly this bug is fixed, but when I tested it with latest 1.8.2 (stable) version of amx mod x today, that native (get_user_team) returns wrong team id in few cases. So I reported that in bugs section -> https://bugs.alliedmods.net/show_bug.cgi?id=6635 and I hope it will be fixed soon.
The only solution I found so far is that this plugin can fix that problem (I tested it - I put plugin name below admin.amxx in plugins.ini) but it would be great if amxx dev team make a small update and fix this.
GasmoN is offline
OciXCrom
Veteran Member
Join Date: Oct 2013
Location: Macedonia
Old 12-19-2018 , 07:02   Re: get_user_team is not fixed yet!
Reply With Quote #2

You should test with the latest 1.9, not with 1.8.2. Most bugs have already been fixed in 1.9. If this one's fixed too, there's no point in reporting it, so test with 1.9 first.
__________________
OciXCrom is offline
Send a message via Skype™ to OciXCrom
rtxa
Member
Join Date: Mar 2018
Location: Argentina
Old 12-19-2018 , 18:01   Re: get_user_team is not fixed yet!
Reply With Quote #3

Quote:
Originally Posted by OciXCrom View Post
You should test with the latest 1.9, not with 1.8.2. Most bugs have already been fixed in 1.9. If this one's fixed too, there's no point in reporting it, so test with 1.9 first.
Not fixed, at least in Half-Life. I'm not sure how amx mod x gets user team, but the correct way is getting it from m_szTeamName or from model userinfo. Of course, this issue affects get_players setted with team flag.

Last edited by rtxa; 12-19-2018 at 18:03.
rtxa is offline
fysiks
Veteran Member
Join Date: Sep 2007
Location: Flatland, USA
Old 12-19-2018 , 20:35   Re: get_user_team is not fixed yet!
Reply With Quote #4

If after you have tested 1.9 and you still see the issue, you should submit the bug on GitHub here.
__________________
fysiks is offline
GasmoN
Member
Join Date: Jul 2014
Old 12-20-2018 , 06:21   Re: get_user_team is not fixed yet!
Reply With Quote #5

Well, why not fix it in 1.8.2 since it's latest stable version? I mean, they already tried to fix it in 1.8.2 so why not fix there first? Lot of server owners (Including me) still want to use stable version of amx mod x instead of Dev releases. One of the lot of reasons is that in 1.9 there will be way more problems with back compatibility so it would all come down to fixing new bugs. Instead of all that, they can just fix this one and we can continue to run our servers in peace.
I like new amx mod x version, and I can't wait for it's stable version. but until then I am happy with 1.8.2 since I have servers for years with that version and this is the only bug that started to bothering me so far.
GasmoN is offline
OciXCrom
Veteran Member
Join Date: Oct 2013
Location: Macedonia
Old 12-20-2018 , 08:43   Re: get_user_team is not fixed yet!
Reply With Quote #6

Quote:
Originally Posted by GasmoN View Post
Well, why not fix it in 1.8.2 since it's latest stable version? I mean, they already tried to fix it in 1.8.2 so why not fix there first? Lot of server owners (Including me) still want to use stable version of amx mod x instead of Dev releases. One of the lot of reasons is that in 1.9 there will be way more problems with back compatibility so it would all come down to fixing new bugs. Instead of all that, they can just fix this one and we can continue to run our servers in peace.
I like new amx mod x version, and I can't wait for it's stable version. but until then I am happy with 1.8.2 since I have servers for years with that version and this is the only bug that started to bothering me so far.
1.8.2 is no longer supported for updates. The next version is 1.9 and all current bugs will be fixed there. There's no point in releasing a new 1.8.2 version when 1.9 is almost done, especially for just one simple thing like this.
__________________
OciXCrom is offline
Send a message via Skype™ to OciXCrom
rtxa
Member
Join Date: Mar 2018
Location: Argentina
Old 12-20-2018 , 12:39   Re: get_user_team is not fixed yet!
Reply With Quote #7

Quote:
Originally Posted by GasmoN View Post
Well, why not fix it in 1.8.2 since it's latest stable version? I mean, they already tried to fix it in 1.8.2 so why not fix there first? Lot of server owners (Including me) still want to use stable version of amx mod x instead of Dev releases. One of the lot of reasons is that in 1.9 there will be way more problems with back compatibility so it would all come down to fixing new bugs. Instead of all that, they can just fix this one and we can continue to run our servers in peace.
I like new amx mod x version, and I can't wait for it's stable version. but until then I am happy with 1.8.2 since I have servers for years with that version and this is the only bug that started to bothering me so far.
Not true, 1.9 is almost done and it doesn't break compatibility, check release notes.
Quote:
AMX Mod X 1.9 is a major update, containing many features, fixes, and improvements under the hood.

✓ All old plugins and modules will continue to work.
✓ This release does have new configuration files.
✓ This release does have configuration changes.
✓ This release does include plugin changes.
✓ This release does have translations changes.
✓ This release does not break compatibility.
Anyway, that bug you are mentioning has not been fixed yet.
rtxa is offline
fysiks
Veteran Member
Join Date: Sep 2007
Location: Flatland, USA
Old 12-20-2018 , 22:26   Re: get_user_team is not fixed yet!
Reply With Quote #8

Quote:
Originally Posted by GasmoN View Post
Well, why not fix it in 1.8.2 since it's latest stable version?
By definition, fixing something in version 1.8.2 makes it not version 1.8.2 anymore (and not officially stable until extensive testing is done). Hence why 1.9 exists.
__________________
fysiks is offline
GasmoN
Member
Join Date: Jul 2014
Old 12-21-2018 , 08:16   Re: get_user_team is not fixed yet!
Reply With Quote #9

Quote:
Originally Posted by fysiks View Post
By definition, fixing something in version 1.8.2 makes it not version 1.8.2 anymore (and not officially stable until extensive testing is done). Hence why 1.9 exists.
Well, you are right about that haha
If this is true what rtxa sad, the I guess we (server owners) can be patient untill stable release of 1.9 version is published.
GasmoN is offline
Natsheh
Veteran Member
Join Date: Sep 2012
Location: Muslim and proud!
Old 10-14-2019 , 09:45   Re: get_user_team is not fixed yet!
Reply With Quote #10

sorry for bumping this, but this bug still not fixed in 1.9 get_players & get_user_team still return the previous team id until the player/user spawns
__________________
@Jailbreak MOD [Alot of features + API] 100% done !
@User Tag Prefix 100% done !
@Mystery Box 100% done !
@VIP System 100% done !
Natsheh is offline
Send a message via MSN to Natsheh Send a message via Skype™ to Natsheh
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 20:39.


Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Theme made by Freecode