Raised This Month: $23 Target: $400
 5% 

Server keeps crashing on startup only when metamod is enabled


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
The_Expert
Junior Member
Join Date: Nov 2011
Old 04-28-2012 , 06:38   Server keeps crashing on startup only when metamod is enabled
Reply With Quote #1

I'm using the latest version of sourcemod and metamod. I even did a completely clean install of tf2, SM and MM with no additional plugins. It worked fine before I installed metamod, but now it crashes almost instantly after starting up the server, and of course the dump files are no help at all.
This is a windows server.

Any ideas?
The_Expert is offline
Bacardi
Veteran Member
Join Date: Jan 2010
Location: mom's basement
Old 04-28-2012 , 08:23   Re: Server keeps crashing on startup only when metamod is enabled
Reply With Quote #2

If you installed both MM:S and SM on your server, MetaMod:Source will run SourceMod.
I don't see any "only metamod" at this part.

Week ago they where Valve update what stop SM working in some mods.
SM will automatically update new gamedata files but server need to be up.

Try this, go SourceMod plugins folder and create "New folder".
Drag and drop all plugins.smx in that "New folder", then move that "New folder" in plugins/disabled folder.
So you not run any SourceMod plugins when server start, to prevent crash.

*reboot (run mm:s and sm)
Wait will SourceMod start update files (You see message in SM logs).

If not, then download Sourcemod newest snapshot.
Pick gamedata-folder from zip and replace yours from server.

After reboots move your Sourcemod plugins back

Last edited by Bacardi; 04-28-2012 at 08:25.
Bacardi is offline
The_Expert
Junior Member
Join Date: Nov 2011
Old 04-28-2012 , 08:35   Re: Server keeps crashing on startup only when metamod is enabled
Reply With Quote #3

But I've already tried it without any plugins at all. And I installed a clean copy with the newest version of Soucremod and metamod.

Last edited by The_Expert; 04-28-2012 at 08:35.
The_Expert is offline
Bacardi
Veteran Member
Join Date: Jan 2010
Location: mom's basement
Old 04-28-2012 , 09:32   Re: Server keeps crashing on startup only when metamod is enabled
Reply With Quote #4

So it still crash ??
Try only MM:S, remove ...addons/metamod/sourcemod.vdf. (SouceMod would not load.)

What Windows OS you have ?

Last edited by Bacardi; 04-28-2012 at 09:32.
Bacardi is offline
Pexeble
New Member
Join Date: May 2018
Old 06-10-2018 , 17:26   Re: Server keeps crashing on startup only when metamod is enabled
Reply With Quote #5

I got the same thing here. But with insurgency.

Last edited by Pexeble; 06-10-2018 at 17:29.
Pexeble is offline
8guawong
AlliedModders Donor
Join Date: Dec 2013
Location: BlackMarke7
Old 06-11-2018 , 04:52   Re: Server keeps crashing on startup only when metamod is enabled
Reply With Quote #6

Quote:
Originally Posted by Pexeble View Post
I got the same thing here. But with insurgency.
try updating to the latest stable mm & sm if you have not done it yet
__________________
8guawong is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 20:26.


Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Theme made by Freecode