Raised This Month: $13 Target: $400
 3% 

cs bot enabler crash ?


Post New Thread Reply   
 
Thread Tools Display Modes
Neon123
Senior Member
Join Date: Jan 2016
Old 01-05-2019 , 17:21   Re: cs bot enabler crash ?
Reply With Quote #11

i think the problem is windows 7, a friend with windows 10 not having this problem
Neon123 is offline
Arkshine
AMX Mod X Plugin Approver
Join Date: Oct 2005
Old 01-05-2019 , 17:31   Re: cs bot enabler crash ?
Reply With Quote #12

I'm using windows 7, and the module has been developed and tested under this OS (and linux as well).
__________________
Arkshine is offline
mattisbogus
Senior Member
Join Date: Jun 2009
Location: North Carolina, USA
Old 01-05-2019 , 18:17   Re: cs bot enabler crash ?
Reply With Quote #13

Iím using Windows 10 with a fresh install of hlds from steamcmd and when I try this version it crashes as soon as a I tell a bot to connect.

The thing I donít understand is I also tried the version Whistler started. If I take his file, put it in dlls, and then call it to run from liblist, I have no problem with bots joining along side with still being able to use metamod.

Iíll try again tonight with another fresh install and post my settings.
mattisbogus is offline
Arkshine
AMX Mod X Plugin Approver
Join Date: Oct 2005
Old 01-05-2019 , 18:52   Re: cs bot enabler crash ?
Reply With Quote #14

The module has only been tested with a normal server installed with SteamCMD.
If you are using the standard way, it should not have issues. It has been tested.

The code itself is really simple. It's about to hook UTIL_IsCZero function in the game, and returning always true. That's it. Nothing else. It doesn't manage the bots. The only way it could crash is maybe if the signatures to find the function matched something else. But again, I tested it again when Neon123 had issues, and it still worked with the latest game version.

Try a fresh SteamCMD install, install only metamod and this module, and test again. If it crashes, post how you installed the server, how you started it, the game version, etc.
__________________

Last edited by Arkshine; 01-05-2019 at 18:55.
Arkshine is offline
mattisbogus
Senior Member
Join Date: Jun 2009
Location: North Carolina, USA
Old 01-06-2019 , 00:19   Re: cs bot enabler crash ?
Reply With Quote #15

I can't figure it out man. I just did a fresh install from SteamCMD. I only put in metamod 1.20 and csbot_enabler_mm.dll.

running hlds from console I type: bot_join_after_player "0" then
bot_add_t

as soon as I hit enter, console stops, waits about 2-3 seconds, and closes.

Running Windows 10 Pro 64bit

PHP Code:
100.0 fps  0/32 on         de_dust2
Console initialized
.
Protocol version 48
Exe version 1.1.2.7 
(cstrike)
Exe build16:10:04 Aug 10 2018 (7960)
STEAM Auth Server
Server IP address 192.168.1.113
:27015

   Metamod version 1.20  Copyright 
(c2001-2013 Will Day <willday@metamod.org>
   
Metamod comes with ABSOLUTELY NO WARRANTY; for details type `meta gpl'.
   This is free software, and you are welcome to redistribute it
   under certain conditions; type 
`meta gpl' for details.

   CS Bot Enabler v1.0.1
   Status: Loaded.

Navigation map loaded.
couldn'
t exec listip.cfg
couldn
't exec banned.cfg
Connection to Steam servers successful.
   VAC secure mode is activated.
meta list
Currently loaded plugins:
      description      stat pend  file              vers      src  load  unlod
 [ 1] CS Bot Enabler   RUN   -    csbot_enabler_mm  v1.0.1    ini  ANY   ANY
1 plugins, 1 running
meta version
Metamod v1.20  2013-02-16 (5:13)
by Will Day <[email protected]>
   http://www.metamod.org/
compiled: Feb 16 2013, 17:12:42 +0100 (optimized) 
I was also able to catch an error right before console closed:

PHP Code:
\src\tier0\threadtools.cpp (3190) : Assertion FailedIllegal termination of worker thread 'Thread(0x6DAC97F8/0x000005E8/0x' 

Last edited by mattisbogus; 01-06-2019 at 00:28.
mattisbogus is offline
Arkshine
AMX Mod X Plugin Approver
Join Date: Oct 2005
Old 01-06-2019 , 04:45   Re: cs bot enabler crash ?
Reply With Quote #16

Metamod version is outdated. Test with the latest which can be either latest Metamod-p 1.21 or Metamod 1.21-am.
__________________

Last edited by Arkshine; 01-06-2019 at 07:59.
Arkshine is offline
E1_531G
Senior Member
Join Date: Dec 2017
Old 01-06-2019 , 07:38   Re: cs bot enabler crash ?
Reply With Quote #17

Quote:
Originally Posted by Arkshine View Post
Metamod version is outdated. Test with the latest which can be either Metamod-p 1.21p37 or Metamod 1.21-am.
Sorry for off-topic, but i want to know if your comment means that 1.21p38 is bad?
https://github.com/jkivilin/metamod-p/releases
__________________
My English is A0
E1_531G is offline
Arkshine
AMX Mod X Plugin Approver
Join Date: Oct 2005
Old 01-06-2019 , 07:40   Re: cs bot enabler crash ?
Reply With Quote #18

My comment meant he can use either the -p or -am version. It should not matter.
__________________
Arkshine is offline
E1_531G
Senior Member
Join Date: Dec 2017
Old 01-06-2019 , 07:48   Re: cs bot enabler crash ?
Reply With Quote #19

Yeah, but you said "1.21p37" and 1.21p38 is the latest.
__________________
My English is A0
E1_531G is offline
Arkshine
AMX Mod X Plugin Approver
Join Date: Oct 2005
Old 01-06-2019 , 07:59   Re: cs bot enabler crash ?
Reply With Quote #20

Oh right, it should still not matter. p38 is just about enabling SSE optimization.
__________________
Arkshine is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 19:18.


Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Theme made by Freecode