Raised This Month: $106 Target: $400
 26% 

Error: Undefined symbol


Post New Thread Reply   
 
Thread Tools Display Modes
Author Message
Tonybear
Junior Member
Join Date: Jun 2017
Old 08-02-2017 , 07:29   Error: Undefined symbol
Reply With Quote #1

Im trying to run the messagebot extension for calladmin and I'm getting an error.

CentOS 7 minimal libstdc++ and such are installed.

Code:
 ldd -d -r /home/ogp_server/OGP_User_Files/1/tf/addons/sourcemod/extensions/messagebot.ext.so
	linux-gate.so.1 =>  (0xf7757000)
	libm.so.6 => /lib/libm.so.6 (0xf7705000)
	libdl.so.2 => /lib/libdl.so.2 (0xf7700000)
	libc.so.6 => /lib/libc.so.6 (0xf7542000)
	/lib/ld-linux.so.2 (0xf7758000)
undefined symbol: _ZNSt8ios_base4InitC1Ev	(/home/ogp_server/OGP_User_Files/1/tf/addons/sourcemod/extensions/messagebot.ext.so)
undefined symbol: _ZNSt8ios_base4InitD1Ev	(/home/ogp_server/OGP_User_Files/1/tf/addons/sourcemod/extensions/messagebot.ext.so)
undefined symbol: _ZNSt8ios_baseC2Ev	(/home/ogp_server/OGP_User_Files/1/tf/addons/sourcemod/extensions/messagebot.ext.so)
undefined symbol: _ZTTSt18basic_stringstreamIcSt11char_traitsIcESaIcEE	(/home/ogp_server/OGP_User_Files/1/tf/addons/sourcemod/extensions/messagebot.ext.so)
undefined symbol: _ZTVSt9basic_iosIcSt11char_traitsIcEE	(/home/ogp_server/OGP_User_Files/1/tf/addons/sourcemod/extensions/messagebot.ext.so)
undefined symbol: _ZNSt9basic_iosIcSt11char_traitsIcEE4initEPSt15basic_streambufIcS1_E	(/home/ogp_server/OGP_User_Files/1/tf/addons/sourcemod/extensions/messagebot.ext.so)
undefined symbol: _ZTVSt18basic_stringstreamIcSt11char_traitsIcESaIcEE	(/home/ogp_server/OGP_User_Files/1/tf/addons/sourcemod/extensions/messagebot.ext.so)
undefined symbol: _ZTVSt15basic_streambufIcSt11char_traitsIcEE	(/home/ogp_server/OGP_User_Files/1/tf/addons/sourcemod/extensions/messagebot.ext.so)
undefined symbol: _ZNSt6localeC1Ev	(/home/ogp_server/OGP_User_Files/1/tf/addons/sourcemod/extensions/messagebot.ext.so)
undefined symbol: _ZTVSt15basic_stringbufIcSt11char_traitsIcESaIcEE	(/home/ogp_server/OGP_User_Files/1/tf/addons/sourcemod/extensions/messagebot.ext.so)
undefined symbol: _ZNSs4_Rep20_S_empty_rep_storageE	(/home/ogp_server/OGP_User_Files/1/tf/addons/sourcemod/extensions/messagebot.ext.so)
undefined symbol: _ZStlsISt11char_traitsIcEERSt13basic_ostreamIcT_ES5_PKc	(/home/ogp_server/OGP_User_Files/1/tf/addons/sourcemod/extensions/messagebot.ext.so)
undefined symbol: _ZNSi10_M_extractIyEERSiRT_	(/home/ogp_server/OGP_User_Files/1/tf/addons/sourcemod/extensions/messagebot.ext.so)
undefined symbol: _ZNSt18basic_stringstreamIcSt11char_traitsIcESaIcEED1Ev	(/home/ogp_server/OGP_User_Files/1/tf/addons/sourcemod/extensions/messagebot.ext.so)
Someone send help ;w;
Tonybear is offline
asherkin
SourceMod Developer
Join Date: Aug 2009
Location: OnGameFrame()
Old 08-02-2017 , 07:51   Re: Error: Undefined symbol
Reply With Quote #2

The extension is using libstdc++ but you are not linking to it.
__________________
asherkin is offline
Spirit_12
Veteran Member
Join Date: Dec 2012
Location: Toronto, CA
Old 08-02-2017 , 07:54   Re: Error: Undefined symbol
Reply With Quote #3

Recompile the extension on your system. It seems to be linking against wrong libraries.
__________________
Spirit_12 is offline
Tonybear
Junior Member
Join Date: Jun 2017
Old 08-02-2017 , 17:23   Re: Error: Undefined symbol
Reply With Quote #4

Quote:
Originally Posted by asherkin View Post
The extension is using libstdc++ but you are not linking to it.
As yes, this is what happened on my other linux machine in Berlin. Is there a ln command syntax to link to libstdc++? I can't remember how I did it last time.
Tonybear is offline
blacklagoon
Senior Member
Join Date: Jun 2012
Old 08-02-2017 , 17:59   Re: Error: Undefined symbol
Reply With Quote #5

https://github.com/popoklopsi/MessageBot#how-to-build
i believe the makefile links it no? edit no : you can link it using this with g++ now i believe -static-libstdc++

Last edited by blacklagoon; 08-02-2017 at 18:08.
blacklagoon is offline
Tonybear
Junior Member
Join Date: Jun 2017
Old 08-02-2017 , 19:49   Re: Error: Undefined symbol
Reply With Quote #6

I compiled it against sourcemod via git clone --recursive https://github.com/alliedmodders/sourcemod.git but now it says:
Code:
Failed to load messagebot.ext.so :: Could not find interface: IForwardManager
Even after updating to the latest development build of sourcemod.

Last edited by Tonybear; 08-02-2017 at 19:49. Reason: typed clove instead of clone
Tonybear is offline
Spirit_12
Veteran Member
Join Date: Dec 2012
Location: Toronto, CA
Old 08-02-2017 , 21:26   Re: Error: Undefined symbol
Reply With Quote #7

What version of sourcemod are you running on your server?
__________________

Last edited by Spirit_12; 08-02-2017 at 21:26.
Spirit_12 is offline
blacklagoon
Senior Member
Join Date: Jun 2012
Old 08-02-2017 , 22:03   Re: Error: Undefined symbol
Reply With Quote #8

Quote:
Originally Posted by Spirit_12 View Post
What version of sourcemod are you running on your server?
Yes i believe he needs 1.7 at least (not sure) couldn't find an history but as he is using 1.8 to compile, to be in the safe side he might upgrade to the stable build

Last edited by blacklagoon; 08-02-2017 at 22:07.
blacklagoon is offline
Tonybear
Junior Member
Join Date: Jun 2017
Old 08-03-2017 , 21:02   Re: Error: Undefined symbol
Reply With Quote #9

Right now? I'm running the latest dev build of 1.8 for linux, was using 1.8 stable then updated to the latest snapshot.

EDIT: OH CRAP... Just realized the dev builds are actually 1.9.. woops. Going to try again with the latest stable 1.8. Will update if it works.

Edit Edit: Nevermind, still hasnt fixed it. || Could not find interface: IForwardManager

Last edited by Tonybear; 08-03-2017 at 21:10.
Tonybear is offline
WildCard65
Veteran Member
Join Date: Aug 2013
Location: Canada
Old 08-03-2017 , 21:32   Re: Error: Undefined symbol
Reply With Quote #10

What is the value of the following define?
SMINTERFACE_FORWARDMANAGER_VERSION (Link is for example + where to find)
__________________

Last edited by WildCard65; 08-03-2017 at 21:34.
WildCard65 is offline
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 22:49.


Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Theme made by Freecode